Subject: [core] Roman Danyliw's No Objection on draft-ietf-core-new-block-11: (with COMMENT)

From: Roman Danyliw via Datatracker <[email-masked]>
Date: Wed, 05 May 2021 12:17:52 -0700

Roman Danyliw has entered the following ballot position for
draft-ietf-core-new-block-11: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-core-new-block/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

** Section 3.2 and Section 11
(a) Section 3.2. It is not recommended that these options are used in a NoSec
security mode

(b) Section 11. It is NOT RECOMMENDED that the NoSec security mode is
   used if the Q-Block1 and Q-Block2 Options are to be used.

I believe that the intend of (a) and (b) is to caution against using NoSec mode
with either Q-Block1 or 2.  One read of (b) would be that this guidance is only
about when both options are used together (e.g., the language of Section 4.7). 
I recommend restating (b) to be more along the lines of:

Therefore, it is NOT RECOMMENDED to use the NoSec security mode if either the
Q-Block1 or Q-Block2 Options is used.

** Section 4.1.  Colloquialism. s/local configuration knob/local configuration
option/

** Section 4.4.

(a)   If the server detects part way through a body transfer that the
   resource data has changed and the server is not maintaining a cached
   copy of the old data, then the transmission is terminated.  Any
   subsequent missing block requests MUST be responded to using the
   latest ETag and Size2 Option values with the updated data.

...

(b) If the server transmits a new body of data (e.g., a triggered Observe
   notification) with a new ETag to the same client as an additional
   response, the client should remove any partially received body held
   for a previous ETag for that resource as it is unlikely the missing
   blocks can be retrieved.

(1) Is (a) suggesting that the missing block requests would be serviced from a
copy of the “resource data that has changed”?  This would mean that the client
would get an inconsistent version of the resource which is neither the old or
new version.

(2) (b) seems like it is noting that the partially received body should in fact
be discarded to avoid the situation in (1).  However, how does the client get
the initial, now discarded blocks?  I’m not sure where that transmission
shouldn’t fail with an error as I don’t follow how recover is possible.

---

From: <[email-masked]>
Date: Thu, 6 May 2021 06:12:44 +0000

Hi Roman, 

Thank you for the review. 

Please see inline. 

Cheers,
Med

> -----Message d'origine-----
> De : Roman Danyliw via Datatracker [mailto:[email-masked]]
> Envoyé : mercredi 5 mai 2021 21:18
> À : The IESG <[email-masked]>
> Cc : [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Objet : Roman Danyliw's No Objection on draft-ietf-core-new-block-11:
> (with COMMENT)
> 
> email addresses included in the To and CC lines. (Feel free to cut
> this introductory paragraph, however.)
> 
> 
> (a) Section 3.2. It is not recommended that these options are used in
> a NoSec security mode
> 
> I believe that the intend of (a) and (b) is to caution against using
> NoSec mode with either Q-Block1 or 2.  One read of (b) would be that
> this guidance is only about when both options are used together
> (e.g., the language of Section 4.7).

[Med] ACK.

> 
> ** Section 4.1.  Colloquialism. s/local configuration knob/local
> configuration option/
> 

[Med] Changed it to "local configuration parameter".

> (1) Is (a) suggesting that the missing block requests would be
> serviced from a copy of the “resource data that has changed”?  This
> would mean that the client would get an inconsistent version of the
> resource which is neither the old or new version.

[Med] The client will detect that as per the text right after the one you quoted: 

   If the server responds during a body update with a different ETag
                          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   Option value (as the resource representation has changed), then the
   client should treat the partial body with the old ETag as no longer
                                                 ^^^^^^^^^^^^^^^^^^^^^^            
   being fresh.
   ^^^^^^^^^^^^  

The client can then get the new version. It can't get the old one as the server does not cache it. 

> 
> (2) (b) seems like it is noting that the partially received body
> should in fact be discarded to avoid the situation in (1).  However,
> how does the client get the initial, now discarded blocks?  I’m not
> sure where that transmission shouldn’t fail with an error as I don’t
> follow how recover is possible.
> 

[Med] This is not an error given that the client is getting the new resource representation as maintained by the server. The old one is obsolete if you will. 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Roman Danyliw <[email-masked]>
Date: Thu, 6 May 2021 13:47:27 +0000

Hi Med!

> -----Original Message-----
> From: iesg <[email-masked]> On Behalf Of
> [email-masked]
> Sent: Thursday, May 6, 2021 2:13 AM
> To: Roman Danyliw <[email-masked]>; The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: Roman Danyliw's No Objection on draft-ietf-core-new-block-11:
> (with COMMENT)
> 
> Hi Roman,
> 
> > De : Roman Danyliw via Datatracker [mailto:[email-masked]] Envoyé :
> > mercredi 5 mai 2021 21:18 À : The IESG <[email-masked]> Cc :
> > [email-masked]; [email-masked];
> > [email-masked]; [email-masked]; [email-masked] Objet : Roman
> > Danyliw's No Objection on draft-ietf-core-new-block-11:
> > (with COMMENT)
> >
> > this guidance is only about when both options are used together (e.g.,
> > the language of Section 4.7).

Thanks for these changes.

> [Med] This is not an error given that the client is getting the new resource
> representation as maintained by the server. The old one is obsolete if you will.

Got it.  Thanks for explaining it.

Roman

> 
> ___________________________________________________________________
> ______________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou
> copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le
> signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration, Orange decline toute
> responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged
> information that may be protected by law; they should not be distributed, used
> or copied without authorisation.