Subject: Re: [core] Martin Duke's No Objection on draft-ietf-core-senml-versions-03: (with COMMENT)

From: Carsten Bormann <[email-masked]>
Date: Thu, 3 Jun 2021 22:11:54 +0200

On 2021-05-26, at 17:33, Martin Duke via Datatracker <[email-masked]> wrote:
> 
> Martin Duke has entered the following ballot position for
> draft-ietf-core-senml-versions-03: No Objection
> 
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> Given the very constrained space, I wonder if it's wise to reserve 0 and 2 for
> no real purpose. IIUC these would still result in version numbers > 10 and
> therefore not break anything, yes?

Hi Martin,

The cop-out (end of Section 3) is:

   These four reserved feature codes are not to be used with any
   more specific semantics except in a specification that updates the
   present specification.

So we still can use these bits, we just haven’t said yet, how.
But indeed, we could have used 0 and 2 as the first bits to be allocated (much harder to do anything useful with 1 and 3).
Not sure we want to change this now to reclaim those bits now, but we still could.
Any reaction, CoRE WG?

Grüße, Carsten

---

From: Martin Duke <[email-masked]>
Date: Thu, 3 Jun 2021 13:16:03 -0700

Ah, good point, you're not throwing them away forever.

Thanks!

On Thu, Jun 3, 2021 at 1:11 PM Carsten Bormann <[email-masked]> wrote:

> But indeed, we could have used 0 and 2 as the first bits to be allocated
> (much harder to do anything useful with 1 and 3).