Subject: [core] I-D Action: draft-ietf-core-observe-multicast-notifications-01.txt

From: [email-masked]
Date: Mon, 12 Jul 2021 08:35:22 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Constrained RESTful Environments WG of the IETF.

        Title           : Observe Notifications as CoAP Multicast Responses
        Authors         : Marco Tiloca
                          Rikard Höglund
                          Christian Amsüss
                          Francesca Palombini
	Filename        : draft-ietf-core-observe-multicast-notifications-01.txt
	Pages           : 77
	Date            : 2021-07-12

Abstract:
   The Constrained Application Protocol (CoAP) allows clients to
   "observe" resources at a server, and receive notifications as unicast
   responses upon changes of the resource state.  In some use cases,
   such as based on publish-subscribe, it would be convenient for the
   server to send a single notification addressed to all the clients
   observing a same target resource.  This document updates RFC7252 and
   RFC7641, and defines how a server sends observe notifications as
   response messages over multicast, synchronizing all the observers of
   a same resource on a same shared Token value.  Besides, this document
   defines how Group OSCORE can be used to protect multicast
   notifications end-to-end between the server and the observer clients.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-core-observe-multicast-notifications/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-core-observe-multicast-notifications-01.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-core-observe-multicast-notifications-01

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Marco Tiloca <[email-masked]>
Date: Fri, 16 Jul 2021 14:28:23 +0200

Hello CoRE,

We have submitted an update for the draft "Observe Notifications as CoAP 
Multicast Responses".

https://datatracker.ietf.org/doc/html/draft-ietf-core-observe-multicast-notifications-01

The document describes how a CoAP server can send Observe notifications 
over multicast, and how Group OSCORE can be used to protect such 
notifications.

This update is especially about the following points.

1) Simplified cancellation of the group observation, with no need for 
the server to use an explicit cancellation request.

2) If the server provides clients with information to join the right 
OSCORE group, the parameters and their semantics are aligned with the 
latest updates in draft-ietf-core-oscore-groupcomm-12 and 
draft-ietf-ace-key-groupcomm-oscore-11.

3) Improved Appendix C about the server self-managing the OSCORE group 
and Appendix D about using Cacheable OSCORE [1].

4) Added a new Appendix G, which provides a discussed example when using 
together a proxy, Group OSCORE and Cacheable OSCORE [1].

Comments are very welcome!

Best,
/Marco

[1] https://datatracker.ietf.org/doc/draft-amsuess-core-cachable-oscore/

-------- Forwarded Message --------
Subject: 	[core] I-D Action: 
draft-ietf-core-observe-multicast-notifications-01.txt
Date: 	Mon, 12 Jul 2021 08:35:22 -0700
From: 	[email-masked]
Reply-To: 	[email-masked]
To: 	[email-masked]
CC: 	[email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.
This draft is a work item of the Constrained RESTful Environments WG of 
the IETF.

Abstract:

The IETF datatracker status page for this draft is:
https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-core-observe-multicast-notifications%2F&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7C1ce2149aeb1043e18b5608d9454ac649%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637617009728442257%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=n0bXpuLi3jp3X4Qw7iQYqlywymJlZvOfyAZsjts9xj4%3D&amp;reserved=0

There is also an HTML version available at:
https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-ietf-core-observe-multicast-notifications-01.html&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7C1ce2149aeb1043e18b5608d9454ac649%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637617009728442257%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=ByI1NU5O0p9zuxWsvpSqP%2BJuMNU%2FowhkR8%2FTfY0CG3M%3D&amp;reserved=0

A diff from the previous version is available at:
https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-core-observe-multicast-notifications-01&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7C1ce2149aeb1043e18b5608d9454ac649%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637617009728452226%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=aNV18b4G63Khkpu8RvRGJuHqUd2zcfQ40MQcal7W2to%3D&amp;reserved=0

Internet-Drafts are also available by anonymous FTP at:
https://eur02.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.org%2Finternet-drafts%2F&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7C1ce2149aeb1043e18b5608d9454ac649%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637617009728452226%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=iSw%2BRsdLPfyuBxlBLWW6f34%2BnbybWIzYGQO644eURZE%3D&amp;reserved=0

_______________________________________________
core mailing list
[email-masked]
https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fcore&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7C1ce2149aeb1043e18b5608d9454ac649%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637617009728452226%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=91hJFLnDeDrBmLf5tdrqOl0d61cSHkYzPIAp9uQt504%3D&amp;reserved=0