Subject: [core] Murray Kucherawy's Discuss on draft-ietf-core-senml-data-ct-05: (with DISCUSS)

From: Murray Kucherawy via Datatracker <[email-masked]>
Date: Wed, 22 Sep 2021 22:02:52 -0700

Murray Kucherawy has entered the following ballot position for
draft-ietf-core-senml-data-ct-05: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/blog/handling-iesg-ballot-positions/
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-core-senml-data-ct/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

This should be easy to resolve:

The SenML Labels registry specifies a column called "EXT ID" (or actually just
"EI" in RFC 8428) that is absent from the registrations in Section 8.  If that
column should be empty for these new registrations, that should be explicit
rather than implicit.

---

From: Francesca Palombini <[email-masked]>
Date: Thu, 23 Sep 2021 13:24:58 +0000

Hi Murray,

That column should indeed be left empty (I got clarifications about it during my AD review):

> 9. -----
>
> FP: In Section 8, several columns for the registration of SenML labels are missing: CBOR label, exi ID.

As they should be:

RFC8428 12.2:  […] the
  CBOR labels SHOULD be left empty as CBOR will use the string encoding
  for any new labels. The EI column contains the EXI schemaId value of
  the first schema that includes this label, or it is empty if this
  label was not intended for use with EXI.

This was also clarified with IANA, so they know, but I am sure the authors will have no problem to explicitly add it to the document.

Thanks,
Francesca

From: core <[email-masked]> on behalf of Murray Kucherawy via Datatracker <[email-masked]>
Date: Thursday, 23 September 2021 at 07:03
To: The IESG <[email-masked]>
Cc: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: [core] Murray Kucherawy's Discuss on draft-ietf-core-senml-data-ct-05: (with DISCUSS)
Murray Kucherawy has entered the following ballot position for
draft-ietf-core-senml-data-ct-05: Discuss

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 23 Sep 2021 07:04:57 -0700

Hi Francesca,

On Thu, Sep 23, 2021 at 6:25 AM Francesca Palombini <
[email-masked]> wrote:

> [...]
>
>
>
> This was also clarified with IANA, so they know, but I am sure the authors
> will have no problem to explicitly add it to the document.
>

Perfect, thanks!

-MSK