Subject: [core] CoAP option for Well-Known Uri-Path

From: Michael Richardson <[email-masked]>
Date: Sun, 19 Sep 2021 16:15:33 -0400

Has anyone considered a CoAP-Option that would compress well-known prefixes?
So, instead of:
    Uri-Path ".well-known"
    Uri-Path "brski"
    Uri-Path "sen"

one could have:
    Well-Known-Uri-Path [CBOR-int from to be created .well-known Registry column]
    Uri-Path "sen"

Takes some coordination to get it deployed, but in some greenfields we could
do this now.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Göran Selander <[email-masked]>
Date: Mon, 20 Sep 2021 06:22:15 +0000

Hi Michael,

Do you mean something like this:
https://datatracker.ietf.org/meeting/interim-2021-core-05/materials/slides-interim-2021-core-05-sessa-core-option-for-well-known-resources-00.pdf

Göran

On 2021-09-19, 22:16, "core on behalf of Michael Richardson" <[email-masked] on behalf of [email-masked]> wrote:

    one could have:

---

From: Christian Amsüss <[email-masked]>
Date: Mon, 20 Sep 2021 08:29:48 +0200

> Takes some coordination to get it deployed, but in some greenfields we could

I have a rough sketch, presented at [1]. In its minimal form it'd only
be a replacement for Uri-Path (ie. .well-known/brski/sen would need a
point just as any other brski path), but "prepend to actual path"
semantics are feasible at slightly increased processing effort for those
who use it.

Main stopper for further work since May was that I'd like to build it on
SCHC semantically, but if urgency comes to it, the option could just as
well be defined, and the SCHC semantics retconned into it.

BR
c

[1]: https://datatracker.ietf.org/meeting/interim-2021-core-05/session/core

-- 
To use raw power is to make yourself infinitely vulnerable to greater powers.
  -- Bene Gesserit axiom

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 20 Sep 2021 10:43:16 +0200

I think the main reason that we didn’t do this right away was that the original Usage (. Well known core) was relatively rare and implied even larger data. But with other protocols using wk it may start making more sense. Unfortunately, there is no option position left that would keep the correct order in the Uri. Oh well. 

Sent from mobile, sorry for terse

> On 19. Sep 2021, at 22:16, Michael Richardson <[email-masked]> wrote:
> 
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Michael Richardson <[email-masked]>
Date: Mon, 20 Sep 2021 12:22:08 -0400

> https://datatracker.ietf.org/meeting/interim-2021-core-05/materials/slides-interim-2021-core-05-sessa-core-option-for-well-known-resources-00.pdf

I knew that someone had thought about this before.

Carsten Bormann <[email-masked]> wrote:
    > I think the main reason that we didn’t do this right away was that the
    > original Usage (. Well known core) was relatively rare and implied even
    > larger data. But with other protocols using wk it may start making more
    > sense. Unfortunately, there is no option position left that would keep
    > the correct order in the Uri. Oh well.

Oh, in terms of options being always incrementing.