Subject: [core] Fwd: New Version Notification for draft-lenders-dns-over-coap-02.txt

From: Martine Sophie Lenders <[email-masked]>
Date: Mon, 25 Oct 2021 23:09:05 +0200

Hi!

as promised during the last interim, we provided an update of our draft 
on DNS over CoAP which should address all the requested changes made 
during that meeting.

The most important changes encompass:

- Remove GET and POST methods
- Add note on ETag option and response codes
- Provide requirement conflict for DNS over QUIC
- Clarify Content-Format / Accept handling

Comments are, as always, very much welcome.

Thanks,
Martine
on behalve of all co-authors

-------- Original Message --------
Subject: 	New Version Notification for draft-lenders-dns-over-coap-02.txt
Date: 	Mon, 25 Oct 2021 13:57:22 -0700
From: 	[email-masked]
To: 	Thomas C. Schmidt <[email-masked]>, Cenk Gündoğan 
<[email-masked]>, Christian Amsüss 
<[email-masked]>, Matthias Wählisch <[email-masked]>, 
Martine Sophie Lenders <[email-masked]>

A new version of I-D, draft-lenders-dns-over-coap-02.txt
has been successfully submitted by Martine Lenders and posted to the
IETF repository.

Name: draft-lenders-dns-over-coap
Revision: 02
Title: DNS Queries over CoAP (DoC)
Document date: 2021-10-25
Group: Individual Submission
Pages: 13
URL: https://www.ietf.org/archive/id/draft-lenders-dns-over-coap-02.txt
Status: https://datatracker.ietf.org/doc/draft-lenders-dns-over-coap/
Html: https://www.ietf.org/archive/id/draft-lenders-dns-over-coap-02.html
Htmlized: https://datatracker.ietf.org/doc/html/draft-lenders-dns-over-coap
Diff: https://www.ietf.org/rfcdiff?url2=draft-lenders-dns-over-coap-02

Abstract:
This document defines a protocol for sending DNS messages over the
Constrained Application Protocol (CoAP). These CoAP messages are
protected by DTLS-Secured CoAP (CoAPS) or Object Security for
Constrained RESTful Environments (OSCORE) to provide encrypted DNS
message exchange for constrained devices in the Internet of Things
(IoT).

The IETF Secretariat

---

From: <[email-masked]>
Date: Thu, 28 Oct 2021 12:37:10 +0000

Hi Martine, all,

For this item :

“DHCP and RA options to deliver?  [I-D.peterson-doh-dhcp]”

You may consider pointing to draft-ietf-add-dnr which can be used to discover any encrypted DNS. This will basically return an authentication name + a list of IP addresses. That I-D covers RA, DHCP, and DHCPv6.

Cheers,
Med

De : core <[email-masked]> De la part de Martine Sophie Lenders
Envoyé : lundi 25 octobre 2021 23:09
À : [email-masked]
Objet : [core] Fwd: New Version Notification for draft-lenders-dns-over-coap-02.txt

Hi!

as promised during the last interim, we provided an update of our draft on DNS over CoAP which should address all the requested changes made during that meeting.

Thanks,
Martine

-------- Original Message --------
Subject:

New Version Notification for draft-lenders-dns-over-coap-02.txt

Date:

Mon, 25 Oct 2021 13:57:22 -0700

From:

[email-masked]<mailto:[email-masked]>

To:

Thomas C. Schmidt <[email-masked]><mailto:[email-masked]>, Cenk Gündoğan <[email-masked]><mailto:[email-masked]>, Christian Amsüss <[email-masked]><mailto:[email-masked]>, Matthias Wählisch <[email-masked]><mailto:[email-masked]>, Martine Sophie Lenders <[email-masked]><mailto:[email-masked]>

Abstract:

The IETF Secretariat

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Martine Sophie Lenders <[email-masked]>
Date: Thu, 28 Oct 2021 19:33:59 +0200

Hi Med,

while our main idea so far was to discover the DoC resource via CoRE-RD, 
this is definitely something to look into as a fallback or alternative 
discovery option.

Cheers,
Martine

Am 28.10.21 um 14:37 schrieb [email-masked]:
> Fwd: New Version Notification for draft-lenders-dns-over-coap-02.txt
>
> Hi Martine, all,
>
> For this item :
>
> You may consider pointing to draft-ietf-add-dnr which can be used to 
> discover any encrypted DNS. This will basically return an 
> authentication name + a list of IP addresses. That I-D covers RA, 
> DHCP, and DHCPv6.
>
> Cheers,
>
> Med
>
> *De :* core <[email-masked]> *De la part de* Martine Sophie Lenders
> *Envoyé :* lundi 25 octobre 2021 23:09
> *À :* [email-masked]
> *Objet :* [core] Fwd: New Version Notification for 
> draft-lenders-dns-over-coap-02.txt
>
> Hi!
>
> as promised during the last interim, we provided an update of our 
> draft on DNS over CoAP which should address all the requested changes 
> made during that meeting.
>
> *Subject: *
> *Date: *
> *From: *
> [email-masked]
> *To: *
> Thomas C. Schmidt <[email-masked]> 
> <mailto:[email-masked]>, Cenk Gündoğan 
> <[email-masked]> 
> <mailto:[email-masked]>, Christian Amsüss 
> <[email-masked]> <mailto:[email-masked]>, Matthias 
> Wählisch <[email-masked]> <mailto:[email-masked]>, 
> <mailto:[email-masked]>
>
>
>
>
> Htmlized: 
> https://datatracker.ietf.org/doc/html/draft-lenders-dns-over-coap