Subject: [core] Data retrieval for a specific timeframe

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 12 Jan 2022 14:12:22 +0000

Hi all

Is there functionality defined somewhere to allow a CoAP client to ask a CoAP server for data (e.g. temperature sensor) from a specific timeframe or from a specific date?
With SenML there is the possibility to encode this time series data but I haven't seen any definitions for requesting such data (e.g. as URI parameters).

I am sure that the need for such functionality has come up before.

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 12 Jan 2022 15:19:43 +0100

> On 2022-01-12, at 15:12, Hannes Tschofenig <[email-masked]> wrote:
> 
> Hi all
>  
> With SenML there is the possibility to encode this time series data but I haven’t seen any definitions for requesting such data (e.g. as URI parameters).
>  

This can be left to an application, but it certainly is a good idea to have a standard vocabulary for that.

This also could be combined with pagination.
See also https://datatracker.ietf.org/doc/draft-bormann-t2trg-stp/

Grüße, Carsten

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 12 Jan 2022 16:50:56 +0000

Thanks, Carsten. I will get the group asking for this feature involved in the discussion.

I will also take a look at draft-bormann-t2trg-stp. It sounds promising to me!

-----Original Message-----
From: Carsten Bormann <[email-masked]>
Sent: Wednesday, January 12, 2022 3:20 PM
To: Hannes Tschofenig <[email-masked]>
Cc: [email-masked] WG ([email-masked]) <[email-masked]>
Subject: Re: [core] Data retrieval for a specific timeframe

Grüße, Carsten