Subject: Re: [core] New Version Notification for draft-amsuess-core-coap-kitchensink-00.txt

From: Christian Amsüss <[email-masked]>
Date: Wed, 2 Mar 2022 15:37:29 +0100

Hello CoRE,

I've assembled a short (and clearly not comprehensive) overview of tools
built on top of CoAP, with the intention of making (re)usable components
known more widely, to get a better grip on where doing something over
CoAP makes sense and where not, and to identify gaps, closing some
(like, I've been using "poor man's NTP" for almost a decade now and
never wrote anything).

Therer is no clear direction for this document, and working on it may
easily not be in scope for this WG (well, the I-D format may not even
be ideal here), but nonetheless I hope it is of interest to some of you.

BR
c

On Wed, Mar 02, 2022 at 06:27:54AM -0800, [email-masked] wrote:
> A new version of I-D, draft-amsuess-core-coap-kitchensink-00.txt
> has been successfully submitted by Christian Amsüss and posted to the
> IETF repository.
> 
> Name:		draft-amsuess-core-coap-kitchensink
> Revision:	00
> Title:		Everything over CoAP
> Document date:	2022-03-02
> Group:		Individual Submission
> Pages:		10
> URL:            https://www.ietf.org/archive/id/draft-amsuess-core-coap-kitchensink-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-amsuess-core-coap-kitchensink/
> Html:           https://www.ietf.org/archive/id/draft-amsuess-core-coap-kitchensink-00.html
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-amsuess-core-coap-kitchensink
> 
> 
> Abstract:
>    The Constrained Application Protocol (CoAP) has become the base of
>    applications both inside of the constrained devices space it
>    originally aimed for and outside.  This document gives an overview of
>    applications that are, can, may, and would better not be implemented
>    on top of CoAP.

-- 
To use raw power is to make yourself infinitely vulnerable to greater powers.
  -- Bene Gesserit axiom

---

From: Michael Richardson <[email-masked]>
Date: Wed, 02 Mar 2022 14:16:22 -0500

> (like, I've been using "poor man's NTP" for almost a decade now and

I think that I understand your goals.
I like how you indicate what it competes with, and what remains to be done.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide