Subject: [core] DNS over CoAP: How abstract should the draft be?

From: Martine Sophie Lenders <[email-masked]>
Date: Fri, 25 Mar 2022 13:13:42 +0100

Hi,

during today's meeting, I was asked to put the four discussion points I 
presented in my talk on DoC [1] on the list. Here is the discussion 
point on how abstract the draft should be (slide 14 of [2]).

Klaus proposed in GitHub issue #18 to focus less on protocol details and 
rather to just define a REST API for how to fetch DNS information from a 
DoC server.

The question is, if such a more abstract specification is what would be 
more desirable and if the "how to implement over CoAP" should be more 
relegated to the Appendix or another document.

Cheers,
Martine

[1] https://datatracker.ietf.org/doc/draft-lenders-dns-over-coap/
[2] 
https://datatracker.ietf.org/meeting/113/materials/slides-113-core-dns-queries-over-coap-doc-00 

[3] https://github.com/anr-bmbf-pivot/draft-dns-over-coap/issues/18

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 25 Mar 2022 14:31:29 +0100

On 25. Mar 2022, at 13:13, Martine Sophie Lenders <[email-masked]> wrote:
> 
> Klaus proposed in GitHub issue #18 to focus less on protocol details and rather to just define a REST API for how to fetch DNS information from a DoC server.
> 
> The question is, if such a more abstract specification is what would be more desirable and if the "how to implement over CoAP" should be more relegated to the Appendix or another document.

What is better about leaving this open instead of simply defining it?

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 25 Mar 2022 14:33:58 +0100

> What is better about leaving this open instead of simply defining it?

Maybe I misunderstood the question.

I think Klaus may be pointing out the “restatement anti-pattern”: We don’t need text in the draft that explains how CoAP works (except maybe in examples).
So you would explain the protocol in terms of CoAP’s service, not in terms of CoAP’s individual messages that CoAP uses to provide this service.

Grüße, Carsten