Subject: [COSE] [Technical Errata Reported] RFC8152 (5066)

From: RFC Errata System <[email-masked]>
Date: Tue, 11 Jul 2017 11:03:04 -0700 (PDT)

The following errata report has been submitted for RFC8152,
"CBOR Object Signing and Encryption (COSE)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5066

--------------------------------------
Type: Technical
Reported by: Jim Schaad <[email-masked]>

Section: 14

Original Text
-------------
   o  The restriction applies to the encoding of the Sig_structure, the
      Enc_structure, and the MAC_structure.

Corrected Text
--------------
   o  The restriction applies to the encoding of the COSE_KDF_Context, 
      Sig_structure, the Enc_structure, and the MAC_structure.

Notes
-----
When listing the set of structure that need to be canonically encoded, I missed this one.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8152 (draft-ietf-cose-msg-24)
--------------------------------------
Title               : CBOR Object Signing and Encryption (COSE)
Publication Date    : July 2017
Author(s)           : J. Schaad
Category            : PROPOSED STANDARD
Source              : CBOR Object Signing and Encryption
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Jim Schaad <[email-masked]>
Date: Tue, 11 Jul 2017 11:05:54 -0700

I reported it, so yes I believe that this should be approved.

Jim

-----Original Message-----
From: RFC Errata System [mailto:[email-masked]] 
Sent: Tuesday, July 11, 2017 11:03 AM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Technical Errata Reported] RFC8152 (5066)

The following errata report has been submitted for RFC8152, "CBOR Object Signing and Encryption (COSE)".

Section: 14

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please use "Reply All" to discuss whether it should be verified or rejected. When a decision is reached, the verifying party can log in to change the status and edit the report, if necessary.