Subject: [COSE] Question regarding RFC 8152

From: Brian Rasmussen <[email-masked]>
Date: Thu, 9 Nov 2017 11:43:26 +0000

Hi

I have a specific question regarding the COSE defined AES CCM (chapter 10.2 of RFC 8152) mode. The definition of CCM mode is referenced in RFC3610, but RFC3610 only defines 128-bit block ciphers. In Table 10 in chapter 10.2 of RFC8152 there are specified AES CCM algorithms, that uses 256-bit block ciphers like the AES-CCM-16-64-256 algorithm. Where is the CCM mode for 256-bit block ciphers defined?

Any advice would be helpful. Thanks in advance for your answer.

Venlig hilsen / Best regards
[Kamstrup A/S]<http://kamstrup.com/>
Brian Rasmussen
Teamlead Embedded SW
Technology

Kamstrup A/S
Industrivej 28
DK-8660 Skanderborg
T: +45 89 93 10 00
D: +45 89 93 16 17

[email-masked]<mailto:[email-masked]>
kamstrup.com

---

From: Derek Atkins <[email-masked]>
Date: Sun, 12 Nov 2017 08:27:37 -0500

You are confusing block size and key size
All instances of AES are 128-bit block size, regardless of key size.

-derek
Sent using my mobile device. Please excuse any typos.

On November 12, 2017 8:01:49 AM Brian Rasmussen <[email-masked]> wrote:

> Hi
>
> I have a specific question regarding the COSE defined AES CCM (chapter 10.2 
> of RFC 8152) mode. The definition of CCM mode is referenced in RFC3610, but 
> RFC3610 only defines 128-bit block ciphers. In Table 10 in chapter 10.2 of 
> RFC8152 there are specified AES CCM algorithms, that uses 256-bit block 
> ciphers like the AES-CCM-16-64-256 algorithm. Where is the CCM mode for 
> 256-bit block ciphers defined?
>
> ----------
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose
>