Subject: Re: [cso] Potential CSO Research Area: Designing Routing to handle variable traffic loads

From: Leeyoung <[email-masked]>
Date: Fri, 19 Aug 2011 15:19:49 +0000

Hi all,

I think we have a good progress on the CSO work in the last meeting in Quebec City. It seems that more people are interested in the idea. I'd like to say thanks Dr. Dave McDaysan for providing a few links that might be related to CSO research.

It might be a good idea to bring any on-going activities in research community to the discussion that resonate with the CSO idea and its spirit.

I have found the following activities:

http://pnrl.stanford.edu/HyperFlow/HyperFlow_summary.htm
http://web.mit.edu/chan/www/vincent_project.html (please see optical flow swtiching and future optical network architecture)

Hyperflow project is a NSF funded project that has a great synergy with the CSO's vision for joint otpimization across physical transport network with application stratum. Here's an excerpt from Standford's Hyperflow descritpion:

"HyperFlow relies on a novel optical network infrastructure comprising new transport mechanisms and a new comprehensive control plane including network protocols from the physical layer up to the application layer."

I think UTD's Dr. Andrea Fumagalli (one of the three PI's for Hyperflow project and one of the main supporters of the CSO work ) can provide more insight on Hyperflow in light of CSO spirit.

Please feel free to pitch in any research activities you either have been involved with or are aware of that might contribute the CSO work to move forward in IRTF.

Thanks & Best Regards,
Young

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mcdysan, David E
Sent: Wednesday, July 27, 2011 8:33 PM
To: [email-masked]
Subject: [cso] Potential CSO Research Area: Designing Routing to handle variable traffic loads

The other research paper that I mentioned:

Efficient and Robust Routing of Highly Variable Traffic

What network routing should an Inter- net Service Provider use so as to (i) accommodate users demanding "good" service while being unpredictable in the traffic that they would like to send to different destinations, (ii) minimize the amount of "overprovi- sioning" that needs to be done in the network in or- der to make "best effort networking better" without re- sorting to sophisticated traffic prediction and manage- ment mechanisms, (iii) operate the network efficiently with mostly static routing configurations and without dynamic routing adjustments to avoid congestion due to drastic changes in traffic flows between a network's ingress and egress routers.

http://www.cc.gatech.edu/classes/AY2007/cs7260_spring/papers/variable.pdf

Dave

---

From: "Nicola Ciulli" <[email-masked]>
Date: Tue, 30 Aug 2011 18:35:36 +0200

Hi Young, all,

I can point the EC-funded GEYSERS project, as already introduced at the CSO workshop in Daejeon.
http://www.geysers.eu/

Imho, the following two deliverables are of specific relevance for the CSO works:

Deliverable 4.2: NIPS user-network interface and procedures
http://www.geysers.eu/images/stories/deliverables/geysers-deliverable_4.2.pdf

Deliverable 2.2: GEYSERS overall architecture & interfaces specification and service provisioning workflow http://www.geysers.eu/images/stories/deliverables/geysers-deliverable_2.2_update_final.pdf

Also some requirements and use cases documents from WP1 (D1.x), from the list in http://www.geysers.eu/index.php/deliverables, could be useful.

Hope this helps.

best regards,
Nicola.

------------------------------------------------------------------------------
  From: [email-masked] [mailto:[email-masked]] On Behalf Of Leeyoung
  Sent: Friday, August 19, 2011 10:20 AM
  To: [email-masked]
  Subject: Re: [cso] Potential CSO Research Area: Designing Routing to handle variable traffic loads

  Hi all,

    

  Thanks & Best Regards,
  Young

------------------------------------------------------------------------------
  From: [email-masked] [mailto:[email-masked]] On Behalf Of Mcdysan, David E
  Sent: Wednesday, July 27, 2011 8:33 PM
  To: [email-masked]
  Subject: [cso] Potential CSO Research Area: Designing Routing to handle variable traffic loads

  Dave