Subject: [cso] survey on research on CSO

From: Leeyoung <[email-masked]>
Date: Wed, 23 Nov 2011 00:08:36 +0000

Hi,

Enclosed is the CSO research proposal PPT presented during the IRTF Open Meeting. As previously sent meeting notes indicated, there is no doubt that there is an interested party on CSO research and many people have contributed to further this research in the past months.

I'd like to take this opportunity to ask people on the mailing list if they do/do not support forming a CSO research group. This information will be used as a barometer to indicate the level of interest in the community.

If you do support forming a CSO research group, please say in your reply, "support"; otherwise, "not support."

Thanks in advance for your cooperation. Your response to this poll will be very crucial in determining the future CSO research effort.

Best Regards,
Young

---

From: Greg Bernstein <[email-masked]>
Date: Tue, 22 Nov 2011 17:05:52 -0800

Support!
Greg B.
On 11/22/2011 4:08 PM, Leeyoung wrote:
>
> Hi,
>
> Enclosed is the CSO research proposal PPT presented during the IRTF 
> Open Meeting. As previously sent meeting notes indicated, there is no 
> doubt that there is an interested party on CSO research and many 
> people have contributed to further this research in the past months.
>
> I'd like to take this opportunity to ask people on the mailing list if 
> they do/do not support forming a CSO research group. This information 
> will be used as a barometer to indicate the level of interest in the 
> community.
>
> If you do support forming a CSO research group, please say in your 
> reply, "support"; otherwise, "not support."
>
> Thanks in advance for your cooperation. Your response to this poll 
> will be very crucial in determining the future CSO research effort.
>
> Best Regards,
>
> Young
>
>
>
> _______________________________________________
> cso mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cso

-- 
===================================================
Dr Greg Bernstein, Grotto Networking (510) 573-2237

---

From: Lucy yong <[email-masked]>
Date: Wed, 23 Nov 2011 01:59:01 +0000

support!

Lucy

From: [email-masked] [mailto:[email-masked]] On Behalf Of Leeyoung
Sent: Tuesday, November 22, 2011 6:09 PM
To: [email-masked]
Subject: [cso] survey on research on CSO

Hi,

Best Regards,
Young

---

From: Lars Eggert <[email-masked]>
Date: Wed, 23 Nov 2011 07:52:29 +0200

Hi,

as I have explained during the side meeting in Taipei, I will not charter an IRTF research group on CSO. 

Lars Eggert
IRTF Chair

On 2011-11-23, at 2:08, Leeyoung wrote:

> I’d like to take this opportunity to ask people on the mailing list if they do/do not support forming a CSO research group. This information will be used as a barometer to indicate the level of interest in the community.
> 
> If you do support forming a CSO research group, please say in your reply, “support”; otherwise, “not support.”
> 
> <CSO Research Proposal_IRTF Open Meeting Taipei V8.pdf>_______________________________________________
> cso mailing list
> [email-masked]

---

From: Riccardo Bernardini <[email-masked]>
Date: Wed, 23 Nov 2011 08:29:51 +0100

Support

2011/11/23 Leeyoung <[email-masked]>

>  Hi,****
>
> ** **
>
> Enclosed is the CSO research proposal PPT presented during the IRTF Open
> Meeting. As previously sent meeting notes indicated, there is no doubt that
> there is an interested party on CSO research and many people have
> contributed to further this research in the past months. ****
>
> ** **
>
> I’d like to take this opportunity to ask people on the mailing list if
> they do/do not support forming a CSO research group. This information will
> be used as a barometer to indicate the level of interest in the community.
> ****
>
> ** **
>
> If you do support forming a CSO research group, please say in your reply,
> “support”; otherwise, “not support.” ****
>
> ** **
>
> Thanks in advance for your cooperation. Your response to this poll will be
> very crucial in determining the future CSO research effort.  ****
>
> ** **
>
> Best Regards,****
>
> Young****
>

---

From: Zhangfatai <[email-masked]>
Date: Wed, 23 Nov 2011 09:06:11 +0000

Support.

Thanks

Fatai

Sent: 2011年11月23日 8:09

Hi,

Best Regards,
Young

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Wed, 23 Nov 2011 16:36:30 +0100

support

De: [email-masked] [mailto:[email-masked]] En nombre de Leeyoung
Enviado el: miércoles, 23 de noviembre de 2011 1:09
Para: [email-masked]
Asunto: [cso] survey on research on CSO

Hi,

Best Regards,
Young

________________________________
Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at.
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: "Zhu, Jing Z" <[email-masked]>
Date: Wed, 23 Nov 2011 10:16:17 -0700

Support! -Jing

Hi,

Best Regards,
Young

---

From: Kohei Shiomoto <[email-masked]>
Date: Thu, 24 Nov 2011 02:57:29 +0900

Yes. Support.

Kohei Shiomoto

(2011/11/23 9:08), Leeyoung wrote:
> reply, “support”; otherwise, “not support.”
>
-- 
Kohei Shiomoto, Ph.D
Senior Research Engineer, Supervisor, Group Leader
NTT Service Integration Laboratories
http://www.ntt.co.jp/islab/e/org/si.html
3-9-11 Midori, Musashino, Tokyo 180-8585, Japan
Phone +81 422 59 4402 Fax +81 422 59 5671
Free online contents of "NTT Technical Review" available at
https://www.ntt-review.jp/

---

From: Ning So <[email-masked]>
Date: Wed, 23 Nov 2011 10:55:36 -0800 (PST)

Yes, support.

Ning

________________________________
 From: Leeyoung <[email-masked]>
To: "[email-masked]" <[email-masked]> 
Sent: Tuesday, November 22, 2011 6:08 PM
Subject: [cso] survey on research on CSO

Hi,

 

Best Regards,
Young

---

From: "Y. Richard Yang" <[email-masked]>
Date: Wed, 23 Nov 2011 16:13:33 -0500

Hi Young,

I support a more organized research effort on Cross Stratum 
Optimization. I feel that it is an important issue.

First a disclaimer, I attended only the CSO meeting at Quebec but missed 
this meeting at Taipei. Hence I have only limited info on the scope and 
goals of CSO from the attached ppt. Please correct me if I misunderstand 
some of the key goals of CSO.

In slide 4 of your attached ppt, CSO is "defined as cooperation between 
the application and network strata ...". I think that this is an 
important problem! The interactions/cooperation between app and net has 
been of interest in the research community.

One of the initial investigations on this topic, as I know of, started 
rigorously in the context of selfish routing (i.e., app directed routing 
w/o net). The initial results were reflected in both theoretical (e.g., 
a good summary is Roughgarden's Selfish Routing and Price of Anarchy 
thesis published by MIT Press in 2005) and real-trace-driven studies 
(e.g., our Selfish Routing paper in SIGCOMM 2003). I should say that the 
results were, in a sense, negative, in that the price-of-anarchy is low 
at linear cost functions (e.g., at low utilization); in certain sense, 
(app only) end-to-end control can have a bound on penalty. Transport 
adaption can also reduce penalty of no coordination. One can also bound 
the penalty by using "over-provision" (see Roughgarden's doubling 
capability bound).

However, the previous investigation also shows that net and app can 
interact poorly, if both conduct optimization, and the results depend on 
the mechanisms. An example we gave in the SIGCOMM'03 selfish routing 
paper was the poor interaction of (app) selfish routing and net TE (OSPF 
vs MPLS). One way to address the poor interaction is to make the network 
less responsive (i.e., not to react) and we looked along this line on 
the COPE TE approach (SIGCOMM'06) and then the R3 TE approach 
(SIGCOMM'10). But I believe that network responsive and joint net/app 
optimization can bring more benefits than app-oblivious net.

In a sense, the P4P framework in 2008 was also focused on net/app 
interactions. The specific problem domain was overlay (p2p) traffic 
selection. The theoretical framework is an app/net interface based on 
decomposition achieved by primal-dual. Such map-based net/app interface 
is also similar in spirit to the early Nimrod design. Some details on 
P4P can be found at our SIGCOMM'08 P4P paper. The Oracle approach of 
net/app gives yet another style of interface. In 2010, Freedman and 
Rexford and their students presented DONAR in SIGCOMM'10, and DONAR 
gives another interesting style of potential interface between app and 
the infrastructure (servers).

The purpose of the preceding examples is to show that app/net (or more 
generally app/infrastructure) coordination can raise interesting 
analysis and design issues. I believe that the fundamental value of net 
is to help net app to create values. Hence, interfaces between net to 
app is important. In recent talks, Scott Shenker proposes that a 
fundamental design issue of network is to come up with good 
abstractions. I feel that the basic abstractions between app and net for 
their coordination (net -> app feedback, and app->net command/hint) 
should be important abstractions and hence a more organized effort here 
can be quite valuable.

Thanks.

Richard

---

From: 김태연 <[email-masked]>
Date: Thu, 24 Nov 2011 09:18:18 +0900

Support

-------------------------

TaeYeon Kim

Principal Engineer, ETRI

e-mail: [email-masked]

TEL: 042-860-6377

Mobile : 010-4189-0052

From: [email-masked] [mailto:[email-masked]] On Behalf Of Leeyoung
Sent: Wednesday, November 23, 2011 9:09 AM
To: [email-masked]
Subject: [cso] survey on research on CSO

Hi,

Best Regards,

Young

---

From: Jordi Ferrer Riera <[email-masked]>
Date: Thu, 24 Nov 2011 09:15:43 +0100

Yes, support.

El 23/11/11 01:08, Leeyoung escribió:
> Meeting. As previously sent meeting notes indicated, there is no doubt
> that there is an interested party on CSO research and many people have
> contributed to further this research in the past months.
>
> Thanks in advance for your cooperation. Your response to this poll will
> be very crucial in determining the future CSO research effort.
>
> Best Regards,
>
> Young
>
>
>

-- 
Jordi Ferrer Riera
PhD Researcher

Distributed Applications and Networks Area (DANA)
Fundaci i2CAT, Internet i Innovaci Digital a Catalunya
C/ Gran Capit 2-4, Nexus I building, 1st floor, office 109
08034 Barcelona, Spain

P: +34 93 553 2518     (Int. Ext.: 518)
F: +34 93 553 2520
SIP:  [email-masked] (Ext. 153)

@:     [email-masked]
web:   www.i2cat.net
skype: jordi.ferrer.mntc
blog:  http://dana.i2cat.net

Si us plau no imprimiu aquest correu si no s necessari
Please do not print this email if not required

----------------------------------------------------------
The information contained in this electronic mail message
is confidential. It is intended solely for the use of the
individual or entity to whom it is addressed and others
authorised to receive it. If the reader of this message is
not the intended recipient, you are hereby notified that
any use, copying, dissemination or disclosure of this
information is strictly prohibited. If you receive this e-
mail message in error please notify me immediately at the
address box [email-masked].
----------------------------------------------------------

'Labor omnia vincit improbus'

---

From: Giada Landi <[email-masked]>
Date: Thu, 24 Nov 2011 09:31:15 +0100 (GMT+01:00)

Support.

Giada

----- Original Message -----
From: "Leeyoung" <[email-masked]>
To: [email-masked]
Sent: Wednesday, 23 November, 2011 01:08:36 GMT +01:00 Amsterdam / Berlin / Bern / Rome / Stockholm / Vienna
Subject: [cso] survey on research on CSO

Hi, 

Best Regards, 

Young

---

From: Kathy McEwen <[email-masked]>
Date: Thu, 24 Nov 2011 08:26:51 -0600

Support

Sent from my iPhone

On Nov 22, 2011, at 6:08 PM, Leeyoung <[email-masked]> wrote:

> <CSO Research Proposal_IRTF Open Meeting Taipei V8.pdf>

---

From: "Chris Fenton" <[email-masked]>
Date: Thu, 24 Nov 2011 13:44:47 -0600

Support too ! 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Leeyoung
Sent: Tuesday, November 22, 2011 6:09 PM
To: [email-masked]
Subject: [cso] survey on research on CSO

Hi,

I'd like to take this opportunity to ask people on the mailing list if they
do/do not support forming a CSO research group. This information will be
used as a barometer to indicate the level of interest in the community.

If you do support forming a CSO research group, please say in your reply,
"support"; otherwise, "not support." 

Thanks in advance for your cooperation. Your response to this poll will be
very crucial in determining the future CSO research effort.  

Best Regards,

Young

---

From: Leeyoung <[email-masked]>
Date: Tue, 29 Nov 2011 21:39:50 +0000

Hi Richard,

I concur with your analysis below. See in-line for my comment.

Young

From: [email-masked] [mailto:[email-masked]] On Behalf Of Y. Richard Yang
Sent: Wednesday, November 23, 2011 3:14 PM
To: [email-masked]
Subject: Re: [cso] survey on research on CSO

Hi Young,

I support a more organized research effort on Cross Stratum Optimization. I feel that it is an important issue.

First a disclaimer, I attended only the CSO meeting at Quebec but missed this meeting at Taipei. Hence I have only limited info on the scope and goals of CSO from the attached ppt. Please correct me if I misunderstand some of the key goals of CSO.

In slide 4 of your attached ppt, CSO is "defined as cooperation between the application and network strata ...". I think that this is an important problem! The interactions/cooperation between app and net has been of interest in the research community.

YOUNG>> This is the heart of CSO research.

One of the initial investigations on this topic, as I know of, started rigorously in the context of selfish routing (i.e., app directed routing w/o net). The initial results were reflected in both theoretical (e.g., a good summary is Roughgarden's Selfish Routing and Price of Anarchy thesis published by MIT Press in 2005) and real-trace-driven studies (e.g., our Selfish Routing paper in SIGCOMM 2003). I should say that the results were, in a sense, negative, in that the price-of-anarchy is low at linear cost functions (e.g., at low utilization); in certain sense, (app only) end-to-end control can have a bound on penalty. Transport adaption can also reduce penalty of no coordination. One can also bound the penalty by using "over-provision" (see Roughgarden's doubling capability bound).

YOUNG>> Google person (Eddie Crabbe) mentioned that even 5-10% saving using cso-like mechanism would be huge. KT's Kun-Yul Park also reported that over-provisioning does not help the carrier. Buying more routers would not help carrier economics. They want to be  more intelligent and smart by ways of control and management from application to transport network.

However, the previous investigation also shows that net and app can interact poorly, if both conduct optimization, and the results depend on the mechanisms. An example we gave in the SIGCOMM'03 selfish routing paper was the poor interaction of (app) selfish routing and net TE (OSPF vs MPLS). One way to address the poor interaction is to make the network less responsive (i.e., not to react) and we looked along this line on the COPE TE approach (SIGCOMM'06) and then the R3 TE approach (SIGCOMM'10). But I believe that network responsive and joint net/app optimization can bring more benefits than app-oblivious net.

YOUNG>> This is one of the key CSO goals spelled out in the PPT I sent to the group.

In a sense, the P4P framework in 2008 was also focused on net/app interactions. The specific problem domain was overlay (p2p) traffic selection. The theoretical framework is an app/net interface based on decomposition achieved by primal-dual. Such map-based net/app interface is also similar in spirit to the early Nimrod design. Some details on P4P can be found at our SIGCOMM'08 P4P paper. The Oracle approach of net/app gives yet another style of interface. In 2010, Freedman and Rexford and their students presented DONAR in SIGCOMM'10, and DONAR gives another interesting style of potential interface between app and the infrastructure (servers).

The purpose of the preceding examples is to show that app/net (or more generally app/infrastructure) coordination can raise interesting analysis and design issues. I believe that the fundamental value of net is to help net app to create values. Hence, interfaces between net to app is important. In recent talks, Scott Shenker proposes that a fundamental design issue of network is to come up with good abstractions. I feel that the basic abstractions between app and net for their coordination (net -> app feedback, and app->net command/hint) should be important abstractions and hence a more organized effort here can be quite valuable.

YOUNG>> Information abstraction to scale is one of the key CSO research goals.  We need to tackle network abstraction mechanism as well we application resource abstraction.

Thanks.

Richard

Best Regards,
Young

cso mailing list

[email-masked]<mailto:[email-masked]>