Subject: Re: [cuss] "package" vs "purpose" name in draft-ietf-cuss-sip-uui-04

From: Alan Johnston <[email-masked]>
Date: Fri, 17 Feb 2012 14:49:57 -0600

Celine,

Are you looking for a adding a statement to the draft such as:

A request or response may contain multiple User-to-User header fields containing uui-data for different packages.  A request or response may also contain multiple User-to-User header fields containing uui-data for the same package, if that package allows this.  The rules for how many User-to-User header fields of a package may be present in a request or a response are defined for each package.

- Alan -

On Jan 5, 2012, at 11:05 AM, <[email-masked]> <[email-masked]> wrote:

> Hello,
>  
> Please find an additional comment on draft-ietf-cuss-sip-uui-04, I hope it would not too late:
>  
> We would like to raise that it seems to us that it is not clear enough that multiple User-to-User headers set to different package values are allowed in the same message. There is a precision on how many User-to-User headers can be present for a given package (“The rules for how many User-to-User header field of each package may be present in a request or a response are defined for each package be present in a request or a response are defined for each package.” in section 4.1), but no precision on the possibility to have in parallel multiple User-to-User headers set to different package values. Would it be possible to give this possibility in the draft in a general way?
>  
> Regards,
>  
> Celine Serrut-Valette
> Orange Labs
>  
>  
> De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
> Envoyé : mardi 13 décembre 2011 14:58
> À : MARJOU Xavier RD-CORE-LAN; [email-masked]
> Objet : Re: [cuss] "package" vs "purpose" name in draft-ietf-cuss-sip-uui-04
>  
> Hi all,
>  
> for sure a package is used for a certain purpose. So I agree with Xavier, for the solution itself it doesn't matter if the parameter name is 'package' or 'purpose', however the name 'purpose' would provide a certain degree of backward compatibility.
>  
> Regards, Martin
>  
>  
>  
>  
> Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Xavier Marjou
> Gesendet: Freitag, 9. Dezember 2011 15:50
> An: [email-masked]
> Betreff: [cuss] "package" vs "purpose" name in draft-ietf-cuss-sip-uui-04
> 
> Hi,
>  
> Regarding draft-ietf-cuss-sip-uui-04, one modification I would like is to rename the “package” parameter name into “purpose” which existed until draft-ietf-cuss-sip-uui-00. The goal would to allow compatibility with already deployed implementations that are based on the draft-johnston individual draft (draft referenced since a long time in 3GPP documents). There would be no change regarding the semantics: the goal of the defined parameter is to indicate the purpose of the application usage of UUI data and this can be fulfilled by a parameter called “purpose”, in order to indicate how and why UUI data is used.
>  
> Cheers,
> Xavier
> _______________________________________________
> cuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cuss

---

From: <[email-masked]>
Date: Mon, 27 Feb 2012 17:05:22 +0100

Hello,

Thanks a lot for your answer. Your proposal gives the expected clarification on multiple User-to-User headers in the draft.

Could you, if possible, give us your feedback on the first point raised by Xavier Marjou in December regarding the name of the parameter to indicate the purpose of the application usage of UUI? Indeed, moving back to the initial parameter name "purpose" would allow compatibility with already deployed implementations and would not change anything in the semantics and the meaning of the parameter. Thanks in advance for your feedback.

Regards,

Celine Serrut-Valette

Orange Labs

De : Alan Johnston [mailto:[email-masked]] 
Envoyé : vendredi 17 février 2012 21:50
À : SERRUT-VALETTE Celine RD-CORE-ISS
Cc : [email-masked]
Objet : Re: [cuss] "package" vs "purpose" name in draft-ietf-cuss-sip-uui-04

Celine,

- Alan -

Hello,

We would like to raise that it seems to us that it is not clear enough that multiple User-to-User headers set to different package values are allowed in the same message. There is a precision on how many User-to-User headers can be present for a given package ("The rules for how many User-to-User header field of each package may be present in a request or a response are defined for each package be present in a request or a response are defined for each package." in section 4.1), but no precision on the possibility to have in parallel multiple User-to-User headers set to different package values. Would it be possible to give this possibility in the draft in a general way?

Regards,

Celine Serrut-Valette

Orange Labs

Hi all,

Regards, Martin

	 

________________________________

	Hi,

	Regarding draft-ietf-cuss-sip-uui-04, one modification I would like is to rename the "package" parameter name into "purpose" which existed until draft-ietf-cuss-sip-uui-00. The goal would to allow compatibility with already deployed implementations that are based on the draft-johnston individual draft (draft referenced since a long time in 3GPP documents). There would be no change regarding the semantics: the goal of the defined parameter is to indicate the purpose of the application usage of UUI data and this can be fulfilled by a parameter called "purpose", in order to indicate how and why UUI data is used.

	Cheers,

	Xavier

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 27 Feb 2012 18:31:42 +0100

The answers I gave were obviously from the perspective of the editor of the ISDN package draft.

As regards the naming of the header field parameter, I regard the prime source of this as the ABNF which appears in the generic mechanism draft, and the ISDN package draft will follow whatever the generic mechanism draft states.

Obviously this cannot appear in the ISDN package draft until that determination has been made.

I would note that the name of the parameter has varied over the years so it is very specific to version an implementation has been build against:

draft-johnston-sipping-cc-uui-00, -01

no parameters at all

draft-johnston-sipping-cc-uui-02, -03, -04, -05, -06, -07

only the encoding header field parameter

draft-johnston-sipping-cc-uui-08, -09, draft-johnston-cuss-sip-uui-00, -01, draft-ietf-cuss-sip-uui-00

encoding, content and purpose header field parameters

draft-ietf-cuss-sip-uui-01, 02

"purpose" changed to "app"

draft-ietf-cuss-sip-uui-03, -04

"app" changed to "package"

One thing to note with regard to interoperability is that all versions that have contained a parameter of any form have shown examples with lower case hex encodings. So which version or versions are we trying to main compatibility with?

At the end of the day, I personally do not mind what it is called - but we do need a parameter (with an appropriate name) to cater for the package concept (which is written into the charter) and I would certainly resist going back to the "app" name which caused the name to be used in the document with two different semantics.

Regards

Keith

________________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 27 February 2012 16:05
To: [email-masked]
Cc: [email-masked]
Subject: Re: [cuss] "package" vs "purpose" name in draft-ietf-cuss-sip-uui-04

Hello,

Regards,

Celine Serrut-Valette
Orange Labs

Celine,

- Alan -

Hello,

 
Regards,
 
Celine Serrut-Valette
Orange Labs

Hi all,

Regards, Martin

 
________________________________________
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Xavier Marjou
Gesendet: Freitag, 9. Dezember 2011 15:50
An: [email-masked]
Betreff: [cuss] "package" vs "purpose" name in draft-ietf-cuss-sip-uui-04
Hi,

Cheers,
Xavier

---

From: Alan Johnston <[email-masked]>
Date: Mon, 27 Feb 2012 11:51:54 -0600

Keith is right - we have changed the parameter names a bunch of times
to try to find ones that were a good fit.

Package seems to be a good fit.  I would be very reluctant to change
it back to any of the other old ones.  If there is a new name that is
an even better fit, then I'm open to that, but it would have to be a
really good name!

- Alan -

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 27 Feb 2012 12:59:07 -0500

> an even better fit, then I'm open to that, but it would have to be a

XYZZY ? :-)

	Thanks,
	Paul

---

From: <[email-masked]>
Date: Tue, 28 Feb 2012 14:07:25 +0100

Hello,

Thank you for your answers. 
We think that what is important is the definition we give to the parameter and the fact that its name matches to this definition, more than the name itself. "purpose" is a relevant name if the parameter is defined as to indicate the purpose of the package mechanism used to convey the IUU data. Moreover it has the benefit to be backward compatible with historical draft-johnston-sipping-cc-uui-08 on which some implementations are based.

Regards,

Celine Serrut-Valette
Orange Labs

-----Message d'origine-----
De : Alan Johnston [mailto:[email-masked]] 
Envoyé : lundi 27 février 2012 18:52
À : DRAGE, Keith (Keith)
Cc : SERRUT-VALETTE Celine RD-CORE-ISS; [email-masked]
Objet : Re: [cuss] "package" vs "purpose" name in draft-ietf-cuss-sip-uui-04

- Alan -