Subject: [cuss] Change of "package" to "purpose" in Mechanism

From: Alan Johnston <[email-masked]>
Date: Fri, 13 Apr 2012 11:18:36 -0500

At IETF-83, we had discussion about the syntax of the package
parameter, currently called "package" in draft-ietf-cuss-sip-uui-05.

In order to accommodate some existing implementations that use the
"purpose" parameter from draft-ietf-cuss-sip-uui-00, the consensus of
the room was to change the syntax name of the parameter back to
"purpose", but to retain all the current text and semantics about UUI
packages.   As a result, the change to the draft would just be
changing from:

pkg-param   = "package" EQUAL token

to:

pkg-param   = "purpose" EQUAL token

in the ABNF.  We would also include an explanation for why this is the case.

If there are any objections to this, please respond immediately to the
list as the authors plan to revise the draft with this change in a few
days.

- Alan -

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Sat, 14 Apr 2012 02:32:58 +0200

This is the change that also has impact on the uui-isdn package document. Assuming there are no objections I'll also make the obvious changes to this document. Note this is only the change of the name of the header field parameter where it is used in the document, otherwise usages of the term "package" remain.

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Alan Johnston
> Sent: 13 April 2012 17:19
> To: [email-masked]
> Subject: [cuss] Change of "package" to "purpose" in Mechanism
> 
> _______________________________________________
> cuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cuss

---

From: Laura Liess <[email-masked]>
Date: Tue, 17 Apr 2012 11:55:08 +0200

Hi Alan,

We (deutsche Telekom) agree to either "purpose" or "package", if the final
decision is taken within the next days. Our current implementation order to
the our vendor requires "package", but we still can change this within the
next few days. After that we have to pay a lot for the change.

Thanks a lot
Laura

2012/4/13 Alan Johnston <[email-masked]>

---

From: Andrew Allen <[email-masked]>
Date: Tue, 17 Apr 2012 10:09:28 +0000

Can we please make a decision on making the change to purpose as soon as possible.

It has been over 2 weeks since the WG session decided that using purpose was what we should do providing there were no objections on the list.

Andrew

From: Laura Liess [mailto:[email-masked]]
Sent: Tuesday, April 17, 2012 04:55 AM
To: Alan Johnston <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [cuss] Change of "package" to "purpose" in Mechanism

Hi Alan,

We (deutsche Telekom) agree to either "purpose" or "package", if the final decision is taken within the next days. Our current implementation order to the our vendor requires "package", but we still can change this within the next few days. After that we have to pay a lot for the change.

Thanks a lot
Laura

2012/4/13 Alan Johnston <[email-masked]<mailto:[email-masked]>>
At IETF-83, we had discussion about the syntax of the package
parameter, currently called "package" in draft-ietf-cuss-sip-uui-05.

to:

- Alan -
_______________________________________________
cuss mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cuss

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.