Subject: [dane] The DANE list and psudonmyms...

From: Warren Kumari <[email-masked]>
Date: Sun, 16 Jun 2013 18:52:15 -0400

Hi there,

I suspect that this might be a contentious call, but I feel that it is well within my rights as a chair. I have not spoken with my co-chair about this, so if there is a kerfuffle / centi-thread on discuss@, it is my fault :-P

I would prefer that participants not use pseudonyms on the DANE list. As an IETF participant contributions fall under the Note Well -- having contributions coming from a name that is obviously a pseudonym "feels" wrong, and I'm concerned about the IPR implications.

Now, obviously fairly much all of the identities participating *could* be pseudonyms (e.g has anyone seen John C. Klensin's drivers license / passport?), but most of the participants / identities hare are known (e.g. I know and have met the entry that uses the label Richard Barnes -- no clue if that is his legal name, but I have no reason to suspect it isn't).

W

--
"When it comes to glittering objects, wizards have all the taste and self-control of a deranged magpie."
-- Terry Pratchett

---

From: DANE <[email-masked]>
Date: Mon, 17 Jun 2013 08:52:07 +0200

On Mon, Jun 17, 2013, at 12:52 AM, Warren Kumari wrote:
> Hi there,
> 
> I suspect that this might be a contentious call, but I feel that it is
> well within my rights as a chair. I have not spoken with my co-chair
> about this, so if there is a kerfuffle / centi-thread on discuss@, it is
> my fault :-P
> 
> I would prefer that participants not use pseudonyms on the DANE list. As
> an IETF participant contributions fall under the Note Well -- having
> contributions coming from a name that is obviously a pseudonym "feels"
> wrong, and I'm concerned about the IPR implications.
> 
> Now, obviously fairly much all of the identities participating *could* be
> pseudonyms (e.g has anyone seen John C. Klensin's drivers license /
> passport?), but most of the participants / identities hare are known
> (e.g. I know and have met the entry that uses the label Richard Barnes --
> no clue if that is his legal name, but I have no reason to suspect it
> isn't).

So basically you're saying that as long as a name appears to be a real
one then it's okay, whilst anything that obviously isn't a real name is
not ? How will that judgement be made ? If for example someone called
'Poo Ann Wee' from Singapore registers how will you tell if it's fake or
not ? 

Closed Shops have been illegal in the UK since 1990 btw ;)
http://en.wikipedia.org/wiki/Closed_Shop

n>

---

From: Olaf Kolkman <[email-masked]>
Date: Mon, 17 Jun 2013 10:04:17 +0200

> http://en.wikipedia.org/wiki/Closed_Shop

I can't speak for Warren. But IMHO we have to keep the Note-Well seriously. If folk contribute technology to the IETF it would be could if we (collectively) have a reasonable idea who those folk are.

It would be very painful if in the future I'd be implementing technology that was brought to the IETF by [email-masked] and I found I was being sued by a very real legal entity by infringing their patents.

It is off course not the case that everybody has to know everybody but if we _collectively_ do not know who is behind [email-masked] then I start to feel uncomfortable about using the technology, specifically if the contributions are highly innovative and competent and thus patentable.

For debates like this, or any other process issue, I really do not care if you use Pseudonyms or not[*].

--Olaf Kolkman
  NLnet Labs

PS. As many people on the DANE list will appreciate this is not a technical issue but a trust issue. I am not proposing mechanisms that involve authentications, I-Ds and what have you but I personally would appreciate people to be forthcoming.

[*] I know that [email-masked] has commented on some IETF discussions in the past.

---

From: DANE <[email-masked]>
Date: Mon, 17 Jun 2013 10:24:11 +0200

On Mon, Jun 17, 2013, at 10:04 AM, Olaf Kolkman wrote:
> I can't speak for Warren. But IMHO we have to keep the Note-Well
> seriously. If folk contribute technology to the IETF it would be could if
> we (collectively) have a reasonable idea who those folk are.
> 
> It would be very painful if in the future I'd be implementing technology
> that was brought to the IETF by [email-masked] and I found
> I was being sued by a very real legal entity by infringing their patents.
> 
> It is off course not the case that everybody has to know everybody but if
> we _collectively_ do not know who is behind [email-masked] then I
> start to feel uncomfortable about using the technology, specifically if
> the contributions are highly innovative and competent and thus
> patentable.
> 
> PS. As many people on the DANE list will appreciate this is not a
> technical issue but a trust issue. I am not proposing mechanisms that
> involve authentications, I-Ds and what have you but I personally would
> appreciate people to be forthcoming.
> 
> 
> 

So if it's trust you want then I guess we'll need to find an anchor for
that. Trusted domain names, people's real names, now where have I heard
that stuff before...

Oh, let's have a new DNS RRTYPE 0wnr
Is this a technical discussion now ?

n>

---

From: Olaf Kolkman <[email-masked]>
Date: Mon, 17 Jun 2013 10:38:34 +0200

On Jun 17, 2013, at 10:24 AM, DANE <[email-masked]> wrote:

>> [...]

I had hoped that that sense of irony came through in the first line of the PS.

> Is this a technical discussion now ?

Nope, I believe this is a serious issue that can be solve when people are forthcoming. There could be reasons not to be forthcoming but those should be rare, specifically when providing technical and patentable contributions.

--Olaf

---

From: SM <[email-masked]>
Date: Mon, 17 Jun 2013 03:07:40 -0700

>not ? How will that judgement be made ? If for example someone called

Yes. :-)

>'Poo Ann Wee' from Singapore registers how will you tell if it's fake or

dig TXT Poo%20Ann%20Wee.sg.profile.gmail.com

Regards,
-sm

P.S. The message was likely about making a good faith effort to 
provide information to the DANE WG Chairs so that they can assess 
whether there might be IPR issues.

---

From: Warren Kumari <[email-masked]>
Date: Mon, 17 Jun 2013 10:44:29 -0400

On Jun 17, 2013, at 6:07 AM, SM <[email-masked]> wrote:

> P.S. The message was likely about making a good faith effort to provide information to the DANE WG Chairs so that they can assess whether there might be IPR issues. 

Yup -- when the lawyers come a knockin' I want to be able to say (in good faith :-)) that I tried to enforce the Note Well. Having an obvious "That's not a real person" would make that, um, implausible.

W

> _______________________________________________
> dane mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dane
> 

--
There were such things as dwarf gods. Dwarfs were not a naturally religious species, but in a world where pit props could crack without warning and pockets of fire damp could suddenly explode they'd seen the need for gods as the sort of supernatural equivalent of a hard hat. Besides, when you hit your thumb with an eight-pound hammer it's nice to be able to blaspheme. It takes a very special and straong-minded kind of atheist to jump up and down with their hand clasped under their other armpit and shout, "Oh, random-fluctuations-in-the-space-time-continuum!" or "Aaargh, primitive-and-outmoded-concept on a crutch!"
  -- Terry Pratchett