Subject: [dane] Fwd: New Version Notification for draft-dane-registry-acronym-00.txt

From: Olafur Gudmundsson <[email-masked]>
Date: Fri, 9 Aug 2013 10:19:25 -0400

Posted as individual submission. 
Willing to repost as WG document if chairs allow

	Olafur

Begin forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-dane-registry-acronym-00.txt
> Date: August 9, 2013 10:17:25 AM EDT
> To: Olafur Gudmundsson <[email-masked]>
> 
> 
> A new version of I-D, draft-dane-registry-acronym-00.txt
> has been successfully submitted by Olafur Gudmundsson and posted to the
> IETF repository.
> 
> Filename:	 draft-dane-registry-acronym
> Revision:	 00
> Title:		 Harmonizing how applications specify DANE-like usage
> Creation date:	 2013-08-09
> Group:		 Individual Submission
> Number of pages: 4
> URL:             http://www.ietf.org/internet-drafts/draft-dane-registry-acronym-00.txt
> Status:          http://datatracker.ietf.org/doc/draft-dane-registry-acronym
> Htmlized:        http://tools.ietf.org/html/draft-dane-registry-acronym-00
> 
> 
> Abstract:
>   Experience has show that people get confused using the three numeric
>   fields the TLSA record.  This document specifies descriptive acronyms
>   for the three numeric fields in the TLSA records.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Scott Schmit <[email-masked]>
Date: Fri, 9 Aug 2013 22:10:08 -0400

> >   for the three numeric fields in the TLSA records.

I do find myself a little puzzled that we feel this is necessary --
nobody is calling for this for DNSKEY, RRSIG, or DS records?

Anyway, we aren't generating acronyms for the numbers -- we're
identifying enumeration values.

In Table 2, "Hash" should be "SPKI", "Full" should probably be "Cert".
In Table 3, "NoHash" should be "Full".

I'm not convinced that Priv* will see enough use to be worth making an
enumeration value for them. If you're going to have them, "PrivHash"
needs to be "PrivMatch".

Otherwise you'll end up with weird things like:
* PKIX-CA Hash NoHash
* DANE-EE Full SHA2-256
* DANE-TA Full NoHash

instead of:
* PKIX-CA SPKI Full
* DANE-EE Cert SHA2-256
* DANE-TA Cert Full

Other questions not addressed in the draft:
* Case sensitive or not?
* Probably should show some examples of use?
* Can I mix enumerations with the numbers?
* What if the enumerations are used out of order?

-- 
Scott Schmit

---

From: John Gilmore <[email-masked]>
Date: Sat, 10 Aug 2013 12:34:03 -0700

> nobody is calling for this for DNSKEY, RRSIG, or DS records?

If nobody is adopting your hard-fought standard to secure the Web,
perhaps it's time to rearrange the deck chairs, just in case that's
why the ship is sinking.

	John

---

From: Olafur Gudmundsson <[email-masked]>
Date: Sun, 11 Aug 2013 12:40:22 -0400

On Aug 9, 2013, at 10:10 PM, Scott Schmit <[email-masked]> wrote:

> ]

Because the registries had acronym's from day one there.

> _______________________________________________
> dane mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dane