Subject: [dane] I-D Action: draft-ietf-dane-registry-acronyms-03.txt

From: [email-masked]
Date: Mon, 06 Jan 2014 14:45:41 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the DNS-based Authentication of Named Entities Working Group of the IETF.

        Title           : Adding acronyms to simplify DANE conversations
        Author          : Olafur Gudmundsson
	Filename        : draft-ietf-dane-registry-acronyms-03.txt
	Pages           : 5
	Date            : 2014-01-06

Abstract:
   Experience has show that people get confused using the three numeric
   fields the TLSA record.  This document specifies descriptive acronyms
   for the three numeric fields in the TLSA records.  This document
   updates the format of the IANA registry created by RFC6698.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dane-registry-acronyms/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-dane-registry-acronyms-03

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-dane-registry-acronyms-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Warren Kumari <[email-masked]>
Date: Mon, 6 Jan 2014 18:28:15 -0500

>  This draft is a work item of the DNS-based Authentication of Named Entities Working Group of the IETF.

This just adds a note to the abstract explaining that it updates the
format of the registry in RFC6698 (to keep the nitter happy...)
W

> _______________________________________________
> dane mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dane

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 09 Jan 2014 01:41:48 +0000

Thanks for that. I've requested IETF last call as-is
since I don't have a problem with the current acronyms
nor a startlingly better alternative.

I've a couple of nits, its fine to fix 'em anytime.

section 1:
- s/confused as what/confused as to what/
- s/column with acronym/column with an acronym/

section 2:
- maybe s/upper or lower/upper, mixed or lower/ ?

Cheers,
S.

---

From: Olafur Gudmundsson <[email-masked]>
Date: Thu, 16 Jan 2014 15:49:43 -0500

> - s/column with acronym/column with an acronym/
Fixed 

> - maybe s/upper or lower/upper, mixed or lower/ ?

applied 

thanks
	Olafur

---

From: Viktor Dukhovni <[email-masked]>
Date: Fri, 17 Jan 2014 03:41:43 +0000

> > - s/column with acronym/column with an acronym/

While you're still taking fixes of this sort:

diff --git a/draft-ietf-dane-registry-acronyms-03.xml b/draft-ietf-dane-registry-acronyms-03.xml
index b75515a..27d1d66 100644
--- a/draft-ietf-dane-registry-acronyms-03.xml
+++ b/draft-ietf-dane-registry-acronyms-03.xml
@@ -38,9 +38,9 @@
       <workgroup>DANE</workgroup>
       
       <abstract>
-	<t>Experience has show that people get confused using the three
-	numeric fields the TLSA record. This document specifies
-	descriptive acronyms for the three numeric fields in the TLSA
+	<t>Experience has shown that people get confused using the three
+	numeric fields in the TLSA record. This document specifies
+	descriptive acronyms for the three numeric fields in TLSA
 	records. 
 	  This document updates the format of the IANA registry created by RFC6698.
 	</t> 
@@ -50,11 +50,12 @@
   <middle>
     <section title="Introduction"> 
       <t> During discussions on how to add DANE <xref target="RFC6698"/> 
-	technology to new protocols/services people repeatedly have
-	got confused as what the numeric values stand for and even 
-	the order of the fields of a TLSA record.
-	This document updates the IANA registry definition for TLSA
-	record to add a column with acronym for each specified field, in order to reduce confusion. 
+	technology to new protocols/services people have repeatedly
+	been confused as what the numeric values stand for and even 
+	the order of the fields in a TLSA record.
+	This document updates the IANA registry definition of the TLSA
+	record to add a column with an acronym for each specified field, so
+	as to reduce confusion. 
 	This document does not change the DANE protocol in any way. 
       </t> 
       <t>It is expected that DANE parsers in applications and DNS
@@ -168,8 +169,8 @@
       <section title="Acronym use in a specification example:"> 
 	<t>
 	  Protocol FOO only allows
-	TLSA records using PKIX-EE and DANE-EE, with selector SPKI and
-	using SHA2-512. </t>
+	TLSA records using PKIX-EE(1) and DANE-EE(3), with selector SPKI(1) and
+	using SHA2-512(2). </t>
 <!--      <t> Sides example: "In the case of FOO for practical cases you
 	can treat PKIX-CA == DANE-TE" (see talk at IETF-87 on DANE for
 	email)  </t>  -->
@@ -185,7 +186,7 @@
   <section title="Acknowledgements"> 
       <t>Scott Schmit offered real good suggestions to decrease the 
 	possibility of confusion. Viktor Dukhovni provided comments
-	from expert point of view. Jim Schaad, Wes Hardaker and Paul
+	from an implementor's viewpoint. Jim Schaad, Wes Hardaker and Paul
 	Hoffman provided feedback during WGLC. 
       </t>
   </section> 

-- 
	Viktor.

---

From: Olafur Gudmundsson <[email-masked]>
Date: Tue, 21 Jan 2014 19:56:43 -0500

Viktor, 

> +++ b/draft-ietf-dane-registry-acronyms-03.xml

This looks good I will propose that we apply it, before the document pops out as an RFC. 

Same here, 

Much better 

Same here 
> 	Viktor.

Thanks for suggestions. 

	Olafur