Subject: [dane] SMIMEA test vectors

From: "Garfinkel, Simson L." <[email-masked]>
Date: Mon, 4 Jan 2016 15:22:19 +0000

Greetings,

Are there any public SMIMEA test vectors?  I’m looking for DANE SMIMEA records that I can use to get an S/MIME certificate, send and email message that’s (optionally) encrypted, and get a response that’s digitally signed.

Regards,

Simson

---

From: "Osterweil, Eric" <[email-masked]>
Date: Mon, 4 Jan 2016 21:13:20 +0000

> On Jan 4, 2016, at 10:22 AM, Garfinkel, Simson L. <[email-masked]> wrote:
> 
> Greetings,
> 

Hey Simson,

There are libsmaug and its associated Thunderbird Plugin:
	https://github.com/verisign/smaug
	https://github.com/verisign/smaug-tbird-plugin

The library should easily be useable to implement a test harness.

Eric

---

From: "Garfinkel, Simson L." <[email-masked]>
Date: Mon, 4 Jan 2016 21:58:14 +0000

Hi Eric,

Thanks for pointing me at this. I’m actually writing a second SMIMEA implementation that is specifically created to be a test harness, so I’m looking actually looking for test vectors in the public DNS, rather than a reference implementation.  Are there SMIMEA announcements for any VeriSign email addresses?

While I have your attention — which are the SMIMEA key usages that make sense?  Several of them seem nonsensical.  For example, how would a matching type of 1 be used?  Do you anticipate that anyone will use a selector of 1?

Simson

> On Jan 4, 2016, at 4:13 PM, Osterweil, Eric <[email-masked]> wrote:
> 
>