Subject: Re: [datatracker-rqmts] Last Call: <draft-ietf-genarea-charter-tool-07.txt> (Requirements for a Working Group Charter Tool) to Informational RFC

From: Robert Sparks <[email-masked]>
Date: Tue, 15 Mar 2011 17:20:51 -0500

Hi Paul -

In section 2.2, I would prefer either using the names the tracker currently uses for IESG evaluation:
"Discuss" and "Comment", or some set of words that do not intersect those, perhaps "Blocking" and
"Not-Blocking". The current set ("discuss" and "regular") will lead to confusion.

In section 2.7, you don't specifically capture WGs that currently exist, but are not rechartering at the moment.
I think you meant to as part of the second paragraph, but the last phrase could be read to be exclusive.

(As an aside - do you intend that for existing working groups, this history will go all the way back to when
the group was formed? Will we be able to count on <foo-charter-00> being the charter that the working group
formed with for all foo?)

In section 3.1 - It would be better to have the ability to override the tool's rejection of a name because some
previous effort (particularly abandoned ones) had the same name. If someone thought about using a name
5 years ago, but never took it even to the point of Internal Review, why should the tool force it not be be used now?
This is a place that human judgement should be allowed to be exercised.

Also, we should make sure the tool doesn't unintentionally make reopening a closed WG harder than intended.

It would help to clarify in the first bullet in 3.1 that the tool should prompt the AD, but not prevent them from
completing the move if that's the right thing to do. (The tool is providing a reminder, not enforcing a rule).

In the 4th bullet of that list, you ask the tool to send a note to the scretariat to schedule discussion on a telechat.
In practice today, this happens as part of the transition into External Review. I suggest moving the sentence into
the 3rd bullet.

In section 3.2's second bullet, it is possible, I believe, to directly approve a recharter from internal review. The tool
should allow that transition.

I'm a little concerned about taking working groups for which a recharter is being considered out of the state named
"WG Exists". Semantically, if you aren't in that state, it implies the WG doesn't exist, and I could see someone
drawing the wrong conclusion from a search. The best way to avoid this might be to rename the "WG Exists" state
to something like "WG Chartered - no rechartering effort currently in progress" (which I realize is too wordy).

RjS

On Mar 11, 2011, at 4:11 PM, The IESG wrote:

> 
> The IESG has received a request from the General Area Open Meeting WG
> (genarea) to consider the following document:
> - 'Requirements for a Working Group Charter Tool'
>  <draft-ietf-genarea-charter-tool-07.txt> as an Informational RFC
> 
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2011-03-25. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
> 
> The file can be obtained via
> http://datatracker.ietf.org/doc/draft-ietf-genarea-charter-tool/
> 
> IESG discussion can be tracked via
> http://datatracker.ietf.org/doc/draft-ietf-genarea-charter-tool/
> 
> 
> 
> No IPR declarations have been submitted directly on this I-D.
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 18 Mar 2011 17:57:58 -0700

> Hi Paul -

Thanks again for the copious comments; they are greatly appreciated.

> "Not-Blocking". The current set ("discuss" and "regular") will lead to confusion.

Changed to "blocking" and "non-blocking". (I'm not a big fan of gratuitous capitalization, as exemplified by "a DISCUSS"...)

> I think you meant to as part of the second paragraph, but the last phrase could be read to be exclusive.

Yeeps; fixed.

> formed with for all foo?)

I have no idea. That's why I use the waffle-words "as much information as is currently known...that can be done in a mostly-automated fashion". It's up to the IAOC to decide how much effort to throw at that part.

> This is a place that human judgement should be allowed to be exercised.

Fixed. Changed "so the tool will tell the AD if the acronym that is being proposed has been used in earlier WG charter proposals and prevent its use" to "so the tool will warn the AD if the acronym that is being proposed has been used in earlier WG charter proposals and suggest against its use".

> Also, we should make sure the tool doesn't unintentionally make reopening a closed WG harder than intended.

I think that is covered above.

> completing the move if that's the right thing to do. (The tool is providing a reminder, not enforcing a rule).

Done.

> In practice today, this happens as part of the transition into External Review. I suggest moving the sentence into

That was not my reading of the current IESG procedures. Let me talk that one over with the IESG.

> should allow that transition.

Added.

> to something like "WG Chartered - no rechartering effort currently in progress" (which I realize is too wordy).

Yes, wordy. Currently, that list is followed by "All states above, except for "WG exists", are given the annotation "Rechartering"." Would it suffice to change the annotation to "WG continuing during rechartering" or something of that ilk?

--Paul Hoffman