Subject: [Dclc] Fwd: Re: Toronto meeting

From: Bob Briscoe <[email-masked]>
Date: Thu, 19 Jun 2014 11:11:00 +0100

Lingli,

If appropriate I could also present our work on 
Network Performance Isolation in Data Centres 
using Congestion Policing (needs 10mins).
<http://tools.ietf.org/html/draft-briscoe-conex-data-centre-02>

I've presented it before, but only in the ConEx WG.
<http://www.bobbriscoe.net/presents/1307ietf/1307-conex-data-centre.pdf>
And it's been redesigned so guests don't need 
ConEx any more. And they don't even need ECN 
either - any non-ECN packets are tunnelled 
between the sending and receiving hypervisor.

Bob

>Date: Thu, 19 Jun 2014 10:20:37 +0100
>To: =?gb2312?B?tcvB6cDyL0xpbmdsaSBEZW5n?= <[email-masked]>
>From: Bob Briscoe <[email-masked]>
>Subject: Re: [Dclc] Toronto meeting
>Cc: "'dclc'" <[email-masked]>, Richard 
>Scheffenegger <[email-masked]>, Mirja KUEHLEWIND 
><[email-masked]>
>
>Lingli,
>
>Myself, Richard Scheffeneger (NetApp) & Mirja 
>Kuehlewind (Stuttgart Uni) are about to post a 
>revised draft on our proposed approach to replace TCP's ECN feedback.
>
>It would probably be worth a reasonably long 
>slot to present this (20mins or more?). We will 
>also be asking to present it in the tcpm where 
>it addresses a chartered IETF work item, but we 
>ought to present its "research enablement" angle in more depth in the IRTF.
>
>The original problem we addressed was motivated 
>by the flawed feedback scheme in DCTCP and the needs of ConEx.
>
>However, we have designed it to be a generic 
>feedback reflector that will allow new sender 
>behaviours to be deployed unilaterally without 
>having to deploy new receiver behaviour each 
>time too. We're looking for feedback on whether 
>it is generic enough for all the ideas people 
>might have for using it (I'm working on 5 myself).
>
>
>Bob
>
>At 06:38 18/06/2014, Songhaibin (A) wrote:
>>Dear Lingli,
>>
>>Thant you for organizing this meeting. I'm 
>>preparing a relative draft on TCP parameter 
>>control and would like to present at the DCLC meeting.
>>
>>Best Regards!
>>-Haibin
>>
>> > -----Original Message-----
>> > From: Dclc [mailto:[email-masked]] On Behalf Of µËÁéÀò/Lingli Deng
>> > Sent: Wednesday, June 18, 2014 1:06 PM
>> > To: 'dclc'
>> > Cc: 'Fred Baker (fred)'
>> > Subject: Re: [Dclc] Toronto meeting
>> >
>> > Guys,
>> >
>> > Let's start preparing for our first meeting. ^-^ The following topics are
>> > summarized from an earlier thread
>> > (http://www.ietf.org/mail-archive/web/dclc/current/msg00003.html).
>> >
>> > 1, Production data sharing
>> > 2, Problem statement/analysis
>> > 3, Solutions
>> > 4, Research/experimental tools
>> >
>> > Please kindly feedback your interests and suggestions.
>> >
>> > BTW, if you are preparing a 
>> draft/presentation for dclc@irtf next month, it
>> > would be great to let us know now.
>> >
>> > Cheers,
>> > Lingli
>> >
>> > > -----Original Message-----
>> > > From: Dclc [mailto:[email-masked]] On Behalf Of Eggert, Lars
>> > > Sent: Tuesday, June 17, 2014 11:09 PM
>> > > To: dclc
>> > > Subject: [Dclc] Toronto meeting
>> > >
>> > > Hi,
>> > >
>> > > please operate under the assumption that you'll have a room for a side
>> > > meeting in Toronto. It's time to discuss what to *do* with that slot.
>> > >
>> > > Lars
>> >
>> >
>> >
>> > _______________________________________________
>> > Dclc mailing list
>> > [email-masked]
>> > https://www.irtf.org/mailman/listinfo/dclc
>>_______________________________________________
>>Dclc mailing list
>>[email-masked]
>>https://www.irtf.org/mailman/listinfo/dclc
>
>________________________________________________________________
>Bob Briscoe,                                                  BT

________________________________________________________________
Bob Briscoe,                                                  BT

---

From: Wenbo Mao <[email-masked]>
Date: Thu, 19 Jun 2014 19:20:34 +0800

Dear Lingli and DCLC Community Colleagues,

I am Wenbo Mao of DaoliCloud Company in Beijing, joining this mailing 
list with great interest in DCLC topics. (Thank you Lingli for leading 
me to this community!)

If possible, I would like to present a topic in Toronto in the following 
title and abstract:

Title: Network Virtualization Infrastructure (NVI): A Scalable and 
Interoperable Cloud Network

Abstract:
Today’s technologies for constructing large scale cloud network, or 
“virtual private cloud” (VPC), unanimously resort to network tunnel 
protocol technologies by labelling and encapsulating network packets. 
This style of tunneling has a strong flavor of physical wiring hardware 
machines, really belonging to pre-cloud networking for physical 
machines. Unfortunately, packets labelling/encapsulation based tunneling 
technologies have quite poor scalabilities and probably little hope for 
cloud interoperability as a result that a tunnel protocol is forced to 
run at fixed "virtual tunnel endpoints (VTEPs)" . Cloud computing as 
service must operate in economy of scale and therefore follow the 
established principle of distributed computing for scalability. We 
propose a novel network virtualization technology: Network 
Virtualization Infrastructure (NVI). NVI creates and maintains context 
flow based virtual channel for communication nodes only when they are in 
communication. Without physical wiring style of tunneling, can not only 
network forwarding resource in NVI be better utilized, but more 
importantly cloud overlay networks be decoupled from the underlying 
physical network, e.g., be decoupled from fixed "virtual tunnel 
endpoints" like traffic hot and/or choke points. These properties 
translate to an unbound scalability and interoperability for cloud networks.

Best wishes,
Wenbo Mao, Ph.D.
CEO, DaoliCloud Company
Beijing
www.daolicloud.com

> > BTW, if you are preparing a draft/presentation for dclc@irtf next 
> month, it