Subject: [dcon] DCON and Media

From: Alan Johnston <[email-masked]>
Date: Thu, 10 Nov 2011 11:50:54 -0600

I am greatly looking forward to getting started on the DCON work.  Thanks to everyone who has worked on the comprehensive set of drafts. 

I have one high level question about the work. Having read the DCON framework and requirements drafts, I understand how state will be shared among the distributed elements. However, I am not clear on the media sharing which needs to happen for any DCON conference. 

In a few places, the drafts say media mixing is out of scope, but we do need to define how it will work in the simple cascaded case, right?  I can see how mixing optimization could be deferred for later. 

- Alan -

---

From: Lorenzo Miniero <[email-masked]>
Date: Fri, 11 Nov 2011 20:23:42 +0100

Hi Alan,

On Thu, 10 Nov 2011 11:50:54 -0600

> In a few places, the drafts say media mixing is out of scope, but we do need to define how it will work in the simple cascaded case, right?  I can see how mixing optimization could be deferred for…

Absolutely! Cascaded conferencing is the starting point, especially in terms of mixing, and I agree we'll need to at least say a few words about how it will be supposed to work. Things start to get complicated, though, when involving advanced stuff like distributed video mixing, for instance, and that's what we thought would be out of scope when writing the drafts.

Lorenzo

> - Alan -
> 
> 
> _______________________________________________
> dcon mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dcon

-- 
Lorenzo Miniero, COB

Meetecho s.r.l.
Web Conferencing and Collaboration Tools
http://www.meetecho.com

---

From: Alan Johnston <[email-masked]>
Date: Sun, 13 Nov 2011 19:37:02 -0600

Lorenzo,

Great.  So media mixing is not completely out of scope, but we will
initially only work on the simple cascaded media mixing.

For the future, it might be useful to do this work in stages.  For example:

1. First define simple cascaded media
2. Next, provide ability for a DCON entity to discover the media graph
3. Then define a mechanism for a participant to leave and join the
conference for the purpose of changing their location in the media
graph.  This would prevent having to propagate state changes that the
participant has left the conference, then the participant has joined
the conference when they are just changing their point of attachment.
4. Then provide a way for a DCON entity to request media graph changes
in another DCON entity.

Perhaps we decide to only do 1 and 2, or just 1 in the first round of DCON work.

- Alan -

---

From: Simon Pietro Romano <[email-masked]>
Date: Mon, 14 Nov 2011 07:30:39 +0100

Hi Alan,

that sounds definitely interesting. 1) and 2) look feasible short-term 
goals. 3) and 4) are needed if we want DCON to be as transparent as 
possible to its end-users; I agree with you that these might be 
longer-term goals.

Thank you for the inputs!

Simon

Il 14/11/2011 02:37, Alan Johnston ha scritto:
> On Fri, Nov 11, 2011 at 1:23 PM, Lorenzo Miniero<[email-masked]>  wrote:
>> Hi Alan,
>>
>>
>> Alan Johnston<[email-masked]>  wrote:
>>

-- 
                             _\\|//_
                             ( O-O )
    ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                     Simon Pietro Romano
               Universita' di Napoli Federico II
                  Computer Science Department
         Phone: +39 081 7683823 -- Fax: +39 081 7684219
                 e-mail: [email-masked]
           http://www.comics.unina.it/simonpietro.romano

     <<Molti mi dicono che lo scoraggiamento è l'alibi degli
    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
                          oooO
    ~~~~~~~~~~~~~~~~~~~~~~(   )~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
                           \ (    (   )
                            \_)    ) /
                                  (_/