Subject: [Dcrup] sha1 wall of shame

From: "John R. Levine" <[email-masked]>
Date: 14 Mar 2018 09:28:28 -0400

I went through my mail logs to see who's still signing with rsa-sha1.  I 
wouldn't claim that my system is typical but some of these really should 
know better.

R's.
John

   24 inbound.readersupportednews.org
   21 email.nextdoor.com
   19 marketwatchmail.com
   16 geldenhuyslaw.com
   15 reply.newsmax.com
   15 nytimes.com
   14 dfh-logistics.com
   13 mail.salsalabs.net
   12 sendgrid.info
   12 castingfrontier.com
   11 info.pentondes.com
   10 public.govdelivery.com
   10 mail.ecnmag.com
   10 e.designworldonline.com
    9 sg.actionnetwork.org
    8 infusionmail.com
    8 email.pvhba.com
    8 email.keysight.com
    7 townhallmail.com
    7 mail.advantagebusinessmedia.com
    6 newsletter.newyorker.com
    6 mta-bbcspool.convio.net
    6 memberservices.latimes.com
    6 mail.wirelessdesignmag.com
    6 inside.com
    6 giftpacs.com
    5 mail.rdmag.com
    5 email.engineering360.com
    4 walmart.com
    4 thedailybeast.com
    4 quora.com
    4 ontramail.com
    4 gotowebinar.com
    4 enews.machinedesign.com
    4 care.com
    3 u.harvard.edu
    3 subscriptions.uspto.gov
    3 scr.org
    3 navigatingcancer.com
    3 morning7.theskimm.com
    3 mail.pddnet.com
    3 mail.dmnews.com
    3 email.ucas.com
    3 email.scmagazineus.com
    3 email.microsoftemail.com
    3 ed-email.techtarget.com
    3 e.officedepot.com
    3 credomobile.com
    3 bounce.myngp.com
    3 afsc.org
    2 thomasnet.com
    2 tastingtable.com
    2 sierratradingpost.com
    2 sendgrid.me
    2 reply.ien.com
    2 radiantretailapps.com
    2 purewow.com
    2 peoplesaction.org
    2 newsweek-mail.com
    2 media.ieee.org
    2 mail.inddist.com
    2 flagnotify.com
    2 enews.newequipment.com
    2 emails.underarmour.com
    2 emails.sierraclub.org
    2 email1.easternbank.com
    2 email.zappos.com
    2 email.tablethotels.com
    2 email.fastcompany.com
    2 em.target.com
    2 ebay.com
    2 ealerts.bankofamerica.com
    2 e.outsideonline.com
    2 e.nymag.com
    2 e.medicaldesignandoutsourcing.com
    2 e.massdevice.com
    2 e.fluidpowerworld.com
    2 e.etsy.com
    2 dripemail2.com
    2 cp20.com
    2 broadwaybox.com
    2 bnp-promotions.com
    2 bnp-interactive.com
    2 biologicaldiversity.org
    2 aclusocal.org
    1 yogaaccessories.com
    1 wsj.com
    1 worbix.com
    1 wateremail.com
    1 vresp.com
    1 vox.com
    1 vetdepot.com
    1 ucsusa.org
    1 ucc.org
    1 thedreamcorps.org
    1 swiftpage3.com
    1 standwithsandra.org
    1 socalgas.com
    1 skyscanner.com
    1 signupgenius.com
    1 shermanstravel.com
    1 salsalabs.org
    1 rjbs.manxome.org
    1 rickhanson.net
    1 retevia.net
    1 rapidmanufacturing.com
    1 quantagreengels.com
    1 pm.mtasv.net
    1 pdamerica.org
    1 pasadenaplayhouse.org
    1 outboundsend.com
    1 o.delta.com
    1 nwlc.org
    1 news.ecmconnection.com
    1 ncjw.org
    1 nationsend4.com
    1 muckfestms.com
    1 mfp.underarmour.com
    1 messages.fwwatch.org
    1 members.wayfair.com
    1 medium.com
    1 mass-creative.org
    1 mailings.ticketmaster.co.uk
    1 mail.zocdoc.com
    1 mail.vividseats.com
    1 mail.scmagazineus.com
    1 mail.change.org
    1 mail.aramarkparks.com
    1 mail.alnmag.com
    1 lyftmail.com
    1 lists.toxicstargeting.com
    1 lagunaplayhouse.com
    1 ivy.com
    1 itrustwomen.org
    1 interactive.wsj.com
    1 info.mouser.com
    1 icontact.vn
    1 iccsafe.org
    1 hubspot.com
    1 hotgadgetdeals.com
    1 hms.harvard.edu
    1 harborfreightemail.com
    1 getpocket.com
    1 fivethirtyeight.com
    1 ewasteshop.com
    1 et.npr.org
    1 equisolve.com
    1 enews.pentonmanufacturing.com
    1 enews.hydraulicspneumatics.com
    1 enews.electronicdesign.com
    1 emails.evernote.com
    1 email.thetileapp.com
    1 email.microsoftrewards.com
    1 email.listen360.com
    1 email.homedepot.com
    1 email-weightwatchers.com
    1 email-aaa.com
    1 em.ftd.com
    1 e1.emeraldexpoinfo.com
    1 e.mozilla.org
    1 e.fitbit.com
    1 douthitforcolorado.com
    1 dlink.com
    1 demandforced3.com
    1 dccc.org
    1 cryptonector.com
    1 connect.scpr.org
    1 cmail19.com
    1 cm.zazzle.com
    1 cleargov.co
    1 bullhornmail.com
    1 booking.com
    1 au.org
    1 atdi.com
    1 andreasschulze.de
    1 act.centerforfoodsafety.org
    1 aclum.org
    1 aadvantage.email.aa.com

---

From: Stan Kalisch <[email-masked]>
Date: Wed, 14 Mar 2018 09:39:39 -0400

> On Mar 14, 2018, at 9:28 AM, John R. Levine <[email-masked]> wrote:
> 
> I went through my mail logs to see who's still signing with rsa-sha1.  I wouldn't claim that my system is typical but some of these really should know better.

I didn't want to single them out, but since you've gone to the trouble to post a list, I'll note US-CERT's mailing lists still use rsa-sha1.

Stan

---

From: Hector Santos <[email-masked]>
Date: Wed, 14 Mar 2018 10:54:53 -0400

This is bullshit. You should know better.  I ask that the chairs and 
the IETF cops to keep this crap out of here.

On 3/14/2018 9:28 AM, John R. Levine wrote:
> I went through my mail logs to see who's still signing with rsa-sha1.
> I wouldn't claim that my system is typical but some of these really
> should know better.
>
> R's.
> John
>
> _______________________________________________
> Dcrup mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dcrup
>
>

-- 
HLS

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 15 Mar 2018 12:01:57 +0000

What is bullshit, exactly?  We shouldn't list sites that use sha1?  Please clarify.

---

From: Bryan Bradsby <[email-masked]>
Date: Thu, 15 Mar 2018 08:51:12 -0500

>    the IETF cops to keep this crap out of here.

Since when is the truth not wanted?

-bryan

---

From: Hector Santos <[email-masked]>
Date: Thu, 15 Mar 2018 12:32:08 -0400

> What is bullshit, exactly?  We shouldn't list sites that use sha1?  Please clarify.

If you have to ask why....

First, I don't wish to participate in a game of public "shaming." 
Pointing out SHA1 usage is one thing, Shaming them is another.  You 
should know better.

Second,  Its only been a few months and there is bound to be untold 
number of domains, legacy or otherwise using a perfectly valid SHA1 
lower overhead hashing method based on a standard DKIM document and 
RFCs before it for many years.   You CAN NOT expect these domains to 
be switching anytime soon. Unrealistic.

Third, have you bothered to see if they even need DKIM?  I bet most of 
them, if not all of them, then don't have a DKIM POLICY or it is very 
relaxed, i.e. p=none.   What they may have is a strong SPF policy 
which is generally good enough. You don't need DKIM with a strong SPF, 
especially if they have a HardFail (-ALL).

Forth, there is certainly shaming that can go around against that do. 
  For example, shame on those (like akamai.com) for not having an SPF 
record. Queries with NXDOMAIN results against your domain are higher 
overhead. You have a DMARC record, but no SPF record. You have no 
protection at SMTP, even more receiver overhead to handle and help 
protect your mail, you are asking receivers to do.   All this is far 
worst than using a DKIM SHA1 because its real today.

Fifth, many legitimate domains will continue to use SHA1 in some 
fashion and and machines for various reasons, including compatibility 
and product support with other domains and customers.

Do I really need to go further? I hope not. Please stop the SHA1 shaming.

-- 
HLS

---

From: Hector Santos <[email-masked]>
Date: Thu, 15 Mar 2018 12:51:40 -0400

> Since when is the truth not wanted?

Create a "SHAE1 Usage"  report.  Domain shaming is not necessary.

-- 
HLS

---

From: Scott Kitterman <[email-masked]>
Date: Thu, 15 Mar 2018 13:03:40 -0400

> Do I really need to go further? I hope not. Please stop the SHA1 shaming.

It's not a few months.  It's since the beginning of DKIM.  Here's the RFC 4871 
language (May 2007):

> 3.3.  Signing and Verification Algorithms
> 
>    DKIM supports multiple digital signature algorithms.  Two algorithms
>    are defined by this specification at this time: rsa-sha1 and rsa-
>    sha256.  The rsa-sha256 algorithm is the default if no algorithm is
>    specified.  Verifiers MUST implement both rsa-sha1 and rsa-sha256.
>    Signers MUST implement and SHOULD sign using rsa-sha256.
> 
>       INFORMATIVE NOTE: Although sha256 is strongly encouraged, some
>       senders of low-security messages (such as routine newsletters) may
>       prefer to use sha1 because of reduced CPU requirements to compute
>       a sha1 hash.  In general, sha256 should always be used whenever
>       possible.

If you were signing only rsa-sha1 in 2007, you were probably wrong, even then.  
DKIM has always required rsa-sha256, so (unless someone didn't fully implement 
RFC 4871 and then sat on their hands for a decade), there's no backward 
compatibility issue.

Scott K

---

From: Hector Santos <[email-masked]>
Date: Thu, 15 Mar 2018 13:21:06 -0400

On 3/15/2018 1:03 PM, Scott Kitterman wrote:
> It's not a few months. It's since the beginning of DKIM.

Your RFC update was only endorsed recently.

> Here's the RFC 4871 language (May 2007):
>

I technically disagree with you.

Nonetheless, the fact remains SHA1 was a legitimate STD protocol 
option for many years despite the hypothetical security concerns and 
still is usage without concerns, and when you study the domains that 
you (speaking in general) which to shame, you may find that DKIM may 
be a low priority.  Without a policy-based model, there is was very 
little, to zero payoff, and I've been saying that since 2007. Using 
SHA1 was not a concern.

-- 
HLS

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 15 Mar 2018 17:32:11 +0000

>    Pointing out SHA1 usage is one thing, Shaming them is another. 

So if the subject line were different you would have no concern about John's message?

---

From: Hector Santos <[email-masked]>
Date: Thu, 15 Mar 2018 13:50:30 -0400

> So if the subject line were different you would have no concern about John's message?

That and also I don't think specifically labeling and shaming domains 
is appropriate, especially without studying the domain facts and 
technical priorities a domain may or may not have.  In principle its 
wrong, especially in an IETF environment.

-- 
HLS

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 15 Mar 2018 13:49:42 -0700

> Create a "SHAE1 Usage"  report.  Domain shaming is not necessary.

I fail to see how (a) a post on a mailing list with only a handful of
participants with specific domain knowledge constitutes legitimate
"shaming"; or (b) creating a usage report of some kind would be any
different.

This is interesting data to this group, not a press release.

-MSK

---

From: Hector Santos <[email-masked]>
Date: Thu, 15 Mar 2018 18:10:37 -0400

> This is interesting data to this group, not a press release.

As a discussion/report of SHA1 usage still in practice, yes, I agree, 
it would be interesting data.   However, listing the domains in order 
to "shame" them, not to prove the point of usage, in my ethical 
opinion, is not.   The op should of known better. I know it, he knows 
it, you know it and everyone else knows it.  So excuse me if I am 
bewildered with the backlash on a very inappropriate action that you 
know typically would be considered a taboo.

You know what. Go ahead. Shame away. I'm done.

-- 
HLS

---

From: denis bider <[email-masked]>
Date: Thu, 15 Mar 2018 21:18:34 -0500

I do not share Hector's strong feelings about the issue, but I think the
points he made make sense. :-)

On Thu, Mar 15, 2018 at 5:10 PM, Hector Santos <[email-masked]> wrote:

> As a discussion/report of SHA1 usage still in practice, yes, I agree, it
> would be interesting data.   However, listing the domains in order to
> "shame" them, not to prove the point of usage, in my ethical opinion, is
> not.   The op should of known better. I know it, he knows it, you know it
> and everyone else knows it.  So excuse me if I am bewildered with the
> backlash on a very inappropriate action that you know typically would be
> considered a taboo.
>

---

From: Stan Kalisch <[email-masked]>
Date: Thu, 15 Mar 2018 22:44:22 -0400

> On Mar 15, 2018, at 6:10 PM, Hector Santos <[email-masked]> wrote:
> 
> However, listing the domains in order to "shame" them, not to prove the point of usage, in my ethical opinion, is not.   The op should of known better. I know it, he knows it, you know it and everyone else knows it.

No, we don't know it.  As you noted one sentence prior, this is your opinion.

I wasn't going to say anything further in this thread, but, speaking as a relatively new poster, it's gotten to the point that it wouldn't surprise me if your attacks on people here turn potential participants off from this WG.  The ease and vigor with which you take offense to things or misconstrue them as personal attacks are, in my opinion, disruptive. I suspect I am not the only person who feels this way.

Stan

---

From: Hector Santos <[email-masked]>
Date: Thu, 15 Mar 2018 23:10:14 -0400

> I wasn't going to say anything further in this thread, but, speaking as a relatively new poster, it's gotten to the point that it wouldn't surprise me if your attacks on people here turn potential…

This is a direct personal attack on a very subjective issue.  I take 
exception to your false insinuation I have attacked anyone. You should 
apologize.

On the other hand, I'm getting hit from the usual except a few who 
dare to give an inking of support. Greatly appreciated. I make no 
excuse for my passion in engineering and ethics.

I'll get back to the main point, whether you like it or not,  Shaming 
-- it is a very widely acceptable ethical engineering opinion, in my 
view, that you don't do it.  It is very disruptive.  I don't agree 
that you should allow opening the door to technical shaming for no 
legitimate reasoning.

If you want to open that door, go right ahead.

-- 
HLS

---

From: Steve Atkins <[email-masked]>
Date: Thu, 15 Mar 2018 20:15:16 -0700

> On Mar 15, 2018, at 8:10 PM, Hector Santos <[email-masked]> wrote:
> 

+1

> 
> This is a direct personal attack on a very subjective issue.  I take exception to your false insinuation I have attacked anyone. You should apologize.
> 
> On the other hand, I'm getting hit from the usual except a few who dare to give an inking of support. Greatly appreciated. I make no excuse for my passion in engineering and ethics.
> 
> I'll get back to the main point, whether you like it or not,  Shaming -- it is a very widely acceptable ethical engineering opinion, in my view, that you don't do it.  It is very disruptive.  I don't agree that you should allow opening the door to technical shaming for no legitimate reasoning.
> 

Actual shaming would require a much more public forum, an accusation more heinous than "uses a somewhat outdated protocol", and some actual accusation of malfeasance.

It's not actually terribly interesting detailed data (as compared to a count / summary) and John could perhaps have used a different subject line but other than that, and it triggering a thread full of bile, I see no issue with it.

Can we move on to something productive now?

Cheers,
  Steve

---

From: Stan Kalisch <[email-masked]>
Date: Fri, 16 Mar 2018 16:58:45 -0400

Likewise, I take exception to everything you said; I stand by my characterization of your behavior.  In any event, I will not continue to discuss this on the list.

Stan

> On Mar 15, 2018, at 11:10 PM, Hector Santos <[email-masked]> wrote:
>

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Sun, 18 Mar 2018 12:29:34 +0000

On Fri, Mar 16, 2018 at 8:58 PM, Stan Kalisch <[email-masked]>
wrote:

> Likewise, I take exception to everything you said; I stand by my
> characterization of your behavior.  In any event, I will not continue to
> discuss this on the list.

Yes, let's please move on.

-MSK, chair hat sitting nearby