Subject: Re: [decade] DECADE meeting minutes

From: "Woundy, Richard" <[email-masked]>
Date: Fri, 31 Jul 2009 04:37:56 -0400

The first few pages of RFC 2804 may be relevant here, even though that RFC is about wiretapping, not copyright infringement.

http://www.isi.edu/in-notes/rfc2804.txt

The issues about what constitutes a legal copy of content go beyond anti-piracy concerns, by the way.

We should try to understand whether the legal issues would preclude deployment. I think it is way too early to draw any conclusions about deployability yet.

-- Rich

----- Original Message -----
From: [email-masked] <[email-masked]>
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Sent: Fri Jul 31 03:09:17 2009
Subject: Re: [decade] DECADE meeting minutes

Hi Spiros,

It's really a very interesting question. "Legal" means different things in different countries. I know some organizations are trying hard to protect the copyright using DRM mechanisms. We really don't want to touch the legal issues and the content itself.

Haibin

----- Original Message ----- 
From: "Spiros Spirou" <[email-masked]>
To: "Song Haibin" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, July 31, 2009 8:49 AM
Subject: Re: [decade] DECADE meeting minutes

>I didn't attend the BoF, so I quickly went over the minutes. (BTW, 
> thanks to the note takers).
> 
> I'm surprised that the legal issues associated with the storage of 
> copyright-infringing content in P2P caches were not debated further. 
> I've been led to believe that P2P cache owners (e.g., ISPs) are liable 
> for the content stored on their caches and this is a show-stopper for 
> work on P2P caches. Opinions? What's the situation outside the US?
> 
> Thanks,
> 
> Spiros
_______________________________________________
decade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/decade

---

From: guyingjie 00107907 <[email-masked]>
Date: Sat, 01 Aug 2009 13:07:31 +0800

DMCA surely can be a reference for law issues of DECADE, it presents some aspects the content providers may concentrate on. Thanks to Kaiyu.

IMHO,DMCA has been the target of much debate since its rollout and it maybe a little bit faraway as "somewhere to draw the line" as Spiros said.
DECADE, as introduced in the slide, might help resource-client authenticate request-client by checking the password before forwarding the content, which already offends DMCA.

Some DMCA requirements are applicable to DECADE, e.g.
1. ISP  is not the one who originally made the material available
2. Caching is automatic, intermediate and temporary storage of content in local servers
4. caching complies with industry standards regarding the updating of the content
6. Provider must remove infringing files upon gaining actual knowledge of infringement

I'm still hesitating whether or not #6 should be considered by DECADE.

Best Regards
Yingjie Gu

----- Original mail -----
From:  <[email-masked]>
Date: Fri., 31 July, 2009 11:30 PM
Subject: Re: Re: [decade] DECADE meeting minutes
To: "Y.J. Gu" <[email-masked]>, "'Woundy, Richard'" <[email-masked]>, 'Song Haibin' <[email-masked]>, decade <[email-masked]>

> It is good to see that DECADE has a good beginning. 
> For the legal issue, I was told that a ISP's cache system should 
> follows DMCA. Which requires:
> 1. ISP  is not the one who originally made the material available
> 2. Caching is automatic, intermediate and temporary storage of 
> content in local servers
> 3. ISP did not modify the content
> 4. caching complies with industry standards regarding the updating 
> of the content
> 5. ISP does not interfere with content’s access manners (such as 
> passwords, etc.)
> 6. Provider must remove infringing files upon gaining actual 
> knowledge of infringement
> These may still be applicable to DECADE.
> 
> 
> 2009-07-31 
> 
> 
> 
> Zhou Kaiyu 
> 
> 
> 
> 發件人： Y.J. Gu 
> 發送時間： 2009-07-31  15:34:47 
> 收件人： 'Woundy, Richard'; 'Song Haibin'; decade 
> 抄送： 
> 主題： Re: [decade] DECADE meeting minutes 
> 
> Hi, this is Yingjie.
> Thanks to chairs and attendees.
> Glad to see that many people are interested in this topic, that's 
> a good
> beginning to DECADE. 
> However we still have much work to do before IETF 76, following 
> are my
> conclusion of what to do according to the meeting minutes. 
> 1) Motivation clarification; First, saving uplink/downlink 
> bandwidth is a
> possible motivation, although it may be not true for all ISPs, it 
> reallyhelps a lot. Second, for each application it supports, the 
> existing cache
> has to understand the corresponding protocol, which makes it 
> painful to
> adapt new applications, especially in flourishing P2P.
> 2) Advantages over existing mechanisms; maybe not overwhelming 
> advantage,but it should be clarified about what DECADE can do (or 
> do better) while the
> others cannot, i.e. why we need a new one instead of reusing the 
> existingones with some modification.  
> 3) Specific application use case; I agree with Yu Shun that we 
> should first
> list the applications that might benefits from DECADE, meanwhile 
> specify how
> and how much these apps will benefit.
> 4) Legal issues; Sure it is not so much important in some 
> countries as in
> others, but we should give some consideration or further 
> explanation before
> simply leaving it out of account.
> Hope for more comments and proposals.
> Regards
> Yingjie Gu
> -----郵件原件-----
> 發件人: [email-masked] [mailto:[email-masked]] 代表
> Woundy, Richard
> 發送時間: 2009年7月31日 樂樂0:46
> 收件人: Song Haibin; [email-masked]
> 主題: Re: [decade] DECADE meeting minutes
> In the minutes, I think I am both "Rich Woundy" and "Rich from ISP".
> > Rich Woundy- current caching system based on transparent passing by
> which they ssume that if it is p2p protocol they put cache inline 
> of the
> transmission line.
> They put the cache inline, or they intercept the traffic inline ala
> DPI............