Subject: [decade] review of draft-ietf-decade-problem-statement-01

From: Tao Ma <[email-masked]>
Date: Tue, 4 Jan 2011 18:15:58 +0800

Hi,

I have carefully read the problem statement draft. It’s clear and concise to
describe the motivation and goal of DECADE. However, I have some confusion
about its details as follows:

1 In section 3.1-P2P infrastructural stress and inefficiency, the third
paragraph about the comparion with LEDBAT, there is a sentence “Also, when
adopted, these techniques do not remove all inefficiencies, such as those
associated with traffic being sent upstream as many times as there are
remote peers interested in getting the corresponding information.” I don’t
catch the main idea of this sentence. What is “those associated with traffic
being sent upstream as many times as there are remote peers”? What is
“corresponding information?”Do you mean LEDBAT only considers peers in local
network? I think this sentence is quite hard to understand.

2 The section 3 describes the problems that would be targeted by DECADE. One
side is to reduce the stress on infrastructure, which benefits ISP. The
other side is to increase flexibility on content sharing, which benefits
users. However, I don’t think the titile of section 3.3 “ineffective
integration of P2P applications” is very appropriate. In my opinion, this
section describes the requirements for P2P applications to utilize
infrastructural resources, which doesn’t match the “ineffective
integration”. I suggest a more appropriate title to highlight the need of
infrastructural resources for P2P applications.

Besides, I think DECADE is a very promising service to transfer the storage
and management of content into the cloud, which envisions the future P2P
applications. Can we add the hot concept of “cloud” into the draft? My 2
cents.

Tao Ma

Beijing University of Posts and Telecommunications, Mobile life and new
media lab

---

From: Songhaibin <[email-masked]>
Date: Thu, 13 Jan 2011 12:25:50 +0000

Hi Tao,

Thanks for the review. I'm sorry for the late reply. Please see in line.

From: Tao Ma [mailto:[email-masked]]
Sent: Tuesday, January 04, 2011 6:16 PM
To: [email-masked]; Songhaibin
Cc: ch zhang; [email-masked]
Subject: [decade]review of draft-ietf-decade-problem-statement-01

Hi,
I have carefully read the problem statement draft. It's clear and concise to describe the motivation and goal of DECADE. However, I have some confusion about its details as follows:
1 In section 3.1-P2P infrastructural stress and inefficiency, the third paragraph about the comparion with LEDBAT, there is a sentence "Also, when adopted, these techniques do not remove all inefficiencies, such as those associated with traffic being sent upstream as many times as there are remote peers interested in getting the corresponding information." I don't catch the main idea of this sentence. What is "those associated with traffic being sent upstream as many times as there are remote peers"? What is "corresponding information?"Do you mean LEDBAT only considers peers in local network? I think this sentence is quite hard to understand.
[Haibin] That sentence means other technique like LEDBAT does not solve the problem, that the content is sent upstream as many times as there are requests for it. "corresponding information" means the shared content itself.
2 The section 3 describes the problems that would be targeted by DECADE. One side is to reduce the stress on infrastructure, which benefits ISP. The other side is to increase flexibility on content sharing, which benefits users. However, I don't think the titile of section 3.3 "ineffective integration of P2P applications" is very appropriate. In my opinion, this section describes the requirements for P2P applications to utilize infrastructural resources, which doesn't match the "ineffective integration". I suggest a more appropriate title to highlight the need of infrastructural resources for P2P applications.
[Haibin] I want to say all subsections in Section 3 are to state the problems. When you read the last sentence, you can understand what is the main idea of section 3.3. "Existing techniques for P2P application in-network storage lack these capabilities."
Besides, I think DECADE is a very promising service to transfer the storage and management of content into the cloud, which envisions the future P2P applications. Can we add the hot concept of "cloud" into the draft? My 2 cents.
[Haibin] "Cloud" is a very interesting and popular concept. But different people have different mind on it, which may confuse the readers
BR,
Haibin

Tao Ma
Beijing University of Posts and Telecommunications, Mobile life and new media lab