Subject: [decade] FW: I-D Action:draft-farrell-ni-00.txt

From: "David Harrington" <[email-masked]>
Date: Mon, 28 Mar 2011 14:38:14 +0200

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Monday, March 28, 2011 11:15 AM
To: [email-masked]
Subject: I-D Action:draft-farrell-ni-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title           : URIs for Named Information
	Author(s)       : S. Farrell, et al.
	Filename        : draft-farrell-ni-00.txt
	Pages           : 11
	Date            : 2011-03-28

This document defines a URI-based name form for objects intended to
be used for information-centric networking and more generally.  The
name form defined here allows for the various forms of hash-based
binding between the name and the named-object, as well as supporting
human-readable and hierarchical names.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-farrell-ni-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Woundy, Richard" <[email-masked]>
Date: Mon, 28 Mar 2011 23:43:48 +0000

Borje,

How does draft-farrell-ni-00 relate to draft-dannewitz-ppsp-secure-naming-02?

I noticed a significant author overlap -- two out of four authors in common, particularly you. :)

-- Rich

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of David Harrington
Sent: Monday, March 28, 2011 2:38 PM
To: [email-masked]
Subject: [decade] FW: I-D Action:draft-farrell-ni-00.txt

-----Original Message-----
[mailto:[email-masked]] On Behalf Of [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

This document defines a URI-based name form for objects intended to be used for information-centric networking and more generally.  The name form defined here allows for the various forms of hash-based binding between the name and the named-object, as well as supporting human-readable and hierarchical names.

Below is the data which will enable a MIME compliant mail reader implementation to automatically retrieve the ASCII version of the Internet-Draft.

---

From: Börje Ohlman <[email-masked]>
Date: Tue, 29 Mar 2011 09:19:09 +0200

Hi Rich,

The dannewitz draft has it's origin in the naming work that we have done for Information Centric Networks (ICN). We realized that this type of naming can be of general interest for many applications, also in today's Internet. We thus wrote the draft for ppsp. The work that that draft is based on is largely summarized in the Global Internet Symposium paper "Secure Naming for a Network of Information" (attached), you can also find the presentation at: 
https://fit.nokia.com/gi2010/gi2010/GIS2010-SecureNamingNetInf.pdf

In the latest version of the dannewitz draft we have put the emphasis on stating that a flexible secure application independent naming scheme for information objects should be a great thing to have for the future development of the Internet. 

The naming scheme presented in the paper was a first shot at that. Our work on this has since then evolved and our current thinking is represented by the farrell draft. Which we think is an even more simple, flexible and extensible way to do secure naming of information objects (and any type of objects for that matter). Please note that we by no means claim this to be the 'final solution'. It is just another proof of concept on the way to, what we hope to see, a common secure naming scheme widely adopted on the Internet for naming information objects.

Hope this helps,
				Börje

---

From: "zhangyunfei" <[email-masked]>
Date: Tue, 29 Mar 2011 16:03:50 +0800

As is a general naming scheme,I suggested as stating in the WG meeting, to discuss in the URNbis mailing list.

Yunfei

zhangyunfei
2011-03-29

发件人： B鰎je_Ohlman
发送时间： 2011-03-29 15:19:34
收件人： Woundy, Richard
抄送： Tim Polk; Dirk Kutscher; decade ietf; Sean Turner; Christian Dannewitz
主题： Re: [decade] FW: I-D Action:draft-farrell-ni-00.txt

Hi  Rich,

Hope  this  helps,
B鰎je

>  Below  is  the  data  which  will  enable  a  MIME  compliant  mail  reader  implementation  to  automatically  retrieve  the  ASCII  version  of  the  Internet-Draft.
_______________________________________________
decade  mailing  list
[email-masked]
https://www.ietf.org/mailman/listinfo/decade