Subject: Re: [decade] re-chartering

From: Börje Ohlman <[email-masked]>
Date: Wed, 13 Jul 2011 11:53:56 +0200

I think the items listed below are the main items for the next period. Obviously the protocol issues are key things to complete. For the other two I want to make the following comments.

Regarding the naming scheme I want to promote the idea to select a naming scheme that can be generally applicable to naming any type of information objects and thus not making it DECADE specific. As was mentioned at the last IETF there is a draft proposing one possible such naming scheme, see http://datatracker.ietf.org/doc/draft-farrell-ni/
In the DECADE architecture draft it is proposed to use a hash of the information object to name them. I support this idea and the naming scheme proposed in our draft could definitely support such naming. It might add a slight overhead compared with using a plain hash, but it will add flexibility and possibility for future extensions. These features could be useful if there is a need to change a comprised hash algorithm in the future or for making DECADE work smoothly with other future features provided by e.g. ALTO or CDNI.

Regarding service discovery I think this is a very important issue that is key for making it possible to use DECADE in scenarios where users and hosts are roaming in the network.

		Börje

On 20 jun 2011, at 09.54, Songhaibin wrote:

> Dear all,
> 
> As we began our discussion about re-chartering from last IETF meeting. We would like to hear more thoughts and comments in the list. The topics include but not limit to what we talked at last meeting.
> 
> 1. protocols
> 2. Mandatory underlying protocol
> 3. Mandatory naming scheme
> 4. service discovery and etc.
> 
> What stuff should we work on in the next period in this WG in your opinion? Any special consideration?
> 
> BR,
> -Haibin and Rich
> _______________________________________________
> decade mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/decade

---

From: "Woundy, Richard" <[email-masked]>
Date: Thu, 21 Jul 2011 14:49:18 +0000

Börje, thanks for your feedback. We will discuss the naming scheme of draft-farrell-ni in our WG session on Tuesday.

Folks, any additional feedback on the re-chartering discussion would be much appreciated. Thanks!

-- Rich

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Börje Ohlman
Sent: Wednesday, July 13, 2011 5:54 AM
To: Songhaibin
Cc: [email-masked]
Subject: Re: [decade] re-chartering

		Börje