Subject: [decade] Review of draft-ietf-decade-integration-example-02

From: ZongNing <[email-masked]>
Date: Tue, 20 Dec 2011 08:11:39 +0000

Hi,

I did a quick review of draft-ietf-decade-integration-example-02.
First of all, I believe this draft provides some concrete examples of applying DECADE to existing P2P applications to achieve improved performance. I'd like to see this draft to move forward.
I also have following comments & suggestions:

1)       In Section 1 "Introduction", it seems that only P2P live streaming is mentioned. We should also mention file sharing application (e.g. Vuze) and Content Distribution Platform for CP;

2)       In Section 2, "DECADE Module" and "DECADE Plugin" should be the same. We should merge these two definition and use one term in the whole draft.

3)       In Section 2, "DECADE-Enabled Vuze" is covered by "DECADE Client". In the whole draft, we could either use two terms - "DECADE-enabled Vuze" & "DECADE-enable PPLS", or just use "DECADE Client" for general purpose.

4)       I think Section 6 needs more editorial work.

5)       In Section 6, I think we'd better to call it "content distribution platform for CP" rather than "ALTO+DECADE platform", as we don't focus on describing an ALTO+DECADE architecture in this draft.

6)       In Section 6, we'd better to use DECADE service provider rather than ISP in Figure 4. We also need more explanation to Figure 4, as the connections are unclear, e.g. are these data or signaling links? Do we need more components such as ALTO server and content origins?

7)       In Section 7, test settings for distribution platform for CP is missing, e.g. how many and which types of servers are used, which CPs are tested?

8)       In Section 8, I think we'd better to give a content distribution performance example, e.g. how long to complete a content distribution, to how many users, how about the bandwidth usage?

BR,
Ning Zong

---

From: Songhaibin <[email-masked]>
Date: Fri, 23 Dec 2011 09:07:28 +0000

Thank you Ning for the comments. The authors please discuss/address these comments.

-Haibin

From: [email-masked] [mailto:[email-masked]] On Behalf Of ZongNing
Sent: Tuesday, December 20, 2011 4:12 PM
To: [email-masked]
Subject: [decade] Review of draft-ietf-decade-integration-example-02

Hi,

BR,
Ning Zong