Subject: [Detnet] I-D Action: draft-ietf-detnet-use-cases-12.txt

From: [email-masked]
Date: Mon, 03 Apr 2017 22:08:09 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Deterministic Networking of the IETF.

        Title           : Deterministic Networking Use Cases
        Authors         : Ethan Grossman
                          Craig Gunther
                          Pascal Thubert
                          Patrick Wetterwald
                          Jean Raymond
                          Jouni Korhonen
                          Yu Kaneko
                          Subir Das
                          Yiyong Zha
                          Balázs Varga
                          János Farkas
                          Franz-Josef Goetz
                          Juergen Schmitt
                          Xavier Vilajosana
                          Toktam Mahmoodi
                          Spiros Spirou
                          Petra Vizarreta
	Filename        : draft-ietf-detnet-use-cases-12.txt
	Pages           : 81
	Date            : 2017-04-03

Abstract:
   This draft documents requirements in several diverse industries to
   establish multi-hop paths for characterized flows with deterministic
   properties.  In this context deterministic implies that streams can
   be established which provide guaranteed bandwidth and latency which
   can be established from either a Layer 2 or Layer 3 (IP) interface,
   and which can co-exist on an IP network with best-effort traffic.

   Additional requirements include optional redundant paths, very high
   reliability paths, time synchronization, and clock distribution.

   Industries considered include wireless for industrial applications,
   professional audio, electrical utilities, building automation
   systems, radio/mobile access networks, automotive, and gaming.

   For each case, this document will identify the application, identify
   representative solutions used today, and what new uses an IETF DetNet
   solution may enable.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-detnet-use-cases/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-detnet-use-cases-12
https://datatracker.ietf.org/doc/html/draft-ietf-detnet-use-cases-12

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-detnet-use-cases-12

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Tue, 4 Apr 2017 05:15:09 +0000

Hi All,
This new version 12 of the DetNet Use Cases draft is primarily intended to prevent it from expiring, so that we can do WGLC. It does contain a few minor tweaks due to feedback received from the list since publication of version 11. 
I know that there are still some additions that are being considered for this draft, and I expect there will be at least one more revision to incorporate them (before or as a result of WGLC). 
Best,
Ethan.

-----Original Message-----
From: detnet [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, April 04, 2017 12:08 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Detnet] I-D Action: draft-ietf-detnet-use-cases-12.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
detnet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/detnet

---

From: "Maik Seewald (maseewal)" <[email-masked]>
Date: Wed, 5 Apr 2017 14:47:50 +0000

Ethan, all,

A few comments on section: 3.1.1.2 Intra-Substation Process Bus Communications

The CT/VT in the substation send the
sampled value (analog voltage or current) to the MU over hard wire. -> Typically, the CT/VT send analog values. A Merging Unit (MU) converts the analog values into digital values, typically into Sampled Values (IEC 61850-9-2)

The MU sends the time-synchronized 61850-9-2 sampled values to the
IEDs in the substation in GOOSE message format. -> Sampled Values (SV) are defined in IEC 61850-9-2. SV are not sent as GOOSE messages (IEC 61850-8-1). They are sent as Sampled Values, completely defined in IEC 61850-9-2.

Cheers. Maik

On 04/04/2017, 07:15, "detnet on behalf of Grossman, Ethan A." <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi All,

-----Original Message-----
From: detnet [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Tuesday, April 04, 2017 12:08 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Detnet] I-D Action: draft-ietf-detnet-use-cases-12.txt

Abstract:

_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet
_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Wed, 5 Apr 2017 19:37:07 +0000

Thanks Maik. I don't know the technical aspects of these statements - I would like at least one other expert to please weigh in on whether these are appropriate changes.
Thanks,
Ethan.

From: Maik Seewald (maseewal) [mailto:[email-masked]]
Sent: Wednesday, April 05, 2017 7:48 AM
To: Grossman, Ethan A. <[email-masked]>; [email-masked]
Subject: Re: [Detnet] I-D Action: draft-ietf-detnet-use-cases-12.txt

Ethan, all,

Cheers. Maik

Hi All,

-----Original Message-----
From: detnet [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Tuesday, April 04, 2017 12:08 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Detnet] I-D Action: draft-ietf-detnet-use-cases-12.txt

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-detnet-use-cases/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Ddetnet-2Duse-2Dcases_&d=DwMFAw&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=G3Xy2Nlssj831C5rH5rLd0FHl4Hahp-GUXIxh-wA8t8&s=DIYlB0-rLHRQ-KCsvfmPjL7Pdv8jz_N3dUUYLPUYaEg&e=>

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-detnet-use-cases-12<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Ddetnet-2Duse-2Dcases-2D12&d=DwMFAw&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=G3Xy2Nlssj831C5rH5rLd0FHl4Hahp-GUXIxh-wA8t8&s=-dQdYhBhh8zf8VwJi1lPtQckDo4-cJB3WT9vLSlLwjs&e=>
https://datatracker.ietf.org/doc/html/draft-ietf-detnet-use-cases-12<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dietf-2Ddetnet-2Duse-2Dcases-2D12&d=DwMFAw&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=G3Xy2Nlssj831C5rH5rLd0FHl4Hahp-GUXIxh-wA8t8&s=pGY52wgfUAAic6OliSO6q24rNoSUvYSU_gqRHDrCZQs&e=>

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-detnet-use-cases-12<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2Ddetnet-2Duse-2Dcases-2D12&d=DwMFAw&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=G3Xy2Nlssj831C5rH5rLd0FHl4Hahp-GUXIxh-wA8t8&s=yt-26VMUmBH-LU7YHE7RPsnXg21oaoiV_LJ6EBsemfA&e=>

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/<https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=DwMFAw&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=G3Xy2Nlssj831C5rH5rLd0FHl4Hahp-GUXIxh-wA8t8&s=wkYmsVq5TVaiu6vImWrA-P6sIS0HbhiSx1Guc3DTx6k&e=>

_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_detnet&d=DwMFAw&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=G3Xy2Nlssj831C5rH5rLd0FHl4Hahp-GUXIxh-wA8t8&s=kjfWc1Me7OyouFh5khVE_w1tWVI3kShxFnOv7VhXrKQ&e=>
_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_detnet&d=DwMFAw&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=G3Xy2Nlssj831C5rH5rLd0FHl4Hahp-GUXIxh-wA8t8&s=kjfWc1Me7OyouFh5khVE_w1tWVI3kShxFnOv7VhXrKQ&e=>

---

From: "Maik Seewald (maseewal)" <[email-masked]>
Date: Thu, 6 Apr 2017 13:51:35 +0000

Hi Ethan,

Sure thing. I have another comment.

 IEC 61850 will recommend the use of the IEEE PTP 1588 Utility Profile
   (as defined in [IEC62439-3:2012] Annex B) which offers the support of
   redundant attachment of clocks to Parallel Redundancy Protcol (PRP)
   and High-availability Seamless Redundancy (HSR) networks.

IEC 61850 has published IEC/IEEE 61850-9-3:2016 as joined work with IEEE: https://webstore.iec.ch/publication/24998

The title is: Precision time protocol profile for power utility automation. It is based on Annex B/IEC 62439.

In other words, for IEC 61850 installations only part 9-3 applies.

I’m a member of of WG10 (IEC 61850) and co-author of several standard documents.

Cheers,

Maik

From: "Grossman, Ethan A." <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, 5 April 2017 at 21:37
To: Cisco Employee <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Detnet] I-D Action: draft-ietf-detnet-use-cases-12.txt

Thanks Maik. I don’t know the technical aspects of these statements – I would like at least one other expert to please weigh in on whether these are appropriate changes.
Thanks,
Ethan.

From: Maik Seewald (maseewal) [mailto:[email-masked]]
Sent: Wednesday, April 05, 2017 7:48 AM
To: Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Detnet] I-D Action: draft-ietf-detnet-use-cases-12.txt

Ethan, all,

The CT/VT in the substation send the
sampled value (analog voltage or current) to the MU over hard wire. —> Typically, the CT/VT send analog values. A Merging Unit (MU) converts the analog values into digital values, typically into Sampled Values (IEC 61850-9-2)

The MU sends the time-synchronized 61850-9-2 sampled values to the
IEDs in the substation in GOOSE message format. —> Sampled Values (SV) are defined in IEC 61850-9-2. SV are not sent as GOOSE messages (IEC 61850-8-1). They are sent as Sampled Values, completely defined in IEC 61850-9-2.

Cheers. Maik

Hi All,

-----Original Message-----
From: detnet [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Tuesday, April 04, 2017 12:08 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Detnet] I-D Action: draft-ietf-detnet-use-cases-12.txt

Abstract: