Subject: [Detnet] 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

From: <[email-masked]>
Date: Fri, 30 Jun 2017 16:18:38 +0800 (CST)

hi all,

I've submitted a draft to bring blockchain as an use case added to the list, and make detnet aware of its deterministic networking requirements.

any comments are welcome.

Thanks & cheers,

Daniel Huang

黄光平 huangguangping

预研标准部/有线研究院/有线产品经营部 Standard Preresearch Dept./Wireline Product Operation Division

南京市雨花区软件大道50号中兴通讯1号楼 
R&D Building, ZTE
Corporation Software Road No.50, 
Yuhua District, Nanjing, P..R.China, 210012 
M: +86 13770311052 
E: [email-masked] 
www.zte.com.cn

原始邮件

发件人： <[email-masked]>
收件人：黄光平10039714
日 期 ：2017年06月29日 12:07
主 题 ：New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

A new version of I-D, draft-blockchain-as-detnet-use-case-00.txt
has been successfully submitted by Daniel Huang and posted to the
IETF repository.

Name:        draft-blockchain-as-detnet-use-case
Revision:    00
Title:        Allied and private blockchain as detnet use case
Document date:    2017-06-28
Group:        Individual Submission
Pages:        4
URL:            https://www.ietf.org/internet-drafts/draft-blockchain-as-detnet-use-case-00.txt
Status:         https://datatracker.ietf.org/doc/draft-blockchain-as-detnet-use-case/
Htmlized:       https://tools.ietf.org/html/draft-blockchain-as-detnet-use-case-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-blockchain-as-detnet-use-case-00

Abstract:
   This draft brings blockchain into the detnet use case list.
   Generally speaking, blockchain is both a technical term and a
   blockchain-based industry, which is spreading into a wide range of
   industries other than the thriving bitcoin.  Blockchain would have to
   require the supporting network offer deterministic networking service
   rather than the ongoing best-effort, because of its inherent p2p and
   frequent multicast working mechanism.

   Blockchain working process, its current network mechanism and
   challenges ahead, as well as requirements to detnet will be
   illustrated in the draft.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Fri, 30 Jun 2017 21:43:52 +0000

Hello Daniel,

Thank you for writing up this blockchain use case, and I appreciate your use of the existing DetNet Use Cases draft format for your text. As far as I can see, the blockchain application is a valid use case for DetNet, and it is different enough from the other use cases in terms of its application that I it would be interesting to include it in the Use Cases draft.

Regarding the ask for “Layer 3 Multicast”, my understanding is that this is already implied by the Use Case Common Theme “L2 and L3 Integration”, which says the following:

8.1.4.  L2 and L3 Integration

   A DetNet network is intended to integrate between Layer 2 (bridged)
   network(s) (e.g.  AVB/TSN LAN) and Layer 3 (routed) network(s) (e.g.
   using IP-based protocols).  One example of this is "making AVB/TSN-
   type deterministic performance available from Layer 3 applications,
   e.g. using RTP".

Is that sufficient, or do we need to add something more specific about L3 multicast?

Also, before adding it to the Use Cases draft, I would like to see some technical review input from the list members, since I myself am not an expert in the area of blockchain.

Thanks again,
Ethan.
Ethan Grossman
Editor, DetNet Use Cases Draft

From: detnet [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, June 30, 2017 1:19 AM
To: [email-masked]
Subject: [Detnet] 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

hi all,

Thanks & cheers,

Daniel Huang

黄光平 huangguangping

南京市雨花区软件大道50号中兴通讯1号楼
R&D Building, ZTE Corporation Software Road No.50,
Yuhua District, Nanjing, P..R.China, 210012
M: +86 13770311052
E: [email-masked]<mailto:[email-masked]>
www.zte.com.cn<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.zte.com.cn_&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=SNM_EYhL3ANwKa2-BK3MuvwdpMoKzRwlS7W5A1I17Bg&s=XQWPLDmy73-dUn0I_M8q48Qe-SlRnRyOSqzQZHoTXcE&e=>

原始邮件
发件人： <[email-masked]<mailto:[email-masked]>>;
收件人：黄光平10039714;
日 期 ：2017年06月29日 12:07
主 题 ：New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

Abstract:

The IETF Secretariat