Subject: [Detnet] DetNet Use Cases additions - Deadline 10Sep17

From: "Grossman, Ethan A." <[email-masked]>
Date: Mon, 14 Aug 2017 21:31:07 +0000

Hi Folks,
The DetNet Use Cases draft 12 will expire in October, i.e. before IETF 100, so I plan to have an update before then. According to my notes, there are five items to address, which I enumerate below. If you are one of the people mentioned below, please reply to indicate your current suggestion for new text for the draft.

I expect such text to be in a form consistent with the existing use cases, however it could be plain text or a Word doc, i.e. it doesn't have to be in XML.

In several of the cases we have had some email exchanges regarding text wording - it is possible that I already have the latest text, but I would like for you to send me what you understand to be the latest, to make sure we are in sync.

1)      Diego Duovne: Mining Industry use case.
2)      Maik Seewald: "Comments on section: 3.1.1.2 Intra-Substation Process Bus Communications" and "for IEC 61850 installations only part 9-3 applies:"
3)      Hassan Halabian: 5G Packet Fronthaul
4)      Daniel Huang: Blockchain use case
5)      Xavier Vilajosana: Wind Farm use case

If anyone else has any suggestions or comments, or if I somehow lost track of your request and didn't list it below, please reply.

Please send your replies for each of these potential additions by September 10, 2017 so that I have time to review and integrate.

Thanks,
Ethan.

---

From: Norman Finn <[email-masked]>
Date: Tue, 15 Aug 2017 14:08:25 +0000

There was a lot of mention of DetNet in the network slicing BOF.  Should we have that use case?

-- Norm

________________________________
From: detnet [[email-masked]] on behalf of Grossman, Ethan A. [[email-masked]]
Sent: Monday, August 14, 2017 2:31 PM
To: DetNet WG
Subject: [Detnet] DetNet Use Cases additions - Deadline 10Sep17

Hi Folks,

I expect such text to be in a form consistent with the existing use cases, however it could be plain text or a Word doc, i.e. it doesn’t have to be in XML.

In several of the cases we have had some email exchanges regarding text wording – it is possible that I already have the latest text, but I would like for you to send me what you understand to be the latest, to make sure we are in sync.

  1.  Diego Duovne: Mining Industry use case.
  2.  Maik Seewald: “Comments on section: 3.1.1.2 Intra-Substation Process Bus Communications” and “for IEC 61850 installations only part 9-3 applies:”
  3.  Hassan Halabian: 5G Packet Fronthaul
  4.  Daniel Huang: Blockchain use case
  5.  Xavier Vilajosana: Wind Farm use case

If anyone else has any suggestions or comments, or if I somehow lost track of your request and didn’t list it below, please reply.

Thanks,
Ethan.

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Tue, 15 Aug 2017 17:08:26 +0000

Good question. Is anyone interested in contributing text for a network slicing use case?
Ethan.

From: Norman Finn [mailto:[email-masked]]
Sent: Tuesday, August 15, 2017 7:08 AM
To: Grossman, Ethan A. <[email-masked]>; DetNet WG <[email-masked]>
Subject: RE: DetNet Use Cases additions - Deadline 10Sep17

-- Norm

2.       Maik Seewald: "Comments on section: 3.1.1.2 Intra-Substation Process Bus Communications" and "for IEC 61850 installations only part 9-3 applies:"

Thanks,
Ethan.

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Wed, 16 Aug 2017 01:29:14 +0000

Hi Ethan,

I volunteer to contribute text for Network Slicing. We are doing relative work recently. Please add me to the list.

Xuesong

From: detnet [mailto:[email-masked]] On Behalf Of Grossman, Ethan A.
Sent: Wednesday, August 16, 2017 1:08 AM
To: Norman Finn; DetNet WG
Subject: Re: [Detnet] DetNet Use Cases additions - Deadline 10Sep17

From: Norman Finn [mailto:[email-masked]]
Sent: Tuesday, August 15, 2017 7:08 AM
To: Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>>; DetNet WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: DetNet Use Cases additions - Deadline 10Sep17

-- Norm

Thanks,
Ethan.

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Wed, 16 Aug 2017 02:15:11 +0000

Hi Xuesong,

OK let's give it a try. However since this is new material, it would be good if we could have some text soon so that we can review it on the list. When do you think you can have some text ready for technical review? It doesn't have to be grammatically correct (I can fix that kind of thing later) but it should be technically complete and in the general format of the existing use cases (for example see Daniel's Blockchain text).

Thanks,

Ethan.

________________________________
From: Gengxuesong (Geng Xuesong) <[email-masked]>
Sent: Tuesday, August 15, 2017 6:29 PM
To: Grossman, Ethan A.; Norman Finn; DetNet WG
Subject: RE: DetNet Use Cases additions - Deadline 10Sep17

Hi Ethan,

Xuesong

-- Norm

Thanks,
Ethan.

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Tue, 15 Aug 2017 23:19:30 -0300

Ethan,
          I am working on a new version of the mining case,
I hope to have it finished before the end of August.
Regards,

                                        Diego Dujovne

2017-08-15 23:15 GMT-03:00 Grossman, Ethan A. <[email-masked]>:

> Hi Xuesong,
>
> OK let's give it a try. However since this is new material, it would be
> good if we could have some text soon so that we can review it on the list.
> When do you think you can have some text ready for technical review? It
> doesn't have to be grammatically correct (I can fix that kind of thing
> later) but it should be technically complete and in the general format of
> the existing use cases (for example see Daniel's Blockchain text).
>
> Thanks,
>
> Ethan.
> ------------------------------
> *From:* Gengxuesong (Geng Xuesong) <[email-masked]>
> *Sent:* Tuesday, August 15, 2017 6:29 PM
> *To:* Grossman, Ethan A.; Norman Finn; DetNet WG
>
> *Subject:* RE: DetNet Use Cases additions - Deadline 10Sep17
>
>
> Hi Ethan,
>
>
>
> I volunteer to contribute text for Network Slicing. We are doing relative
> work recently. Please add me to the list.
>
>
>
> Xuesong
>
>
>
> *From:* detnet [mailto:[email-masked]] *On Behalf Of *Grossman,
> Ethan A.
> *Sent:* Wednesday, August 16, 2017 1:08 AM
> *To:* Norman Finn; DetNet WG
> *Subject:* Re: [Detnet] DetNet Use Cases additions - Deadline 10Sep17
>
>
>
> *From:* Norman Finn [mailto:[email-masked]
> <[email-masked]>]
> *Sent:* Tuesday, August 15, 2017 7:08 AM
> *To:* Grossman, Ethan A. <[email-masked]>; DetNet WG <[email-masked]>
> *Subject:* RE: DetNet Use Cases additions - Deadline 10Sep17
>
>
>
> ------------------------------
>
> *From:* detnet [[email-masked]] on behalf of Grossman, Ethan A. [
> [email-masked]]
> *Sent:* Monday, August 14, 2017 2:31 PM
> *To:* DetNet WG
> *Subject:* [Detnet] DetNet Use Cases additions - Deadline 10Sep17
>
> Hi Folks,
>
> The DetNet Use Cases draft 12 will expire in October, i.e. before IETF
> 100, so I plan to have an update before then. According to my notes, there
> are five items to address, which I enumerate below. If you are one of the
> people mentioned below, please reply to indicate your current suggestion
> for new text for the draft.
>
>
>
> I expect such text to be in a form consistent with the existing use cases,
> however it could be plain text or a Word doc, i.e. it doesn’t have to be in
> XML.
>
>
>
> In several of the cases we have had some email exchanges regarding text
> wording – it is possible that I already have the latest text, but I would
> like for you to send me what you understand to be the latest, to make sure
> we are in sync.
>
>
>
> 2.       Maik Seewald: “Comments on section: 3.1.1.2 Intra-Substation
> Process Bus Communications” and “for IEC 61850 installations only part
> 9-3 applies:”
>
> If anyone else has any suggestions or comments, or if I somehow lost track
> of your request and didn’t list it below, please reply.
>
>
>
> Please send your replies for each of these potential additions by
> September 10, 2017 so that I have time to review and integrate.
>
>
>
> Thanks,
>
> Ethan.
>
>
>
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet
>
>

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Wed, 16 Aug 2017 02:39:15 +0000

Hi Ethan,

We do have some technical materials, but further work should be done to make it ready for review as a DetNet use case.
I need about 2 weeks to prepare for the text. Is it OK for you?

Xuesong

From: Grossman, Ethan A. [mailto:[email-masked]]
Sent: Wednesday, August 16, 2017 10:15 AM
To: Gengxuesong (Geng Xuesong); Norman Finn; DetNet WG
Subject: Re: DetNet Use Cases additions - Deadline 10Sep17

Hi Xuesong,

Thanks,

Ethan.

From: Gengxuesong (Geng Xuesong) <[email-masked]<mailto:[email-masked]>>

Hi Ethan,

Xuesong

-- Norm

Thanks,
Ethan.

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Wed, 16 Aug 2017 03:08:59 +0000

That sounds fine, thank you.
Ethan.

From: Gengxuesong (Geng Xuesong) [mailto:[email-masked]]
Sent: Tuesday, August 15, 2017 7:39 PM
To: Grossman, Ethan A. <[email-masked]>; Norman Finn <[email-masked]>; DetNet WG <[email-masked]>
Subject: RE: DetNet Use Cases additions - Deadline 10Sep17

Hi Ethan,

Xuesong

Hi Xuesong,

Thanks,

Ethan.

Hi Ethan,

Xuesong

-- Norm

Thanks,
Ethan.

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Sun, 27 Aug 2017 14:24:06 +0200

Hi Ethan,

We also provided text (discussed on the mailing list and agreed)
regarding crosshaul for the cellular radio use case. I sent you an e-
mail on April, 3rd. If you want I can resend it to you.

Thanks!

Carlos

On Mon, 2017-08-14 at 21:31 +0000, Grossman, Ethan A. wrote:
> Hi Folks,
> The DetNet Use Cases draft 12 will expire in October, i.e. before
> IETF 100, so I plan to have an update before then. According to my
> notes, there are five items to address, which I enumerate below. If
> you are one of the people mentioned below, please reply to indicate
> your current suggestion for new text for the draft.
>  
> I expect such text to be in a form consistent with the existing use
> cases, however it could be plain text or a Word doc, i.e. it doesn’t
> have to be in XML.
>  
> In several of the cases we have had some email exchanges regarding
> text wording – it is possible that I already have the latest text,
> but I would like for you to send me what you understand to be the
> latest, to make sure we are in sync.
>  
> Diego Duovne: Mining Industry use case.
> Maik Seewald: “Comments on section: 3.1.1.2 Intra-Substation Process
> Bus Communications” and “for IEC 61850 installations only part 9-3
> applies:”
> Hassan Halabian: 5G Packet Fronthaul
> Daniel Huang: Blockchain use case
> Xavier Vilajosana: Wind Farm use case
>  
> If anyone else has any suggestions or comments, or if I somehow lost
> track of your request and didn’t list it below, please reply.
>

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Mon, 28 Aug 2017 07:02:25 +0000

Hi Ethan,

Here is a simple introduction about Network Slicing use case for review.
If there is any question or comments, please let me know.

Best Regards,
Xuesong
__________________________________________________________________________________________________

Network Slicing Use Case

1.      Network Slicing Description
Network slicing divides one physical network infrastructure into multiple logical networks. Each slice, corresponding to a logical network, uses resources and network functions independently from each other. Network slicing provides flexibility of resource allocation and service quality customization.

Future services will demand the network performance with a wide variety of characteristics, such as data rate, latency, loss rate, security and many other parameters. Ideally, every service can set up its own network satisfying its particular performance requirements, which is obviously impossible considering the cost. Network slicing can provide a customized slice for a single service, and multiple slices can share the same physical network. This method can optimize the performance for the service with less cost, and the flexibility of setting up and release the slices also allows the user to allocate the network resources dynamically.

Different from other DetNet use cases, Network slicing is not a specific application with QoS requirements. It is proposed as a new requirement for the future network, which is still in discussion, and DetNet is a candidate solution for it.

2.      Network Slicing Use Cases
Network Slicing is a core feature of 5G defined in 3GPP, which is currently under development. A Network Slice in mobile network is a complete logical network including Radio Access Network (RAN) and Core Network (CN). It provides telecommunication services and network capabilities, which may vary (or not) from slice to slice.

5G bearer network is a typical use case of network slicing, including 3 service scenarios: enhanced Mobile Broadband (eMBB), Ultra-Reliable and Low Latency Communications (URLLC), and massive Machine Type Communications (mMTC).

2.1      Enhanced Mobile Broadband (eMBB)
eMBB focuses on services characterized by high data rates, such as high definition (HD) videos, virtual reality (VR), augmented reality (AR), and fixed mobile convergence (FMC).

2.2      Ultra-Reliable and Low Latency Communications (URLLC)
URLLC focuses on latency-sensitive services, such as self-driving, remote surgery, or drone control.

2.3      massive Machine Type Communications (mMTC)
mMTC focuses on services that have high requirements for connection density, such as those typical for smart city and smart agriculture use cases.

3.      Using DetNet in Network Slicing
One of the requirements discussed for network slicing is the "hard" separation of various users' QoS features.  That is, it should be impossible for activity, lack of activity, or changes in activity of one or more users to have any appreciable effect on the QoS parameters of any other users.  Typical techniques used, today, that share a physical network among users, do not offer this kind of insulation.  DetNet can supply point-to-point or point-to-multipoint paths that offer bandwidth and latency guarantees to a user that cannot be affected by other users' data traffic.

So DetNet is a powerful tool when latency and reliability are required in Network Slicing, but DetNet can't cover all Network Slicing use cases and there are some other problems to be solved: Firstly, DetNet is a point-to-point or point-to-multipoint technology while Network Slicing needs multi-point to multi-point guarantee; secondly, the number of flows that can be carried by DetNet is limited by DetNet scalability. Flow aggregation and queuing management modification may help to fix the problem. More work and discussions are needed in these topics.

4.      Network Slicing Today and Future
Network slicing can satisfy the requirements of a lot of future deployment scenario, but it is still a collection of ideas and analysis, without a specific technical solution. A lot of technologies, such as Flex-E, Segment Routing, including DetNet are potential to be used in Network Slicing. (see IETF99 Network Slicing BOF session agenda and materials)

5.      Network Slicing Asks

-          Slice Specification

-          Slice Isolation

-          Service Quality Customization and Guarantee

-          Dynamic control and management

-          OAM

-          Security

From: Grossman, Ethan A. [mailto:[email-masked]]
Sent: Wednesday, August 16, 2017 11:09 AM
To: Gengxuesong (Geng Xuesong); Norman Finn; DetNet WG
Subject: RE: DetNet Use Cases additions - Deadline 10Sep17

From: Gengxuesong (Geng Xuesong) [mailto:[email-masked]]
Sent: Tuesday, August 15, 2017 7:39 PM
To: Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>>; Norman Finn <[email-masked]<mailto:[email-masked]>>; DetNet WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: DetNet Use Cases additions - Deadline 10Sep17

Hi Ethan,

Xuesong

Hi Xuesong,

Thanks,

Ethan.

Hi Ethan,

Xuesong

-- Norm

Thanks,
Ethan.

---

From: Xavier Vilajosana <[email-masked]>
Date: Thu, 31 Aug 2017 11:27:49 +0200

Dear Ethan,

I reviewed the Wind Farm use case and I have no additions. What it is in
v12 is the latest text.

regards,
Xavi

*Xavier Vilajosana*
*CIO*
Office: <+34%20934%2018%2005%2085>[ <+34%20934%2018%2005%2085>+34] 93 418
0585 <+34%20934%2018%2005%2085>
Cell: <+34%20934%2018%2005%2085>[ <+34%20934%2018%2005%2085>+34] 646 633 681
<+34%20934%2018%2005%2085>
[email-masked]
<[email-masked]>

-- 

<http://www.worldsensing.com/> 
<https://es.linkedin.com/company/worldsensing-s.l.n.e> 
<https://twitter.com/worldsensing> 
<https://www.youtube.com/channel/UCExBd3gO-ZBZwz4fqOrKgWA>
*BARCELONA*
Viriat, 47, Edificio Numancia 1, 10th floor, 08014 Barcelona, Spain
*LONDON*
9-10 Carlos Place, Mayfair - London W1K 3AT, United Kingdom - +44 (0) 203 
807 2495
This email may contain confidential information and may be subject to 
professional secrecy. Its dissemination, copying, distribution, 
reproduction, forwarding or any other unauthorized use is strictly 
prohibited. If you receive this email in error, please notify us 
immediately and arrange for its deletion, together with any attached 
documents.
Este correo electrónico puede contener información estrictamente 
confidencial, y puede estar sometido al secreto profesional. Está prohibida 
su difusión, copia, distribución, reproducción, reenvío o cualquier otro 
uso no autorizado. En caso de recibir este correo por error, rogamos nos lo 
comunique de inmediato y proceda a su eliminación, así como de cualquier 
documento que se adjunte.

---

From: akram hakiri <[email-masked]>
Date: Thu, 31 Aug 2017 10:46:36 +0100

Hi Folks,
I would like to participate to the discussed, I reviewed all the published
DetNet drafts as part of my research of TSN.
Would you please tell me how can I do that !

thanks,

Akram Hakiri

2017-08-31 10:27 GMT+01:00 Xavier Vilajosana <[email-masked]>:

> Cell: <+34%20934%2018%2005%2085>[ <+34%20934%2018%2005%2085>+34] 646 633
> 681 <+34%20934%2018%2005%2085>
>> cases, however it could be plain text or a Word doc, i.e. it doesn’t have
>> to be in XML.
>>
>>    Process Bus Communications” and “for IEC 61850 installations only
>>    part 9-3 applies:”
> 807 2495 <+44%2020%203807%202495>