Subject: [dhcwg] DHCP & option 43 and option 55 (RFC 2132)

From: Girgis George <[email-masked]>
Date: Thu, 14 Feb 2002 08:25:58 -0000

Hi,

I need your help please

Regarding RFC 2132 , option 55 (Parameter request list) and option 43
(vendor class identifier)
  
Is there any  relation between the length field  for option 55 and option 43
?

Regards

George Girgis
Network Designer
Data Network Design Team
BTcellnet
tel +44 (0) 1753 564780
fax +44 (0) 1753 564355
mob +44 (0) 7753 560776 

=========================================================
This electronic message contains information from the mmO2 plc Group 
which may be privileged or confidential. The information is intended to be 
for the use of the individual(s) or entity named above. If you are not the 
intended recipient be aware that any disclosure, copying, distribution or 
use of the contents of this information is prohibited. If you have received 
this electronic message in error, please notify us by telephone or email 
(to the numbers or address above) immediately.
=========================================================

---

From: Thamer Al-Harbash <[email-masked]>
Date: Thu, 14 Feb 2002 01:16:28 -0800 (PST)

> Is there any  relation between the length field  for option 55 and option 43

The parameter request list would just include that tag in its list
so yes there is a relation but it's the same with any other option
tag. I'm not entirely sure why you would _request_ a vendor specific
option. It would seem to me that the client or the server would
simply handle it when it comes in or ignore it.

--
Thamer Al-Harbash    http://www.whitefang.com/dhcp-agent/
       cvs commit -m "unb0rk() now uses stdarg;"

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Thu, 14 Feb 2002 08:52:40 -0600

If you request any parameters at all, you will only get the parameters you 
requested, so you have to request everything you're interested in.