Subject: [dhcwg] Length of Reconf_Msg option

From: Anders Vestlund <[email-masked]>
Date: Thu, 25 Apr 2002 16:04:14 +0200

Hi,

I'm implementing a parse function for dhcp ipv6 messages based on draft
24.

In chapter 22.20 I noticed that the option length
of Reconfigure Message option is set to 1.

In the figure msg-type is drawn with 2 bytes length though.

I assume the length should be one byte , which is enough to
carry the data it's used for.

Best Regards
Anders Vestlund
Ericsson ///

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Thu, 25 Apr 2002 18:26:47 -0500

Yeah, this needs to be fixed. I'm also hoping we can change this slightly - to change the msg-type to use the DHCPv6 message type numbers (in 25.3). A revised version might be:

22.20. Reconfigure Message option

   A server includes a Reconfigure Message option in a Reconfigure
   message to indicate to the client whether the client responds with a
   Renew message or an Information-request message.

    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |      OPTION_RECONF_MSG        |         option-len            |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |   msg-type    |
   +-+-+-+-+-+-+-+-+

      option-code          OPTION_RECONF_MSG (19)

      option-len           1

      msg-type             5 for Renew message, 11 for
                           Information-request message

-----Original Message-----
From: Anders Vestlund [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 10:04 AM
To: [email-masked]
Subject: [dhcwg] Length of Reconf_Msg option

Hi,

Best Regards
Anders Vestlund
Ericsson ///