Subject: [dhcwg] No DHCPOFFER message

From: bao <[email-masked]>
Date: Tue, 02 Apr 2002 17:56:07 -0800

My server is running RH 7.2 with dhcpd-1.3.18p18-10. It is configured as
follows,
==================
# dhcpd.conf

subnet 66.80.7.160 netmask 255.255.255.224 {
    # --- default gateway
    option routers   66.80.7.161;
    option subnet-mask  255.255.255.224;
    option broadcast-address 66.80.7.191;

    option domain-name  "mydomain.com";
    # ISP's DNS addresses
    option domain-name-servers 216.200.176.4, 216.34.237.2;

    option time-offset  -18000; # Eastern Standard Time
    # --- Selects point-to-point node (default is hybrid). Don't change
this unless
    # -- you understand Netbios very well
    # option netbios-node-type 2;

    range dynamic-bootp 66.80.7.188 66.80.7.190;
    default-lease-time 7200;
    max-lease-time 9000;

    # we want the nameserver to appear at a fixed address
    host testmachine {
        hardware ethernet 00:10:4b:2c:af:48;
        fixed-address 66.80.7.166;
    }
}
==================
The server accepts all the configuration parameters, and can be started.
However, when the client testmachine is configured to
use DHCP and is booted up, packetsniffer indicates that although there
are DHCPDISCOVER messages (several, indeed, after
the client sees no response, it retransmits), there is not any DHCPOFFER
message. The server stays silent.

Does anyone see any misconfigurations in the dhcpd.conf file above, and
have any suggestions?

Thanks,

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Wed, 3 Apr 2002 21:56:48 -0700

Run the server with the -d flag and make the client try to get an address.
    The server will tell you why it didn't respond to the client.