Subject: RE: [dhcwg] dhcp : expected behaviour of clients when server is d own ?

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Fri, 23 May 2003 13:06:30 -0500

dhcp.leases doesn't need to have fixed addresses in it since they are fixed by the
configuration file.

You could look into running the failover protocol, but a much easier solution is to use
a much longer lease time. 600 seconds isn't very long (10 minutes) and why do you use such
a short lease? The two general reasons are:

1) few available addresses with fairly rapidly changing client populations (address reuse
if clients don't release or otherwise "disconnect" is critical)

2) frequent changes to the configuration (such as subnet number or resources such as the
DNS server).

If neither of these holds, increase the default lease time.

Note: Renewals start at 50% of the lease time. So, your current clients are renewing every
300 seconds (5 minutes).

-----Original Message-----
From: peter pilsl [mailto:[email-masked]]
Sent: Thursday, May 22, 2003 9:23 AM
To: [email-masked]
Subject: [dhcwg] dhcp : expected behaviour of clients when server is
down ?

I run a dhcp-server with loads of fixed adresses in the conf. The default-lease
is 600 and the  max-lease is 7200.

dhcp works well, but there are two strange things happening:

i) for none of the clients with a fixed adress there is an entry in 
dhcp.leases

ii) if the server is down for maintainance the client will not remember its 
old adress,  but simply dont have an ip-address any more (win2k-clients)

Especially the second point is very irritating to me. Imho the client 
should remember its old adress but maybe this is a limitation in the 
protocol. 

Is there an easy possibility for a backup-dhcpd if the main-dhcpd is down ?
If I need to take off the server for 10 minutes, all my clients do not have
networkaccess for the same time ? 

thnx,
peter

-- 
IT-Consulting
mag. peter  pilsl
tel:+43-699-1-3574035
fax:+43-699-4-3574035
[email-masked]
http://www.goldfisch.at

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Bud Millwood <[email-masked]>
Date: Tue, 27 May 2003 15:40:51 +0200

On Friday 23 May 2003 20.06, Bernie Volz (EUD) wrote:

> You could look into running the failover protocol, but a much easier
> solution is to use a much longer lease time. 600 seconds isn't very long
> (10 minutes) and why do you use such a short lease? The two general reasons
> are:

<snip>

> Note: Renewals start at 50% of the lease time. So, your current clients are
> renewing every 300 seconds (5 minutes).

Also, you may be able to set long lease times, but much shorter renewal times. 
That way your addresses stay out for a long time, but the clients are forced 
to renew at a short interval.

I have no idea if the ISC server allows that.

- Bud

Bud Millwood
Weird Solutions, Inc.
http://www.weird-solutions.com
tel: +46 8 758 3700
fax: +46 8 758 3687
mailto:[email-masked]
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg