Subject: [dhcwg] Status of draft-ietf-dhc-dhcpv6-opt-nisconfig-02.txt

From: Ralph Droms <[email-masked]>
Date: Mon, 06 Oct 2003 11:01:38 -0400

We have two questions on the table concerning
draft-ietf-dhc-dhcpv6-opt-nisconfig-02.txt:

* Is there a need for this option yet?  Is NIS/NIS+ currently IPv6-capable
   or are there plans to extend NIS/NIS+ for IPv6?  Is NIS/NIS+ used with
   IPv6 today?

* Is there a need for an DHCPv6 version of RFC 2937, "The Name Service
   Search Option for DHCP"?

If there is no discussion on these questions, we will put
draft-ietf-dhc-dhcpv6-opt-nisconfig-02.txt on hold until there is a firm
requirement for it.

- Ralph

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Vijayabhaskar A K" <[email-masked]>
Date: Mon, 6 Oct 2003 20:55:02 +0530

Ralph,

My reply inline..

Thanks
Vijay

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Ralph Droms
> Sent: Monday, October 06, 2003 8:32 PM
> To: [email-masked]
> Subject: [dhcwg] Status of draft-ietf-dhc-dhcpv6-opt-nisconfig-02.txt
> 
> 
Yes, Currently NIS/NIS+ is used with IPv6. NIS/NIS+ for IPv6 is
supported in Solaris and some versions of linux. HPUX is working on it. 

> * Is there a need for an DHCPv6 version of RFC 2937, "The Name Service

Yes. It is needed. When we have mutliple ways to resolve a name, we need
a precedence list to do it.

> draft-ietf-dhc-dhcpv6-opt-nisconfig-02.txt on hold until 
> there is a firm requirement for it.
> 
> - Ralph
> 
>

---

From: Ralph Droms <[email-masked]>
Date: Fri, 10 Oct 2003 08:06:40 -0400

Vijay - thanks for your response.  Seems like we should proceed with IESG
review of draft-ietf-dhc-dhcpv6-opt-nisconfig-02.txt.  Please update the
draft with a revised reference to RFC 3315 (the current draft has expired
anayway).

Is there a volunteer to write an equivalent to RFC 2937, "The Name Service
Search Option for DHCP", for DHCPv6?

- Ralph

---

From: "Vijayabhaskar A K" <[email-masked]>
Date: Fri, 10 Oct 2003 17:43:19 +0530

Ralph

I will update the draft with DHCPv6 RFC number and send the updated
version in one or two weeks. I can work on the DHCPv6 quivalent of RFC
2937 and send it by next week

~ Vijay

> Sent: Friday, October 10, 2003 5:37 PM
> To: [email-masked]
> Subject: RE: [dhcwg] Status of 
> draft-ietf-dhc-dhcpv6-opt-nisconfig-02.txt
> 
> 
> Vijay - thanks for your response.  Seems like we should 
> proceed with IESG review of 
> draft-ietf-dhc-dhcpv6-opt-nisconfig-02.txt.  Please update 
> the draft with a revised reference to RFC 3315 (the current 
> draft has expired anayway).
> 
> Is there a volunteer to write an equivalent to RFC 2937, "The 
> Name Service Search Option for DHCP", for DHCPv6?
> 
> - Ralph
> 
> 
> > > From: [email-masked] [mailto:[email-masked]] 
> On Behalf 
> > > Of Ralph Droms
> > > Subject: [dhcwg] Status of 
> > > draft-ietf-dhc-dhcpv6-opt-nisconfig-02.txt
> > >
> > >
> > >    or are there plans to extend NIS/NIS+ for IPv6?  Is 
> NIS/NIS+ used 
> > > with
> > >    IPv6 today?
> > >
> >Yes. It is needed. When we have mutliple ways to resolve a name, we 
> >need a precedence list to do it.
> >
> > >

---

From: Ralph Droms <[email-masked]>
Date: Fri, 10 Oct 2003 08:15:14 -0400

Great ... thanks, Vijay.

- Ralph