Subject: Re: [Mip4] Fw: [dhcwg] WG last call on draft-ietf-dhc-mipadvert-opt-01.txt

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 13 Oct 2003 15:00:01 +0200

Thanks Kuntal.

	You're right with respect to the 'B' bit. In general, the fields
would be static, but this bit potentially won't be, so the draft should
mention that. 

In the usage we (ipUnplugged) see for this option, the dhcp server would
be co-located with one of the mobility-agents, and know about the dynamic
information, but that can't be assumed to always be the case.

There are also the case of differentiation of services, and hot-spot
co-location of different service providers to consider; in those cases
the information also can be assumed to be static, I believe.

	Henrik

On Monday, 13 Oct 2003, Kuntal wrote:

> An high level comment:
> 
> The draft talks about load sharing among Agents with this DHCP option. It is not 
> apparent how the DHCP server comes to know about the actual load each Agent has 
> at the time of sending a response to a client.
> 
> The draft replicates the Agent Advertisement fields in the Mobility Agent 
> Announcements. This may be too static i.e. requires pre-configuration in the 
> DHCP server. I don't think it is a wise idea to proactively set some or all of 
> the fields on behalf of the Mobility Agents e.g. The Agent may be busy and would 
> like to set the B bit in AA.
> 
> IMHO, the DHCP server should only include the Agent's IP address in the 
> response. Let the client send an AS unicast to the Agent and let the Agent 
> respond with an appropriate AA. Let Mobile IPv4 procedure take it's normal course.
> 
> -Kuntal
> 
> Henrik Levkowetz wrote:
> 
> > The message below (hereby forwarded from the dhcwg list to the mip4
> > list) announces a dhc WG last call on "DHCP Option for Mobile IP
> > Mobility Agents",  <draft-ietf-dhc-mipadvert-opt-01.txt>. Although this
> > is a dhc WG work item, is highly relevant to the Mip4 working group.
> > 
> > Please respond to this WG last call, on the dhcwg mailing list
> > ([email-masked]), with copies to the mip4 list.  If you support
> > acceptance of the document without change, respond with a simple
> > acknowledgment, so that support for the document can be assessed.
> > 
> > 	Henrik
> > 
> > ---- Begin forwarded message: ----
> > 
> > 
> >>Date: Sun, 12 Oct 2003 11:17:00 -0400
> >>From: Ralph Droms <[email-masked]>
> >>To: [email-masked]
> >>Subject: [dhcwg] WG last call on draft-ietf-dhc-mipadvert-opt-01.txt
> > 
> > 
> >>
> >>This message announces a WG last call on "DHCP Option for Mobile IP Mobility
> >>Agents" <draft-ietf-dhc-mipadvert-opt-01.txt>.  The last call will conclude
> >>at 5PM ET on Friday, 10/24/2003.
> >>
> >>Please respond to this WG last call.  If you support acceptance of the
> >>document without change, respond with a simple acknowledgment, so that
> >>support for the document can be assessed.
> >>
> >>draft-ietf-dhc-mipadvert-opt-01.txt defines a new DHCP Option called the
> >>Mobility Agent Option, and two sub-options of the Mobility Agent Option: the
> >>Network Access Identifier Sub-Option, which provides
> >>identifying information about a DHCP client to the DHCP server and the
> >>Mobility Agent Announcement sub-option, which announces the address of one
> >>or more mobility agents available to a host. This draft is available as
> >>http://www.ietf.org/internet-drafts/draft-ietf-dhc-mipadvert-opt-01.txt
> >>
> >>- Ralph Droms
> >>
> >>
> >>_______________________________________________
> >>dhcwg mailing list
> >>[email-masked]
> >>https://www1.ietf.org/mailman/listinfo/dhcwg
> >>
> > 
> > 

	Henrik

-- 
  Survive. Socialize. Have fun. That's the progression
    -- Linus Torvalds

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 14 Oct 2003 09:53:56 +0200

Hi Kuntal,

	(Snipping Ralph's personal address and adding the dhcwg list)

Monday 13 October 2003, Kuntal wrote:
> Henrik,
> 
> Please see comments inline...
> 
> Henrik Levkowetz wrote:
[snip]
> A collocated DHCP server with a Mobility Agent may be able to know the load of 
> that Mobility Agent. However my understanding from the draft is that the DHCP 
> server can include more than on Agent Announcements in the DHCP response. How 
> does the DHCP server know the status of the other Mobility Agents that it is not 
> collocated with? As you said it cannot be always assumed. Therefore, why are we 
> doing this (proxy-) static announcement from the DHCP server on behalf of the 
> Mobility Agents?

No, we see the co-located mobility agent being informed of the state also 
of the other agents, so this would not be a problem.

> I think, DHCP server should only include Agent IP address(es) (1+) in a network 
> that the mobile can choose from. We should let the MN to send an AS to the 
> chosen FA and let the FA to respond with an AA. This should suffice. We should 
> stay away from static provisioning of Mobile IP specific parameters in the DHCP 
> server, IMHO.

You realize that this adds a round trip in a handover situation which is already
less than optimal? 

We could add a suboption wich only provided FA addresses, so you have the 
possibility of doing it the way you desire, too. But as I see it, almost all of
the fields of the full advertisement are valuable in choosing which agent to
go with if more than one is offered, so I'd not want to make your alternative
the only one. 

	Henrik