Subject: [dhcwg] [Question]DHCPv6 implementations

From: strates <[email-masked]>
Date: Mon, 21 Jun 2004 02:08:39 +0400

I tried to learn what are nowdays available DHCPv6 client/server
implementations.
Using the search engines I could only find
- KAME implementation for *BSDs: stateless DHCPv6, and they are not going
to improve it
- Widespread linux-related http://dhcpv6.sourceforge.net implementation
- Some traces of proprietary CISCO IOS and NEC implementations
(http://www.dhcpv6.org/ with only relay agent available for public)
- USAGI implementation which leads to a project which claimed himself
'dead'(http://www.linux-ipv6.org/links.html ->
http://www.hycomat.co.uk/dhcp/)
- Signs of some Linux implementation (there is some gentoo related
stuff, config files in google).
- DHCPv6 support in HP-UX

It is quite strange for me, that only a few incomplete
implementations are present (yes, stateless IPv6 autoconfiguration
fulfils a lot of work instead of DHCPv6, and many people seem to be
satisfied with s-less autoconfiguration and router prefix
advertisement, but still...)
Later I found www.dfn.de/uploaded/DHCPv6.pdf and I understood that
it seems there are really only a few implementations.
Could anybody advertise anything in addition to the list above?
Thanks beforehand

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Fri, 25 Jun 2004 11:39:26 +0900

>>>>> On Mon, 21 Jun 2004 02:08:39 +0400, 
>>>>> strates <[email-masked]> said:

> - KAME implementation for *BSDs: stateless DHCPv6, and they are not going

Just checking: what do you mean by "not going to improve it"?  We
(KAME) are actually seriously maintaining the implementation,
including bug fixes and supporting new features.  In fact, we've
recently implemented the brand-new lifetime option, and have just
newly supported the authentication mechanism.

Perhaps you simply meant we do not have a plan to implement address
allocation by DHCPv6.  In that sense you're correct, though I'd not
say "not going to improve it" meaning luck of a plan for one part of
the big specification (even if the part is a major goal of the
specification).

Of course, I admit our implementation is "incomplete" in that it does
not support address allocation.

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]

---

From: "Bernie Volz" <[email-masked]>
Date: Fri, 25 Jun 2004 08:34:08 -0400

There's also http://klub.com.pl/dhcpv6/.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of strates
> Sent: Sunday, June 20, 2004 6:09 PM
> To: [email-masked]
> Subject: [dhcwg] [Question]DHCPv6 implementations
> 
> 
> I tried to learn what are nowdays available DHCPv6 
> client/server implementations. Using the search engines I 
> could only find
> - KAME implementation for *BSDs: stateless DHCPv6, and they 
> are not going to improve it
> - Some traces of proprietary CISCO IOS and NEC 
> implementations (http://www.dhcpv6.org/ with only relay agent 
> available for public)
> - USAGI implementation which leads to a project which claimed 
> himself 'dead'(http://www.linux-ipv6.org/links.html ->
> - Signs of some Linux implementation (there is some gentoo 
> related stuff, config files in google).
> implementations are present (yes, stateless IPv6 
> autoconfiguration fulfils a lot of work instead of DHCPv6, 
> and many people seem to be satisfied with s-less 
> autoconfiguration and router prefix advertisement, but 
> still...) Later I found www.dfn.de/uploaded/DHCPv6.pdf and I 
> understood that it seems there are really only a few 
> implementations. Could anybody advertise anything in addition 
> to the list above? Thanks beforehand
> 
> 
>