Subject: [dhcwg] dhc WG last call on draft-ietf-dhc-rapid-commit-opt-05

From: Ralph Droms <[email-masked]>
Date: Tue, 13 Jul 2004 05:55:02 -0400

This message announces a WG last call on "Rapid Commit Option for
DHCPv4" <draft-ietf-dhc-rapid-commit-opt-05>.  The last call will
conclude at 1700 EDT, 2004-07-30.

Please respond to this WG last call.  If you support acceptance of the
document without change, respond with a simple acknowledgment, so that
support for the document can be assessed.

"Rapid Commit Option for DHCPv4" defines a new DHCPv4 option, modeled
on the DHCPv6 Rapid Commit option, for obtaining IP address and
configuration information using a 2-message exchange rather than the
usual 4-message exchange, expediting client configuration. .  This
draft is available as
http://www.ietf.org/internet-drafts/draft-ietf-dhc-rapid-commit-opt-05.txt

- Ralph Droms 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz" <[email-masked]>
Date: Tue, 13 Jul 2004 07:53:17 -0400

I support moving this document forward (but why wouldn't I as one of the
authors).

Please do note that there is an IPR claim against this draft, but before you
flame, please see
http://www.ietf.org/ietf/IPR/samsung-ipr-draft-ietf-dhc-rapid-commit-opt.txt
. (And, I had nothing to do with this IPR claim.)

- Bernie

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Ralph Droms
> Sent: Tuesday, July 13, 2004 5:55 AM
> To: [email-masked]
> Subject: [dhcwg] dhc WG last call on 
> draft-ietf-dhc-rapid-commit-opt-05
> 
> 
> This message announces a WG last call on "Rapid Commit Option 
> for DHCPv4" <draft-ietf-dhc-rapid-commit-opt-05>.  The last 
> call will conclude at 1700 EDT, 2004-07-30.
> 
> Please respond to this WG last call.  If you support 
> acceptance of the document without change, respond with a 
> simple acknowledgment, so that support for the document can 
> be assessed.
> 
> "Rapid Commit Option for DHCPv4" defines a new DHCPv4 option, 
> modeled on the DHCPv6 Rapid Commit option, for obtaining IP 
> address and configuration information using a 2-message 
> exchange rather than the usual 4-message exchange, expediting 
> client configuration. .  This draft is available as 

- Ralph Droms

---

From: Ted Lemon <[email-masked]>
Date: Tue, 13 Jul 2004 09:24:13 -0700

> . (And, I had nothing to do with this IPR claim.)

The Samsung IPR statement allows for royalty-free use, which is what  
I've been agitating for.   I'm not sure why Samsung would think they  
had some kind of IPR on this draft, but since they've formally stated  
that they're not going to try to make people pay to use it, I don't see  
any point in arguing about it.

---

From: "Steve Gonczi" <[email-masked]>
Date: Tue, 13 Jul 2004 14:40:12 -0400

Kudos to Samsung for the new IPR statement...

How do the authors feel about the following tweak 
to the protocol:

When the Rapid commit client decides to accept an address
sent via a Rapid Commit ack, it should send out a DHCPREQUEST
(perhaps with the rapid commit option), 
similar to the classic DHC protocol. 

The sole purpose of this message is to notify any servers that 
offered addresses to release those addresses not selected.

IMHO this is inexpensive to do, and solves the address 
tie-up issue.

Cheers,

Steve Gonczi

---

From: "Bernie Volz" <[email-masked]>
Date: Tue, 13 Jul 2004 16:09:03 -0400

If you want to do something like this, just set the lease time to a small
value - the client will then renew. This works just as well - it gets the
client the address quickly and recovers unused addresses relatively quickly
(most servers will hold offerred addresses for several minutes to allow a
client to request the address, so this isn't much different).

- Bernie

> From: Steve Gonczi [mailto:[email-masked]] 
> Sent: Tuesday, July 13, 2004 2:40 PM
> To: Bernie Volz
> Cc: [email-masked]
> Subject: RE: [dhcwg] dhc WG last call on