Subject: Re: [dhcwg] [Question]DHCPv6 implementations

From: Martin Stiemerling <[email-masked]>
Date: Fri, 02 Jul 2004 10:55:30 +0200

Hi,

NEC has an implementation that is complete and test against various 
different other implementations.  Unfortunately it is not open source.

The Linux one at sourceforge seem to be quite stable and useful.

Hope that helps.

  Martin

NEC Europe Ltd. -- Network Laboratories [email-masked]
PGP Key at:        http://www.stiemerling.org/stiemerling_nec.gpg
IPv4: http://www.ccrle.nec.de

--On Montag, 21. Juni 2004 2:08 Uhr +0400 strates <[email-masked]> wrote:

| I tried to learn what are nowdays available DHCPv6 client/server
| implementations.
| Using the search engines I could only find
| - KAME implementation for *BSDs: stateless DHCPv6, and they are not going
| to improve it
| - Widespread linux-related http://dhcpv6.sourceforge.net implementation
| - Some traces of proprietary CISCO IOS and NEC implementations
| (http://www.dhcpv6.org/ with only relay agent available for public)
| - USAGI implementation which leads to a project which claimed himself
| 'dead'(http://www.linux-ipv6.org/links.html ->
| http://www.hycomat.co.uk/dhcp/)
| - Signs of some Linux implementation (there is some gentoo related
| stuff, config files in google).
| - DHCPv6 support in HP-UX
|
| It is quite strange for me, that only a few incomplete
| implementations are present (yes, stateless IPv6 autoconfiguration
| fulfils a lot of work instead of DHCPv6, and many people seem to be
| satisfied with s-less autoconfiguration and router prefix
| advertisement, but still...)
| Later I found www.dfn.de/uploaded/DHCPv6.pdf and I understood that
| it seems there are really only a few implementations.
| Could anybody advertise anything in addition to the list above?
| Thanks beforehand
|
|
|
| _______________________________________________
| dhcwg mailing list
| [email-masked]
| https://www1.ietf.org/mailman/listinfo/dhcwg

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: strates <[email-masked]>
Date: Tue, 29 Jun 2004 15:40:30 +0400

Subj: KAME DHCPv6 implementation, clarification
Re : JINMEI, Tatuya, Date: Fri, 25 Jun 2004 11:39:26 +0900
----------------------------------------------------------

>> - KAME implementation for *BSDs: stateless DHCPv6, and they are not going
>>   to improve it

> Just checking: what do you mean by "not going to improve it"?  We
> (KAME) are actually seriously maintaining the implementation,
> including bug fixes and supporting new features.  In fact, we've
I didn't phrase my though clear enough. My apologies.
New features are added, indeed
http://orange.kame.net/dev/cvsweb2.cgi/kame/kame/kame/dhcp6/
> Perhaps you simply meant we do not have a plan to implement address
> allocation by DHCPv6.  In that sense you're correct, though I'd not
> say "not going to improve it" meaning luck of a plan for one part of
...
Yes, it is what I meant.

-- 

Ребриков Константин
[email-masked]

--