Subject: RE: [dhcwg] questions on RFC 3046 and RFC 3527

From: "Kuntal Chowdhury" <[email-masked]>
Date: Wed, 18 Aug 2004 19:12:50 -0400

Thanks for your response.

> Because the RemoteID isn't necessarily an IP address? 
> At least one well-known standard (DOCSIS) sepcifies that the Remote ID is
the MAC address of the cable 
> modem, and not an IP address.

It is true that RemoteID is not necessarily an IP address, but it MAY be an
IP address. The question is, if the RemoteID is an IP address, is the use of
RFC 3527 redundant or there are some other reason to include the Link
selection sub-option? 

Regarding the confusion between RFC 3046 and RFC 3527 (Q2), I think RFC 3527
should say: 

"If the DHCP server supports the Relay Agent Information Option the DHCP
server MUST allocate the address based on the following when the received
Relay Agent Information Option contains the Link selection sub-option:
"
-Kuntal

-----Original Message-----
From: Kostur, Andre [mailto:[email-masked]] 
Sent: Wednesday, August 18, 2004 5:32 PM
To: Chowdhury, Kuntal [RICH1:2H18:EXCH]; [email-masked]
Subject: RE: [dhcwg] questions on RFC 3046 and RFC 3527 

> Hello all, 
> 
> I have some questions regarding RFC3046 and RFC3527: 
> 
> Q1. 
> 
> RFC3046 defines the Relay Agent Information Option. One of 
> the sub option 
> for this option is Agent Remote ID Sub-option. A possible 
> value for this 
> sub-option can be "the remote IP address of a point-to-point link". 
Note the phrasing that a _possible_ value for this sub-option.... 
  
> RFC3527 defines another sub-option for Relay Agent 
> Information Option called 
> Link selection sub-option. The possible value for this 
> sub-option can be the 
> subnet (of the link) of the DHCP client. 
> 
> The question is, why the IP address in "Agent Remote ID 
> Sub-option" can't be 
> used to identify the subnet of link for the DHCP client? Why 
> there was a 
> need for two separate sub-options to convey the same thing? 
Because the RemoteID isn't necessarily an IP address? 
At least one well-known standard (DOCSIS) sepcifies that the Remote ID is
the MAC address of the cable modem, and not an IP address.
> Q2. 
> 
> RFC3046 says: 
> 
> " 
> 2.2 Server Operation 
> 
>    DHCP servers unaware of the Relay Agent Information option will 
>    ignore the option upon receive and will not echo it back on 
>    responses.  This is the specified server behavior for unknown 
>    options. 
> " 
> RFC3527 says: 
> 
> " 
>    When the DHCP server is allocating an address and this 
> sub-option is 
>    present, then the DHCP server MUST allocate the address on either: 
> 
>       o  the subnet specified in the link-selection sub-option, or; 
> 
>       o  a subnet on the same link (also known as a network 
> segment) as 
>          the subnet specified by the link-selection sub-option. 
> " 
> 
> The confusion is: RFC3527 seems to mandate the DHCP server to 
> assign IP 
> address based on link-selection sub-option when this 
> sub-option is present 
> in the received request, but RFC3046 says that the entire Relay Agent 
> Information option can be ignored by the DHCP server if it is 
> not supported. 
> Could someone clarify this? 
Correct.  If the server doesn't support 3046, then it cannot possibly
support 3527. 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Wed, 18 Aug 2004 16:45:59 -0700

> RFC 3527 redundant or there are some other reason to include the Link

The DHCP server will use the link selection suboption to select the 
link on which to configure the client.   It will not use the remote ID 
option for this purpose.   If you can't think of a reason to send the 
link selection suboption, do not send it.   It is intended for a 
specific purpose, and is not something that every relay agent should 
send in all circumstances.