Subject: [dhcwg] RE: mboned: draft-jdurand-assign-addr-ipv6-multicast-dhcpv6-00 comments

From: "Dave Thaler" <[email-masked]>
Date: Wed, 4 Aug 2004 15:03:10 -0700

-----Original Message-----
> From: Jerome Durand [mailto:[email-masked]]
> Sent: Wednesday, August 04, 2004 6:01 AM
> To: Dave Thaler
> Cc: [email-masked]; [email-masked]
> Subject: Re: mboned:
draft-jdurand-assign-addr-ipv6-multicast-dhcpv6-00
> comments
> 
> > 1) One of the things that both the API and the MADCAP protocol
provide
> > is
> > allocation of ranges (not "several", but a large number of
addresses,
> > like
> > a block of 400).  This requirement came from applications which want
a
> > larger range to use with things like
> > a) hashing resource ids into groups (I can't remember the specific
> > examples here, but IANA often gets requests for blocks of space, and
I
> > believe many of them are for this reason.  Dave Meyer can probably
> > correct me :),
> > b) assignment to areas inside virtual worlds (from customers in the
DIS
> > industry),
> 
> I don't beleive we really need this feature. A company that wants
plenty
> of addresses can be allocated manually for example a block. But can be
> added to the specs. (prefix delegation for IPv6 multicast address
could
> be the answer)

To be clear, this has nothing to do with company requests.
This was about _application_ requests from the server's address space.

-Dave

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Dave Thaler" <[email-masked]>
Date: Tue, 10 Aug 2004 09:09:29 -0700

Stig Venaas writes:
> > 2) Another thing that both the API and the MADCAP protocol provide
is
> > the ability to enumerate scopes (specifically, human readable names
for
> > them,
> 
> I'm not sure how important that is for IPv6, if the scoping is to
> strictly follow the scoping defined by the 4-bit scope field. Or do
> you want to allow for scopes defined in other ways? I can see some
> reasons for locally defined names though if the user is to choose
> which scope to use based on the names.

The general point is to get the names when you're multihomed to two
different networks.

-Dave