Subject: [dhcwg] [Q] Threat analysis

From: Mayumi Yanagiya <[email-masked]>
Date: Wed, 13 Oct 2004 18:14:12 +0900

Hi,

I have a question on "DHCPv4 Threat Analysis".

In section 4.2, capability of client is described as follows.
  “Clients MUST be able to authenticate servers (to prevent
    misconfigured clients and assure that the correct servers are
    being contacted).”

I understood this sentence didn't mean that client MUST authenticate
server whenever client uses DHCP.  Is my understanding right?

--Mayumi

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz" <[email-masked]>
Date: Thu, 14 Oct 2004 11:01:29 -0400

We may want to lowercase the MUSTs in this section.

It is "MUST be able". This does not mean that they MUST do this.

We were listing the capabilities that we believe are required for any new
work in DHCPv4 security to support. If new work in this area can't provide
this capability, we likely should not consider that work until it does
provide this support.

- Bernie

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Mayumi Yanagiya
> Sent: Wednesday, October 13, 2004 5:14 AM
> To: [email-masked]
> Subject: [dhcwg] [Q] Threat analysis
> 
> 
> Hi,
> 
>   "Clients MUST be able to authenticate servers (to prevent
>     being contacted)."
> I understood this sentence didn't mean that client MUST 
> authenticate server whenever client uses DHCP.  Is my 
> understanding right?
> 
> 
> --Mayumi
> 
>

---

From: Mayumi Yanagiya <[email-masked]>
Date: Fri, 15 Oct 2004 19:10:12 +0900

Hi Berinie,

Thank you for your reply.
I understood the meaning.

The reason why I asked such question is…
I think that broadcast messages are isolated per subscriber in many 
public access services. Thus, it is difficult for another subscriber to 
impersonate DHCP server, and it is easy to impersonate DHCP client.
So, I personally think that client authentication by server is more 
important.

Best Regards,
--Mayumi