Subject: [Dime] Session Management APIs

From: "Monal Sengar" <[email-masked]>
Date: Mon, 7 Aug 2006 14:38:36 +0530

Hi ,

As per draft draft-ietf-aaa-diameter-api-04 , there are some APIs for
Session Management e.g.
1.AAAStartSession( )
2.AAAEndSession( )
3.AAAAbortSession ( ) e.t.c

But in case , we are implementing the Session state Machine (Sec 8 RFC 3588)
in application and not in Diameter Base Protocol (DBP) then do we need to
implement these API's in stack.

Thanks and Regards
Monal
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: santhosh <[email-masked]>
Date: Mon, 07 Aug 2006 17:20:48 +0800

If Application is implementing the session state machine the Stack does
not need to provide this API..

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Monal Sengar
Sent: Monday, August 07, 2006 5:09 PM
To: [email-masked]; [email-masked]
Subject: [AAA-WG]: Session Management APIs

Hi ,

But in case , we are implementing the Session state Machine (Sec 8 RFC
3588) in application and not in Diameter Base Protocol (DBP) then do we
need to implement these API's in stack. 

Thanks and Regards
Monal