Subject: RE: criteria for new app ID [was: Re: [Dime] Mobile IPv6 Bootstrapping- "Application ID"vs."NAS-Port-Type AVP/Service-Type": Summary]

From: "Glen Zorn \(gwz\)" <[email-masked]>
Date: Mon, 21 Aug 2006 13:32:03 -0700

Anders Kristensen <mailto:[email-masked]> supposedly scribbled:

...

>> Just to stir the pot a bit .. I agree with you, we are discussing how
>> have a Diameter extension and how it fits into the existing
>> deployment. If using MIPv6 with Diameter creates new manditory
>> attributes and/or changes the basic state machine, I assume a new
>> application ID should be used.
> 
> I think there are other conditions under which a separate app ID is
> in order, e.g. if mandatory AVPs have been removed from the
> definition of messages or, more importantly, if the semantics of the
> new app are "sufficiently different" from those of the original
> application.    
> 
> Regarding the latter case consider, for example, the definition of
> AA-Request in RFC 4005. The AAR definition lists pretty much all AVPs
> as being optional meaning one can reuse AAR to do basically anything.
> 
> 3GPP's Gq spec defines its own version of the AA-Request which reuses
> *none* of the 4005 specific AVPs but includes a bunch of its own
> AVPs, also all optional. Gq was given its own app ID which I think
> was appropriate because although nominally they're reusing AAR and
> some other messages, effectively it's a very different application.
> This is even though a Gq AAR is, technically speaking, a valid 4005
> AAR, also - except for the app ID, that is.     
> 
> (I see now that 4005's AAR has a mandatory Auth-Request-Type AVP and
> Gq's AAR does not but that doesn't really change the point.) 

Actually, it completely invalidates your example: Gq was _required_ to use a different app ID _because_ it had a different set of mandatory AVPs.  Note that 1) modifying the set of mandatory AVPs  is enough to require the usage of a different app ID & 2) if you change the set of values allowed in a mandatory AVP, you have modified the set of mandatory AVPs.

...

Hope this helps,

~gwz

Why is it that most of the world's problems can't be solved by simply
  listening to John Coltrane? -- Henry Gabriel

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Anders Kristensen <[email-masked]>
Date: Mon, 21 Aug 2006 17:14:30 -0400

> Actually, it completely invalidates your example: Gq was _required_ to use a different app ID _because_ it had a different set of mandatory AVPs.  Note that 1) modifying the set of mandatory AVPs…

Well, suppose Gq's AAR did include that AVP. The question is whether 
we'd want Gq to define its own app ID in that case. I think we would 
because it seems semantically quite different from NASREQ.

Anders