Subject: Re: [Dime] Application ID, Session Id and message flows

From: "Glen Zorn" <[email-masked]>
Date: Fri, 3 Oct 2008 20:33:46 +0700

Hi,

As far as I know, there is no RAR message in Sh Interface.

As far as I know, there is no Sh Interface in Diameter.   Seriously, if you
guys can't figure out how your own "standards" work that's a shame but it
doesn't make it a part of the work of the either the IETF or the dime WG.

The messages supported in Sh Interface are

UDR/UDA

PUR/PUA

SNR/SNA

PNR/PNA

All these messages use the application ID of Sh.

Can you please elaborate more on the context of RAR in the Sh interface?

Regds,

Vipul Aggarwal

Senior Software Engineer

A R I C E N T

The Presidency Tower-A

351/2, Sector 14, M.G Road

Gurgaon, 122001,  Haryana, India

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Bartosz Baranowski
Sent: Friday, September 26, 2008 8:45 PM
To: [email-masked]
Subject: [Dime] Application ID, Session Id and message flows

Hi
Im trying to figure few things out for some time now and up until now I have
been hearing contradicting voices wherever I turn myself.
I would like to know what are values of ApplicationID set in messages - Base
messages used in context of Sh interface to Authanticate/Authorize user?

Lets consider flow like follows (not sure if its valid or not):

CLIENT                        

       SERVER(HSS ?)
     | -------------    UDR -----------------> |
SesssionId_1, AppId_1 ==Sh
                           X
     | <-----------    RAR ------------------- |
SessionId_2, AppId_2= Base
     | -------------    RAA -----------------> |
SessionId_2, AppId_2= Base
     | -------------    UDR -----------------> |
SesssionId_1, AppId_1 ==Sh
     | <-----------   UDA -------------------- |
SesssionId_1, AppId_1 ==Sh

Does X indicates UDA denying access?
Is SessionId_1 equal to SessionId_2?
Is AppId_2== Base or is it equal to AppId_2 ?

Thanks 

  _____  

"DISCLAIMER: This message is proprietary to Aricent and is intended solely
for the use of the individual to whom it is addressed. It may contain
privileged or confidential information and should not be circulated or used
for any purpose other than for what it is intended. If you have received
this message in error,please notify the originator immediately. If you are
not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this
message. Aricent accepts no responsibility for loss or damage arising from
the use of the information transmitted by this email including damage from
virus."

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: "Glen Zorn" <[email-masked]>
Date: Fri, 3 Oct 2008 20:35:34 +0700

Is there any way that we can stop this incessant 3GPP spam?

> A well written IETF document must describe the Application ID setting
> for the messages an application uses.
> 
> Bartosz Baranowski wrote:
> > Hi
> > Thanks, this clears my mind - should be mentioned in TS or rfc.
> >
> > On Fri, Sep 26, 2008 at 6:03 PM, Vipul2 Aggarwal
> > <[email-masked] <mailto:[email-masked]>>
> wrote:
> >
> >     Hi,
> >
> >
> >
> >     You are right. There is no re-authentication scenario in Sh.
> >
> >
> >
> >     Yes, there are interfaces (like NASReq, EAP, Wm, Rx, that I am
> >     aware of) that use base messages. But, these interfaces use their
> >     own application ID in these messages i.e. they don't use the
> >     application ID of Base (i.e. 0) in the messages.
> >
> >
> >
> >     For e.g. NASReq interface uses the messages STR/STA, RAR/RAA,
> >     ASR/ASA. But, the application ID that goes in these messages is
> >     that of NASReq (i.e. 1).
> >
> >
> >
> >     Hope this helps.
> >
> >     Regds,
> >
> >     *Vipul Aggarwal*
> >
> >     Senior Software Engineer
> >
> >
> >
> >     *A R I C E N T*
> >
> >
> >
> >     The Presidency Tower-A
> >
> >     -----------------------------------------------------------------
> -------
> >
> >     *From:* Bartosz Baranowski [mailto:[email-masked]
> >     <mailto:[email-masked]>]
> >     *Sent:* Friday, September 26, 2008 9:14 PM
> >     *To:* Vipul2 Aggarwal
> >     *Cc:* [email-masked] <mailto:[email-masked]>
> >     *Subject:* Re: [Dime] Application ID, Session Id and message
> flows
> >
> >
> >
> >     Hi
> >     Thanks for such quick answer.
> >     See inline
> >
> >     On Fri, Sep 26, 2008 at 5:29 PM, Vipul2 Aggarwal
> >     <[email-masked]
> <mailto:[email-masked]>>
> >     wrote:
> >
> >     Hi,
> >
> >
> >
> >     Yes I know, there is no such message in Sh defined
> >
> >     Someone just threw example of Sh scenario where server reqeust
> >     authentication - I didnt find anything about that in TS, rfc or
> >     google, neither I was able to find any example scenarios (of any
> >     kind, not regardign this particular case), so I have decided to
> >     post here.
> >     Up until now I was sure that there is not authentication in Sh
> >     scenarios, or is there?
> >     Is there any case of application that uses base messages? I mean
> >     there is no app id in Base, this would indicate that all
> >     aplication have to support those?
> >
> >         *Vipul Aggarwal*
> >         *A R I C E N T*
> >         -------------------------------------------------------------
> -----------
> >
> >         *From:* [email-masked] <mailto:[email-masked]>
> >         [mailto:[email-masked] <mailto:[email-masked]>]
> >         *On Behalf Of *Bartosz Baranowski
> >         *Sent:* Friday, September 26, 2008 8:45 PM
> >         *To:* [email-masked] <mailto:[email-masked]>
> >         *Subject:* [Dime] Application ID, Session Id and message
> flows
> >
> >
> >
> >         Hi
> >
> >
> >         Im trying to figure few things out for some time now and up
> >         until now I have been hearing contradicting voices wherever I
> >         turn myself.
> >         I would like to know what are values of ApplicationID set in
> >         messages - Base messages used in context of Sh interface to
> >         Authanticate/Authorize user?
> >
> >              | -------------    UDR ----------------->
> >         |                             SesssionId_1, AppId_1 ==Sh
> >                                    X
> >              | <-----------    RAR -------------------
> >         |                             SessionId_2, AppId_2= Base
> >              | -------------    RAA ----------------->
> >         |                             SessionId_2, AppId_2= Base
> >              | -------------    UDR ----------------->
> >         |                             SesssionId_1, AppId_1 ==Sh
> >              | <-----------   UDA --------------------
> >         |                             SesssionId_1, AppId_1 ==Sh
> >
> >
> >         -------------------------------------------------------------
> -----------
> >
> >         "DISCLAIMER: This message is proprietary to Aricent and is
> >         intended solely for the use of the individual to whom it is
> >         addressed. It may contain privileged or confidential
> >         information and should not be circulated or used for any
> >         purpose other than for what it is intended. If you have
> >         received this message in error,please notify the originator
> >         immediately. If you are not the intended recipient, you are
> >         notified that you are strictly prohibited from using,
> copying,
> >         altering, or disclosing the contents of this message. Aricent
> >         accepts no responsibility for loss or damage arising from the
> >         use of the information transmitted by this email including
> >         damage from virus."
> >
> >
> >         [email-masked] <mailto:[email-masked]>
> >     --
> >     JBoss R & D
> >     ==================================
> >     Word of criticism meant to improve is always step forward.
> >
> >
> >     -----------------------------------------------------------------
> -------
> >     "DISCLAIMER: This message is proprietary to Aricent and is
> >     intended solely for the use of the individual to whom it is
> >     addressed. It may contain privileged or confidential information
> >     and should not be circulated or used for any purpose other than
> >     for what it is intended. If you have received this message in
> >     error,please notify the originator immediately. If you are not
> the
> >     intended recipient, you are notified that you are strictly
> >     prohibited from using, copying, altering, or disclosing the
> >     contents of this message. Aricent accepts no responsibility for
> >     loss or damage arising from the use of the information
> transmitted
> >     by this email including damage from virus."
> >
> >
> >
> >
> > --
> > Bartosz Baranowski
> > JBoss R & D
> > ==================================
> > Word of criticism meant to improve is always step forward.
> > ---------------------------------------------------------------------
> ---
> >