Subject: [Dime] DRMP: Different priority for answer message

From: Steve Donovan <[email-masked]>
Date: Thu, 10 Sep 2015 15:28:39 -0500

I have been notified of at least one use case (in NS/EP LTE Access 
Network GIR, Issue 2.0, January 2013) where there is the need for an 
answer message to have a different, higher, priority then the priority 
of the request message.

"There is one use case (Advance-Priority-SPR) where the CCR does not 
contain a Priority-Level AVP with a PS value but the corresponding CCA 
does. In this case, the expectation is that the Answer be processed with 
a higher priority than the Request.  More specifically the Answer is 
processed at the highest priority in the system, including non-PS Answers."

My proposed solution, which would not require application level 
processing by agents, is as follows:

- We keep the default that the priority carried in the request message 
applies to the transaction and, as a result, applies to the answer 
message.  As a result, the default processing does not require the 
answer message to carry a Priority AVP.

- We allow the DRMP AVP to optionally be carried in answer messages.

- In the case that there is a DRMP AVP in an answer message, the 
priority in the answer message takes precedence over the priority 
specified in the request message.

Thoughts?

Regards,

Steve

---

From: <[email-masked]>
Date: Fri, 11 Sep 2015 10:47:16 +0000

Hi Steve,

I like the proposal.
By default, the Priority in the request applies for the transaction, except if the Priority AVP is in the answer.
But it means that the priority AVP in the answer will take precedence whatever the value, higher or lower than the one received in the request. I think that it is somehow assumed in your proposal but I just want to be sure.

regards,

Lionel

-----Message d'origine-----
De : DiME [mailto:[email-masked]] De la part de Steve Donovan
Envoyé : jeudi 10 septembre 2015 22:29
À : [email-masked]
Objet : [Dime] DRMP: Different priority for answer message

I have been notified of at least one use case (in NS/EP LTE Access Network GIR, Issue 2.0, January 2013) where there is the need for an answer message to have a different, higher, priority then the priority of the request message.

"There is one use case (Advance-Priority-SPR) where the CCR does not contain a Priority-Level AVP with a PS value but the corresponding CCA does. In this case, the expectation is that the Answer be processed with a higher priority than the Request.  More specifically the Answer is processed at the highest priority in the system, including non-PS Answers."

My proposed solution, which would not require application level processing by agents, is as follows:

- We keep the default that the priority carried in the request message applies to the transaction and, as a result, applies to the answer message.  As a result, the default processing does not require the answer message to carry a Priority AVP.

- In the case that there is a DRMP AVP in an answer message, the priority in the answer message takes precedence over the priority specified in the request message.

Thoughts?

Regards,

Steve

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Steve Donovan <[email-masked]>
Date: Fri, 11 Sep 2015 09:01:51 -0500

Lionel,

You are correct, I had focused on the priority in the answer message 
being higher but it would take priority both when higher and lower.

Steve