Subject: Re: [Din] how to build an Internet-wide federation (for “upper layers”)

From: Nick Roy <[email-masked]>
Date: Fri, 22 Apr 2016 19:22:55 +0000

My observation from the global research and education space, where we have built multi-lateral SAML authN / (~authZ) federations is that these huge embedded infrastructure providers (the big cloud services, etc) are trying to gain a lock on "Internet identity" by herding as many sectors as possible into their cloud and offering really easy "federation" to other services of interest to their markets.  This does a huge disservice to openness, scalability, portable identity, etc.

Nick

From: Din <[email-masked]<mailto:[email-masked]>> on behalf of Dirk Kutscher <[email-masked]<mailto:[email-masked]>>
Date: Friday, April 22, 2016 at 6:40 AM
To: "Hejianfei (Jeffrey)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Din] how to build an Internet-wide federation (for “upper layers”)

Hi Jeffrey,

thanks for the discussion starter.

(All, Jeffrey’s presentation from BA is available at https://trac.tools.ietf.org/group/irtf/trac/wiki/blockchain-federation)

A few questions from my side:

Currently there seems to be a trend in the exact opposite direction, i.e., connectivity providers trying to provide extend their footprint on the vertical value chain (e.g., ASPs moving into ISP territory, rolling out their own access or mobile/fixed carriers trying to become content providers).

Would you say that this is happening because of a lack of Internet-wide federation? Have you thought about what would motivate dominating players today to engage in federation?

From a research perspective, I’d be interested in figuring out the separation of “how to share and access the data” from “how to understand and process the data” that you mentioned. For example, I could see Internet federation emerging as a higher layer on top of an ICN network layer.

Regarding how to organize/facilitate follow-up discussions, it would be great to get more views from people with different backgrounds (especially people who develop/operate services).

I am looking forward to that discussion.

Cheers,
Dirk

From: Din [mailto:[email-masked]] On Behalf Of Hejianfei (Jeffrey)
Sent: Donnerstag, 21. April 2016 14:54
To: [email-masked]<mailto:[email-masked]>
Subject: [Din] how to build an Internet-wide federation (for “upper layers”)

Hi there,

An ice-breaking post? Hopefully!
During IETF-95, I gave a talk “Internet-wide Federation” in the meeting “Distributed Internet Architectures” organized by Dirk. In fact, the main challenge I want to address is best stated in the latest European Horizon 2020 call: ” Current centralised platforms for big and social data management consolidate the dominance of existing incumbent actors, stifling innovation and allowing less and less control over the data by citizens. Distributed architectures and decentralised platforms have a huge potential to enable the creation of viable alternatives to current dominant models.” (ICT-12b, Horizon2020 Work Programme2016-2017)
P2P and federation are two modes of decentralized platform. In my view, “federation” is more promising. Note: Federation= “a union of  autonomous/peer domains”, “client a—server A—server B—client b”.
To build an Internet-wide federation with hundreds or thousands of domains, the main challenge is that the federation needs to be stable and avoid the fragmentation: the peering interfaces among domains have to keep stable so that this federation could grow to be Internet-wide. If these interfaces have to change with the introduction of new services, this Internet-wide federation will break into fragments and gradually fail when facing competition from the “centralized service system” since the centralized platforms could can deploy new services overnight.
Using the experience of current Internet for reference, a layering architecture may be the correct direction. Assuming that information sharing is the mainstream usage of Internet, we may identify some functions common and stable to all services and implement them in the federation, while leave other dynamic functions at the edge of the infrastructure. It is still an open question how to separate the functions, but one possible approach is to separate “how to share and access the data” from “how to understand and process the data”. The federation itself implements only the first part of functions, such as : IDs for smart object/user/content, user relationships, federated authentication and authorization for access control, publishing and subscribing in an online-social-network style, etc.

Based on these initial thoughts, I think probably it would be interesting to the research community in IRTF, to investigate the challenges in building Internet-wide federation for data sharing for various scenarios, and to explore design principles at the architectural level that can be used as guidelines for standardization in other communities like IETF.
If we could have a research group in IRTF, we could investigate several related areas, for examples:
-    Understanding the requirements and challenges for potential new Internet-wide federations, including IoT, repository/data sharing, cloud2cloud etc.
-    Architectural principles that may provide the scalability and stability required for an Internet-wide federation
-    Systematic description of data and metadata, user and user group, devices generating data (like sensors), actuators..
-    Understanding the relationship between the federation of data sharing and the applications presenting or processing the data
-    Security and privacy for data sharing, especially cross domains, in a federation
-    Efficiency of data retrieval and data processing in a distributed architecture

Cheers,
Jeffrey

---

From: Jon Crowcroft <[email-masked]>
Date: Sat, 23 Apr 2016 09:36:55 +0100

agree - as mentioned before, we have examples of succesful id
federation systems - best one i use daily is eduroam...

there's really no excuse:)

> My observation from the global research and education space, where we 
> have built multi-lateral SAML authN / (~authZ) federations is that these 
> huge embedded infrastructure providers (the big cloud services, etc) are 
> trying to gain a lock on "Internet identity" by herding as many sectors 
> as possible into their cloud and offering really easy "federation" to 
> other services of interest to their markets.  This does a huge disservice 
> to openness, scalability, portable identity, etc.
> 
> Nick
> 
> From: Din <[email-masked]<mailto:[email-masked]>> on behalf 
> of Dirk Kutscher <[email-masked]<mailto:[email-masked]>>
> To: "Hejianfei (Jeffrey)" 
> <[email-masked]<mailto:[email-masked]>>, 
> "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
> (All, Jeffrey’s presentation from BA is available at 
> https://trac.tools.ietf.org/group/irtf/trac/wiki/blockchain-federation)
> 
> Currently there seems to be a trend in the exact opposite direction, 
> i.e., connectivity providers trying to provide extend their footprint on 
> the vertical value chain (e.g., ASPs moving into ISP territory, rolling 
> out their own access or mobile/fixed carriers trying to become content 
> providers).
> 
> Would you say that this is happening because of a lack of Internet-wide 
> federation? Have you thought about what would motivate dominating players 
> today to engage in federation?
> 
> From a research perspective, I’d be interested in figuring out the 
> separation of “how to share and access the data” from “how to 
> understand and process the data” that you mentioned. For example, I 
> could see Internet federation emerging as a higher layer on top of an ICN 
> network layer.
> 
> Regarding how to organize/facilitate follow-up discussions, it would be 
> great to get more views from people with different backgrounds 
> (especially people who develop/operate services).
> 
> During IETF-95, I gave a talk “Internet-wide Federation” in the 
> meeting “Distributed Internet Architectures” organized by Dirk. In 
> fact, the main challenge I want to address is best stated in the latest 
> European Horizon 2020 call: ” Current centralised platforms for big and 
> social data management consolidate the dominance of existing incumbent 
> actors, stifling innovation and allowing less and less control over the 
> data by citizens. Distributed architectures and decentralised platforms 
> have a huge potential to enable the creation of viable alternatives to 
> current dominant models.” (ICT-12b, Horizon2020 Work Programme2016-2017)
> P2P and federation are two modes of decentralized platform. In my view, 
> “federation” is more promising. Note: Federation= “a union of  
> autonomous/peer domains”, “client a—server A—server B—client 
> b”.
> To build an Internet-wide federation with hundreds or thousands of 
> domains, the main challenge is that the federation needs to be stable and 
> avoid the fragmentation: the peering interfaces among domains have to 
> keep stable so that this federation could grow to be Internet-wide. If 
> these interfaces have to change with the introduction of new services, 
> this Internet-wide federation will break into fragments and gradually 
> fail when facing competition from the “centralized service system” 
> since the centralized platforms could can deploy new services overnight.
> Using the experience of current Internet for reference, a layering 
> architecture may be the correct direction. Assuming that information 
> sharing is the mainstream usage of Internet, we may identify some 
> functions common and stable to all services and implement them in the 
> federation, while leave other dynamic functions at the edge of the 
> infrastructure. It is still an open question how to separate the 
> functions, but one possible approach is to separate “how to share and 
> access the data” from “how to understand and process the data”. The 
> federation itself implements only the first part of functions, such as : 
> IDs for smart object/user/content, user relationships, federated 
> authentication and authorization for access control, publishing and 
> subscribing in an online-social-network style, etc.
> 
> Based on these initial thoughts, I think probably it would be interesting 
> to the research community in IRTF, to investigate the challenges in 
> building Internet-wide federation for data sharing for various scenarios, 
> and to explore design principles at the architectural level that can be 
> used as guidelines for standardization in other communities like IETF.
> -    Understanding the requirements and challenges for potential new 
> Internet-wide federations, including IoT, repository/data sharing, 
> cloud2cloud etc.
> -    Architectural principles that may provide the scalability and 
> stability required for an Internet-wide federation
> -    Systematic description of data and metadata, user and user group, 
> devices generating data (like sensors), actuators..
> -    Understanding the relationship between the federation of data 
> sharing and the applications presenting or processing the data
> _______________________________________________
> Din mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/din
>