Subject: [Din] how to build an Internet-wide federation (for “upper layers”)

From: "Hejianfei (Jeffrey)" <[email-masked]>
Date: Thu, 21 Apr 2016 12:54:06 +0000

Hi there,

An ice-breaking post? Hopefully!
During IETF-95, I gave a talk “Internet-wide Federation” in the meeting “Distributed Internet Architectures” organized by Dirk. In fact, the main challenge I want to address is best stated in the latest European Horizon 2020 call: ” Current centralised platforms for big and social data management consolidate the dominance of existing incumbent actors, stifling innovation and allowing less and less control over the data by citizens. Distributed architectures and decentralised platforms have a huge potential to enable the creation of viable alternatives to current dominant models.” (ICT-12b, Horizon2020 Work Programme2016-2017)
P2P and federation are two modes of decentralized platform. In my view, “federation” is more promising. Note: Federation= “a union of  autonomous/peer domains”, “client a—server A—server B—client b”.
To build an Internet-wide federation with hundreds or thousands of domains, the main challenge is that the federation needs to be stable and avoid the fragmentation: the peering interfaces among domains have to keep stable so that this federation could grow to be Internet-wide. If these interfaces have to change with the introduction of new services, this Internet-wide federation will break into fragments and gradually fail when facing competition from the “centralized service system” since the centralized platforms could can deploy new services overnight.
Using the experience of current Internet for reference, a layering architecture may be the correct direction. Assuming that information sharing is the mainstream usage of Internet, we may identify some functions common and stable to all services and implement them in the federation, while leave other dynamic functions at the edge of the infrastructure. It is still an open question how to separate the functions, but one possible approach is to separate “how to share and access the data” from “how to understand and process the data”. The federation itself implements only the first part of functions, such as : IDs for smart object/user/content, user relationships, federated authentication and authorization for access control, publishing and subscribing in an online-social-network style, etc.

Based on these initial thoughts, I think probably it would be interesting to the research community in IRTF, to investigate the challenges in building Internet-wide federation for data sharing for various scenarios, and to explore design principles at the architectural level that can be used as guidelines for standardization in other communities like IETF.
If we could have a research group in IRTF, we could investigate several related areas, for examples:
-    Understanding the requirements and challenges for potential new Internet-wide federations, including IoT, repository/data sharing, cloud2cloud etc.
-    Architectural principles that may provide the scalability and stability required for an Internet-wide federation
-    Systematic description of data and metadata, user and user group, devices generating data (like sensors), actuators..
-    Understanding the relationship between the federation of data sharing and the applications presenting or processing the data
-    Security and privacy for data sharing, especially cross domains, in a federation
-    Efficiency of data retrieval and data processing in a distributed architecture

Cheers,
Jeffrey

---

From: Dirk Kutscher <[email-masked]>
Date: Fri, 22 Apr 2016 12:40:07 +0000

Hi Jeffrey,

thanks for the discussion starter.

(All, Jeffrey’s presentation from BA is available at https://trac.tools.ietf.org/group/irtf/trac/wiki/blockchain-federation)

A few questions from my side:

Currently there seems to be a trend in the exact opposite direction, i.e., connectivity providers trying to provide extend their footprint on the vertical value chain (e.g., ASPs moving into ISP territory, rolling out their own access or mobile/fixed carriers trying to become content providers).

Would you say that this is happening because of a lack of Internet-wide federation? Have you thought about what would motivate dominating players today to engage in federation?

>From a research perspective, I’d be interested in figuring out the separation of “how to share and access the data” from “how to understand and process the data” that you mentioned. For example, I could see Internet federation emerging as a higher layer on top of an ICN network layer.

Regarding how to organize/facilitate follow-up discussions, it would be great to get more views from people with different backgrounds (especially people who develop/operate services).

I am looking forward to that discussion.

Cheers,
Dirk

From: Din [mailto:[email-masked]] On Behalf Of Hejianfei (Jeffrey)
Sent: Donnerstag, 21. April 2016 14:54
To: [email-masked]
Subject: [Din] how to build an Internet-wide federation (for “upper layers”)

Hi there,

Cheers,
Jeffrey

---

From: "Hejianfei (Jeffrey)" <[email-masked]>
Date: Fri, 22 Apr 2016 14:26:45 +0000

Hi Dirk,

Motivation issue:
I think we can start a new federation from a new area(e.g IoT) or a niche market(e.g research data sharing among universities). In these areas, the federation is a nature choice due to decentralized administration. Once there are enough active users in this federation, the federation may be attractive for other applications to join.

The research topics:
The idea to the separation of “how to share and access the data” from “how to understand and process the data” reflects a layering methodology like current Internet, but it is still an open issue to me which functions belong to the first (semantics-less) part in the lower layer, while others(semantics-rich) in the upper layers. I only have some initial feelings that the lower layer may be like an Internet-wide file system or database system. That’s why I am interested in IPFS. But things working well in one domain maybe does not in a federation.
As for the relationship with ICN, I think I need more discussion with ICN experts, like you.

People who develop/operate services:
I think if we expose this topic to the research community, more people may join the discussion. If we take IoT as potential use cases, there are many experts in IETF/IRTF. If we take the “research data sharing” as a starting use case, many researchers are themselves users or operators.

Cheers,
Jeffrey

发件人: Din [mailto:[email-masked]] 代表 Dirk Kutscher
发送时间: 2016年4月22日 20:40
收件人: Hejianfei (Jeffrey); [email-masked]
主题: Re: [Din] how to build an Internet-wide federation (for “upper layers”)

Hi Jeffrey,

Cheers,
Dirk

From: Din [mailto:[email-masked]] On Behalf Of Hejianfei (Jeffrey)
Sent: Donnerstag, 21. April 2016 14:54
To: [email-masked]<mailto:[email-masked]>
Subject: [Din] how to build an Internet-wide federation (for “upper layers”)

Hi there,

P2P and federation are two modes of decentralized platform. In my view, “federation” is more promising. Note: Federation= “a union of  autonomous/peer domains”, “client a―server A―server B―client b”.

Cheers,
Jeffrey

---

From: Jon Crowcroft <[email-masked]>
Date: Sat, 23 Apr 2016 12:52:13 +0200

here's the poster-child example of how we do federation, but how it leads
to monopoly systems: it's called WWW.
The surprise to the hypermedia community that Berners-Lee sprung was the
idea of unidirectional URLs - essentially, a web site publishes stuff
without need for anything other than a server on a pubic, hopefully
always-on IP address. Word-of-mouth causes people to hear about the web
site, and link to it - no coordination with the server/site owner needed at
all. Bingo federation.

So what's that magic "word-of-mouth"? well, originally (circa 1992) it was
a) email. b) sites that manually listed other sites (directories, like
sunsite). but of course, eventually someone thought of robots, spiders, and
behold, Search Engines proliferated. But then given there's only one global
public repository of information on the one global public reachable
internet, why would you need more than one search engine? So the
proliferation collapsed from yahoo and altavista and so on, down to google.
A single entry point to a billion websites, which were all federal, but now
all found via one place.

Next step in evolution is that it isn't so cheap and easy to get a site
that has a global reachable IP address and is (affordably) available 24/7,
better than 5 9s. so people start putting there content on hosting sites,
in data centers, and lo & behold, the cloud emerges. The asymmetry of
bandwidth, reachability and availability of a home broadband link just
doesn't really work well, so every home having a web server (or a home
cloud) is tricky - (note, for later, with fiber to the home in much of
developed parts of Europe at least, and fairly rapidly deploying IPv6, and
better firewall technology replacing NATs, we could see a reversal of this
over the next few years).

Then writing web pages that serve active content, and deal with all the
different quirks of different browsers became more and more expensive in
developer time, so people decided to shrink wrap systems, and low and
behold "apps" appeared, with limited functionality, but high reliability -
server side for the app is also simplified. Asymmetry gets even more
pronounced in the Internet.

But then there are contrasts between interworking, and  gratuitously
restrictive cloud based systems - lets take webmail versus
online-social-nets (OSN).

If you don't interwork webmail with SMTP (and IMAP) you are going to have a
walled garden, so its hard to grow your business. If you don't interwork
your web based OSN (trust me - download all your data from your favourite
OSN - you'll note its just a bunch of web pages), then you try and capture
the whole market - why? because once you tip it, like search, everyone
"has" to be on "your" system......no wait, that isn't true. Its just a URL.
WHy can't I have a "friend" on Sina Weibo from my account on Ello? A friend
list is just a list of URLs (or could be). Apps can run across me & my
friends (recommenders) the way search runs over multiple sites in the web.
Apps just need to be able to parse content (hey its all xml anyhow, game
over).

So obviously what we have here is restriction purely because of market
control. The technical arguments for centralisation & asymmetry I gave for
the app/cloud world, do not apply to some services really. So one could
argue that lack of federation where there are no technical barriers for
federation is a layer 11 problem (politics/economics) and not really a
technical (ietf/irtf) one.....

by two bit-cents:-)

cheers
jon

On Fri, Apr 22, 2016 at 4:26 PM, Hejianfei (Jeffrey) <[email-masked]>
wrote:

> Hi Dirk,
>
>
>
> Motivation issue:
>
> I think we can start a new federation from a new area(e.g IoT) or a niche
> market(e.g research data sharing among universities). In these areas, the
> federation is a nature choice due to decentralized administration. Once
> there are enough active users in this federation, the federation may be
> attractive for other applications to join.
>
>
>
> The research topics:
>
> The idea to the separation of “how to share and access the data” from “how
> to understand and process the data” reflects a layering methodology like
> current Internet, but it is still an open issue to me which functions
> belong to the first (semantics-less) part in the lower layer, while
> others(semantics-rich) in the upper layers. I only have some initial
> feelings that the lower layer may be like an Internet-wide file system or
> database system. That’s why I am interested in IPFS. But things working
> well in one domain maybe does not in a federation.
>
> I think if we expose this topic to the research community, more people may
> join the discussion. If we take IoT as potential use cases, there are many
> experts in IETF/IRTF. If we take the “research data sharing” as a
> starting use case, many researchers are themselves users or operators.
>
>
>
> Cheers,
>
> Jeffrey
>
>
>
> *发件人:* Din [mailto:[email-masked]] *代表 *Dirk Kutscher
> *发送时间:* 2016年4月22日 20:40
> *收件人:* Hejianfei (Jeffrey); [email-masked]
> *主题:* Re: [Din] how to build an Internet-wide federation (for “upper
> layers”)
>
>
>
> Hi Jeffrey,
>
>
>
> (All, Jeffrey’s presentation from BA is available at
> https://trac.tools.ietf.org/group/irtf/trac/wiki/blockchain-federation)
>
>
>
> Currently there seems to be a trend in the exact opposite direction, i.e.,
> connectivity providers trying to provide extend their footprint on the
> vertical value chain (e.g., ASPs moving into ISP territory, rolling out
> their own access or mobile/fixed carriers trying to become content
> providers).
>
>
>
> Would you say that this is happening because of a lack of Internet-wide
> federation? Have you thought about what would motivate dominating players
> today to engage in federation?
>
>
>
> From a research perspective, I’d be interested in figuring out the
> separation of “how to share and access the data” from “how to understand
> and process the data” that you mentioned. For example, I could see Internet
> federation emerging as a higher layer on top of an ICN network layer.
>
>
>
> Regarding how to organize/facilitate follow-up discussions, it would be
> great to get more views from people with different backgrounds (especially
> people who develop/operate services).
>
>
>
> *From:* Din [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Hejianfei (Jeffrey)
> *Sent:* Donnerstag, 21. April 2016 14:54
> *To:* [email-masked]
> *Subject:* [Din] how to build an Internet-wide federation (for “upper
> layers”)
>
>
>
> Hi there,
>
>
>
> During IETF-95, I gave a talk “Internet-wide Federation” in the meeting
> “Distributed Internet Architectures” organized by Dirk. In fact, the main
> challenge I want to address is best stated in the latest European Horizon
> 2020 call: ” Current centralised platforms for big and social data
> management consolidate the dominance of existing incumbent actors, stifling
> innovation and allowing less and less control over the data by citizens.
> Distributed architectures and decentralised platforms have a huge potential
> to enable the creation of viable alternatives to current dominant models.”
> (ICT-12b, Horizon2020 Work Programme2016-2017)
>
> P2P and federation are two modes of decentralized platform. In my view,
> “federation” is more promising. Note: Federation= “a union of
> autonomous/peer domains”, “client a—server A—server B—client b”.
>
> To build an Internet-wide federation with hundreds or thousands of
> domains, the main challenge is that the federation needs to be stable and
> avoid the fragmentation: the peering interfaces among domains have to keep
> stable so that this federation could grow to be Internet-wide. If these
> interfaces have to change with the introduction of new services, this
> Internet-wide federation will break into fragments and gradually fail when
> facing competition from the “centralized service system” since the
> centralized platforms could can deploy new services overnight.
>
> Using the experience of current Internet for reference, a layering
> architecture may be the correct direction. Assuming that information
> sharing is the mainstream usage of Internet, we may identify some functions
> common and stable to all services and implement them in the federation,
> while leave other dynamic functions at the edge of the infrastructure. It
> is still an open question how to separate the functions, but one possible
> approach is to separate “how to share and access the data” from “how to
> understand and process the data”. The federation itself implements only the
> first part of functions, such as : IDs for smart object/user/content, user
> relationships, federated authentication and authorization for access
> control, publishing and subscribing in an online-social-network style, etc.
>
>
>
> Based on these initial thoughts, I think probably it would be interesting
> to the research community in IRTF, to investigate the challenges in
> building Internet-wide federation for data sharing for various scenarios,
> and to explore design principles at the architectural level that can be
> used as guidelines for standardization in other communities like IETF.
>
> -    Understanding the requirements and challenges for potential new
> Internet-wide federations, including IoT, repository/data sharing,
> cloud2cloud etc.
>
> -    Architectural principles that may provide the scalability and
> stability required for an Internet-wide federation
>
> -    Systematic description of data and metadata, user and user group,
> devices generating data (like sensors), actuators..
>
> -    Understanding the relationship between the federation of data sharing
> and the applications presenting or processing the data
>
> _______________________________________________
> Din mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/din
>
>

---

From: Dirk Kutscher <[email-masked]>
Date: Sun, 24 Apr 2016 20:24:09 +0000

Oh yes, there are definitely some layer 11 barriers for federation of, for example, OSN.

On the other hand, I wouldn’t exclude that there are also technical barriers, for example, for implementing access control for personal data assets across federated services.

There are technical solutions to identity federation – but that may not be sufficient.

BTW, Arvind Narayanan et al.’s paper from 2012 may be of interest in this discussion:
http://arxiv.org/abs/1202.4503

Cheers,
Dirk

From: Din [mailto:[email-masked]] On Behalf Of Jon Crowcroft
Sent: Samstag, 23. April 2016 12:52
To: Hejianfei (Jeffrey)
Cc: [email-masked]; Dirk Kutscher
Subject: Re: [Din] 答复: how to build an Internet-wide federation (for “upper layers”)

here's the poster-child example of how we do federation, but how it leads to monopoly systems: it's called WWW.
The surprise to the hypermedia community that Berners-Lee sprung was the idea of unidirectional URLs - essentially, a web site publishes stuff without need for anything other than a server on a pubic, hopefully always-on IP address. Word-of-mouth causes people to hear about the web site, and link to it - no coordination with the server/site owner needed at all. Bingo federation.

So what's that magic "word-of-mouth"? well, originally (circa 1992) it was a) email. b) sites that manually listed other sites (directories, like sunsite). but of course, eventually someone thought of robots, spiders, and behold, Search Engines proliferated. But then given there's only one global public repository of information on the one global public reachable internet, why would you need more than one search engine? So the proliferation collapsed from yahoo and altavista and so on, down to google. A single entry point to a billion websites, which were all federal, but now all found via one place.

Next step in evolution is that it isn't so cheap and easy to get a site that has a global reachable IP address and is (affordably) available 24/7, better than 5 9s. so people start putting there content on hosting sites, in data centers, and lo & behold, the cloud emerges. The asymmetry of bandwidth, reachability and availability of a home broadband link just doesn't really work well, so every home having a web server (or a home cloud) is tricky - (note, for later, with fiber to the home in much of developed parts of Europe at least, and fairly rapidly deploying IPv6, and better firewall technology replacing NATs, we could see a reversal of this over the next few years).

Then writing web pages that serve active content, and deal with all the different quirks of different browsers became more and more expensive in developer time, so people decided to shrink wrap systems, and low and behold "apps" appeared, with limited functionality, but high reliability - server side for the app is also simplified. Asymmetry gets even more pronounced in the Internet.

But then there are contrasts between interworking, and  gratuitously restrictive cloud based systems - lets take webmail versus online-social-nets (OSN).

If you don't interwork webmail with SMTP (and IMAP) you are going to have a walled garden, so its hard to grow your business. If you don't interwork your web based OSN (trust me - download all your data from your favourite OSN - you'll note its just a bunch of web pages), then you try and capture the whole market - why? because once you tip it, like search, everyone "has" to be on "your" system......no wait, that isn't true. Its just a URL. WHy can't I have a "friend" on Sina Weibo from my account on Ello? A friend list is just a list of URLs (or could be). Apps can run across me & my friends (recommenders) the way search runs over multiple sites in the web. Apps just need to be able to parse content (hey its all xml anyhow, game over).

So obviously what we have here is restriction purely because of market control. The technical arguments for centralisation & asymmetry I gave for the app/cloud world, do not apply to some services really. So one could argue that lack of federation where there are no technical barriers for federation is a layer 11 problem (politics/economics) and not really a technical (ietf/irtf) one.....

by two bit-cents:-)

cheers
jon

On Fri, Apr 22, 2016 at 4:26 PM, Hejianfei (Jeffrey) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Dirk,

Motivation issue:

The research topics:

Cheers,
Jeffrey

发件人: Din [mailto:[email-masked]<mailto:[email-masked]>] 代表 Dirk Kutscher
发送时间: 2016年4月22日 20:40
收件人: Hejianfei (Jeffrey); [email-masked]<mailto:[email-masked]>
主题: Re: [Din] how to build an Internet-wide federation (for “upper layers”)

Hi Jeffrey,

Cheers,
Dirk

Hi there,

Cheers,
Jeffrey

_______________________________________________
Din mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/din

---

From: Jon Crowcroft <[email-masked]>
Date: Mon, 25 Apr 2016 10:42:21 +0100

that paper is interesting, but represents a useful list of the
challenges for an extreme point in the design space 
(which is useful to think about, of course, but...)

federating id (as per eduroam) across fairly large numbers of medium
size services, is a largely solved problem, i would claim. 
as are consistency algorithms for same (they operate already within
clould services, so extending them over several shouldn't be an
issue:)

the problem is that there's little incentive to disaggregate an
existing service (unless the European Commission or some other
regulatory body decides to de-monopolize something:-)

> On the other hand, I wouldn’t exclude that there are also technical 
> barriers, for example, for implementing access control for personal data 
> assets across federated services.
> 
> site, and link to it - no coordination with the server/site owner needed 
> at all. Bingo federation.
> 
> So what's that magic "word-of-mouth"? well, originally (circa 1992) it 
> was a) email. b) sites that manually listed other sites (directories, 
> like sunsite). but of course, eventually someone thought of robots, 
> spiders, and behold, Search Engines proliferated. But then given there's 
> only one global public repository of information on the one global public 
> reachable internet, why would you need more than one search engine? So 
> the proliferation collapsed from yahoo and altavista and so on, down to 
> google. A single entry point to a billion websites, which were all 
> federal, but now all found via one place.
> 
> that has a global reachable IP address and is (affordably) available 
> 24/7, better than 5 9s. so people start putting there content on hosting 
> sites, in data centers, and lo & behold, the cloud emerges. The asymmetry 
> of bandwidth, reachability and availability of a home broadband link just 
> developed parts of Europe at least, and fairly rapidly deploying IPv6, 
> and better firewall technology replacing NATs, we could see a reversal of 
> this over the next few years).
> 
> behold "apps" appeared, with limited functionality, but high reliability 
> - server side for the app is also simplified. Asymmetry gets even more 
> If you don't interwork webmail with SMTP (and IMAP) you are going to have 
> a walled garden, so its hard to grow your business. If you don't 
> interwork your web based OSN (trust me - download all your data from your 
> favourite OSN - you'll note its just a bunch of web pages), then you try 
> and capture the whole market - why? because once you tip it, like search, 
> everyone "has" to be on "your" system......no wait, that isn't true. Its 
> just a URL. WHy can't I have a "friend" on Sina Weibo from my account on 
> Ello? A friend list is just a list of URLs (or could be). Apps can run 
> across me & my friends (recommenders) the way search runs over multiple 
> sites in the web. Apps just need to be able to parse content (hey its all 
> xml anyhow, game over).
> 
> control. The technical arguments for centralisation & asymmetry I gave 
> for the app/cloud world, do not apply to some services really. So one 
> could argue that lack of federation where there are no technical barriers 
> for federation is a layer 11 problem (politics/economics) and not really 
> a technical (ietf/irtf) one.....
> 
> by two bit-cents:-)
> 
> cheers
> jon
> 
> On Fri, Apr 22, 2016 at 4:26 PM, Hejianfei (Jeffrey) 
> <[email-masked]<mailto:[email-masked]>> wrote:
> Hi Dirk,
> 
> Motivation issue:
> The idea to the separation of “how to share and access the data” from 
> “how to understand and process the data” reflects a layering 
> methodology like current Internet, but it is still an open issue to me 
> which functions belong to the first (semantics-less) part in the lower 
> layer, while others(semantics-rich) in the upper layers. I only have some 
> initial feelings that the lower layer may be like an Internet-wide file 
> system or database system. That’s why I am interested in IPFS. But 
> things working well in one domain maybe does not in a federation.
> I think if we expose this topic to the research community, more people 
> may join the discussion. If we take IoT as potential use cases, there are 
> many experts in IETF/IRTF. If we take the “research data sharing” as 
> a starting use case, many researchers are themselves users or operators.
> 
> Cheers,
> Jeffrey
> 
> Currently there seems to be a trend in the exact opposite direction, 
> i.e., connectivity providers trying to provide extend their footprint on 
> the vertical value chain (e.g., ASPs moving into ISP territory, rolling 
> out their own access or mobile/fixed carriers trying to become content 
> providers).
> 
> separation of “how to share and access the data” from “how to 
> understand and process the data” that you mentioned. For example, I 
> could see Internet federation emerging as a higher layer on top of an ICN 
> network layer.
> 
> great to get more views from people with different backgrounds 
> (especially people who develop/operate services).
> 
> During IETF-95, I gave a talk “Internet-wide Federation” in the 
> meeting “Distributed Internet Architectures” organized by Dirk. In 
> fact, the main challenge I want to address is best stated in the latest 
> European Horizon 2020 call: ” Current centralised platforms for big and 
> social data management consolidate the dominance of existing incumbent 
> actors, stifling innovation and allowing less and less control over the 
> data by citizens. Distributed architectures and decentralised platforms 
> have a huge potential to enable the creation of viable alternatives to 
> current dominant models.” (ICT-12b, Horizon2020 Work Programme2016-2017)
> avoid the fragmentation: the peering interfaces among domains have to 
> keep stable so that this federation could grow to be Internet-wide. If 
> these interfaces have to change with the introduction of new services, 
> this Internet-wide federation will break into fragments and gradually 
> fail when facing competition from the “centralized service system” 
> since the centralized platforms could can deploy new services overnight.
> sharing is the mainstream usage of Internet, we may identify some 
> functions common and stable to all services and implement them in the 
> federation, while leave other dynamic functions at the edge of the 
> infrastructure. It is still an open question how to separate the 
> functions, but one possible approach is to separate “how to share and 
> access the data” from “how to understand and process the data”. The 
> federation itself implements only the first part of functions, such as : 
> IDs for smart object/user/content, user relationships, federated 
> authentication and authorization for access control, publishing and 
> subscribing in an online-social-network style, etc.
> 
> -    Understanding the relationship between the federation of data 
> sharing and the applications presenting or processing the data

---

From: "Hejianfei (Jeffrey)" <[email-masked]>
Date: Mon, 25 Apr 2016 10:39:45 +0000

I agree that "there's little incentive to disaggregate an existing service", so I suggest to address new areas, for instance IoT or scientific data sharing etc, rather than competing directly with dominant services. 

As for the start-of-the-art, web seems a good solution for public contents, but need some enhancements for the access control? It is true there are many existing ID management solutions, like OpenID for independent ID providers, Eduroam as a successful practice for federation ID authentication. But is the Fed ID authentication in Eduroam, which is designed for wifi access, enough for the access control for content? I am not sure. Maybe we need some schemes like authorization, privilege, or even some schemes reflecting "user relationship" like "group". If we identify some use cases, we can testify if current technologies and protocols are sufficient or not. 
  
In a bigger picture, I think we are discussing a decentralized architecture for data sharing. There are some ongoing activities that I am personally interested. For example, IPFS: its version control (borrowed from Git). "Linked Data" is also relevant. It addresses directly the semantics part of the data. Even we leave the "ontology" part, the concept of "relationship between data" could be also helpful in the scientific data sharing. 

Jeffrey  

-----邮件原件-----
发件人: Din [mailto:[email-masked]] 代表 Jon Crowcroft
发送时间: 2016年4月25日 17:42
收件人: Dirk Kutscher
抄送: [email-masked]
主题: Re: [Din] 答复: how to build an Internet-wide federation (for “upper layers”)

that paper is interesting, but represents a useful list of the challenges for an extreme point in the design space (which is useful to think about, of course, but...)

federating id (as per eduroam) across fairly large numbers of medium size services, is a largely solved problem, i would claim. 
as are consistency algorithms for same (they operate already within clould services, so extending them over several shouldn't be an
issue:)

the problem is that there's little incentive to disaggregate an existing service (unless the European Commission or some other regulatory body decides to de-monopolize something:-)

> On the other hand, I wouldnâ€™t exclude that there are also technical 
> barriers, for example, for implementing access control for personal 
> data assets across federated services.
> 
> There are technical solutions to identity federation â€“ but that may 
> not be sufficient.
> 
> BTW, Arvind Narayanan et al.â€™s paper from 2012 may be of interest in 
> this discussion:
> Subject: Re: [Din] ç­”å¤: how to build an Internet-wide federation 
> (for â€œupper layersâ€)
> 
> here's the poster-child example of how we do federation, but how it 
> leads to monopoly systems: it's called WWW.
> The surprise to the hypermedia community that Berners-Lee sprung was 
> the idea of unidirectional URLs - essentially, a web site publishes 
> stuff without need for anything other than a server on a pubic, 
> hopefully always-on IP address. Word-of-mouth causes people to hear 
> about the web site, and link to it - no coordination with the 
> server/site owner needed at all. Bingo federation.
> 
> spiders, and behold, Search Engines proliferated. But then given 
> there's only one global public repository of information on the one 
> global public reachable internet, why would you need more than one 
> search engine? So the proliferation collapsed from yahoo and altavista 
> and so on, down to google. A single entry point to a billion websites, 
> which were all federal, but now all found via one place.
> 
> Next step in evolution is that it isn't so cheap and easy to get a 
> site that has a global reachable IP address and is (affordably) 
> available 24/7, better than 5 9s. so people start putting there 
> content on hosting sites, in data centers, and lo & behold, the cloud 
> emerges. The asymmetry of bandwidth, reachability and availability of 
> a home broadband link just doesn't really work well, so every home 
> having a web server (or a home
> and better firewall technology replacing NATs, we could see a reversal 
> of this over the next few years).
> 
> Then writing web pages that serve active content, and deal with all 
> the different quirks of different browsers became more and more 
> expensive in developer time, so people decided to shrink wrap systems, 
> and low and behold "apps" appeared, with limited functionality, but 
> high reliability
> If you don't interwork webmail with SMTP (and IMAP) you are going to 
> have a walled garden, so its hard to grow your business. If you don't 
> interwork your web based OSN (trust me - download all your data from 
> your favourite OSN - you'll note its just a bunch of web pages), then 
> you try and capture the whole market - why? because once you tip it, 
> like search, everyone "has" to be on "your" system......no wait, that 
> isn't true. Its just a URL. WHy can't I have a "friend" on Sina Weibo 
> from my account on Ello? A friend list is just a list of URLs (or 
> could be). Apps can run across me & my friends (recommenders) the way 
> search runs over multiple sites in the web. Apps just need to be able 
> to parse content (hey its all xml anyhow, game over).
> 
> could argue that lack of federation where there are no technical 
> barriers for federation is a layer 11 problem (politics/economics) and 
> not really a technical (ietf/irtf) one.....
> 
> by two bit-cents:-)
> 
> cheers
> jon
> 
> I think we can start a new federation from a new area(e.g IoT) or a 
> niche market(e.g research data sharing among universities). In these 
> areas, the federation is a nature choice due to decentralized 
> administration. Once there are enough active users in this federation, 
> the federation may be attractive for other applications to join.
> 
> The research topics:
> The idea to the separation of â€œhow to share and access the dataâ€ 
> from â€œhow to understand and process the dataâ€ reflects a layering 
> layer, while others(semantics-rich) in the upper layers. I only have 
> some initial feelings that the lower layer may be like an 
> Internet-wide file system or database system. Thatâ€™s why I am 
> interested in IPFS. But things working well in one domain maybe does not in a federation.
> may join the discussion. If we take IoT as potential use cases, there 
> are many experts in IETF/IRTF. If we take the â€œresearch data 
> sharingâ€ as a starting use case, many researchers are themselves users or operators.
> 
> Cheers,
> Jeffrey
> 
> å‘ä»¶äºº: Din 
> [mailto:[email-masked]<mailto:[email-masked]>]
> ä»£è¡¨ Dirk Kutscher
> å‘é€æ—¶é—´: 2016å¹´4æœˆ22æ—¥ 20:40
> æ”¶ä»¶äºº: Hejianfei (Jeffrey); [email-masked]<mailto:[email-masked]>
> ä¸»é¢˜: Re: [Din] how to build an Internet-wide federation (for 
> â€œupper
> layersâ€)
> 
> Hi Jeffrey,
> 
> (All, Jeffreyâ€™s presentation from BA is available at
> i.e., connectivity providers trying to provide extend their footprint 
> on the vertical value chain (e.g., ASPs moving into ISP territory, 
> rolling out their own access or mobile/fixed carriers trying to become 
> content providers).
> 
> Would you say that this is happening because of a lack of 
> Internet-wide federation? Have you thought about what would motivate 
> dominating players today to engage in federation?
> 
> From a research perspective, Iâ€™d be interested in figuring out the 
> separation of â€œhow to share and access the dataâ€ from â€œhow to 
> understand and process the dataâ€ that you mentioned. For example, I 
> could see Internet federation emerging as a higher layer on top of an 
> ICN network layer.
> 
> Regarding how to organize/facilitate follow-up discussions, it would 
> be great to get more views from people with different backgrounds 
> Subject: [Din] how to build an Internet-wide federation (for â€œupper
> layersâ€)
> 
> Hi there,
> 
> During IETF-95, I gave a talk â€œInternet-wide Federationâ€ in the 
> meeting â€œDistributed Internet Architecturesâ€ organized by Dirk. In 
> fact, the main challenge I want to address is best stated in the 
> latest European Horizon 2020 call: â€ Current centralised platforms 
> for big and social data management consolidate the dominance of 
> existing incumbent actors, stifling innovation and allowing less and 
> less control over the data by citizens. Distributed architectures and 
> decentralised platforms have a huge potential to enable the creation 
> of viable alternatives to current dominant models.â€ (ICT-12b, 
> Horizon2020 Work Programme2016-2017) P2P and federation are two modes 
> of decentralized platform. In my view, â€œfederationâ€ is more 
> promising. Note: Federation= â€œa union of autonomous/peer domainsâ€, 
> â€œclient aâ€”server Aâ€”server Bâ€”client bâ€.
> domains, the main challenge is that the federation needs to be stable 
> and avoid the fragmentation: the peering interfaces among domains have 
> to keep stable so that this federation could grow to be Internet-wide. 
> If these interfaces have to change with the introduction of new 
> services, this Internet-wide federation will break into fragments and 
> gradually fail when facing competition from the â€œcentralized service 
> systemâ€ since the centralized platforms could can deploy new services overnight.
> functions, but one possible approach is to separate â€œhow to share 
> and access the dataâ€ from â€œhow to understand and process the 
> dataâ€. The federation itself implements only the first part of functions, such as :
> Based on these initial thoughts, I think probably it would be 
> interesting to the research community in IRTF, to investigate the 
> challenges in building Internet-wide federation for data sharing for 
> various scenarios, and to explore design principles at the 
> architectural level that can be used as guidelines for standardization in other communities like IETF.

---

From: Nick Roy <[email-masked]>
Date: Mon, 25 Apr 2016 15:03:02 +0000

The R&E SAML federations ostensibly support authZ via attribute release, but getting actual cross-jurisdiction attribute release to happen scalably has proved to be one of those "layer 11" problems.

UMA is interesting in the OpenID Connect space as a possible Internet-scale user-centric identity/access control mechanism.  It also might offer a handle to support the kinds of data set policy-based sharing needed for decentralized scientific data set sharing.

Nick

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Mon, 25 Apr 2016 15:15:55 +0000

Hi,

Just to share a couple of notes, the ABFAB WG was precisely focused on identifying an AAA infrastructure able to leverage a general application framework on the eduroam approach. Its applicability in this problem space could be a path to explore.

I think one of the key aspect here is how we establish a minimum-privilege principle for the exchange of all kind of attributes, either related to the actor identities or to the subject (the data entities) to be shared or accessed.

Be goode,

On 25 Apr 2016, at 12:39 , Hejianfei (Jeffrey) <[email-masked]<mailto:[email-masked]>> wrote:

Jeffrey

-----邮件原件-----
发件人: Din [mailto:[email-masked]] 代表 Jon Crowcroft
发送时间: 2016年4月25日 17:42
收件人: Dirk Kutscher
抄送: [email-masked]<mailto:[email-masked]>
主题: Re: [Din] 答复: how to build an Internet-wide federation (for “upper layers”)

Oh yes, there are definitely some layer 11 barriers for federation of,
for example, OSN.

Cheers,
Dirk

by two bit-cents:-)

cheers
jon

Motivation issue:

The research topics:
As for the relationship with ICN, I think I need more discussion with
ICN experts, like you.

Cheers,
Jeffrey

å‘ä»¶äºº: Din

Hi Jeffrey,

(All, Jeffreyâ€™s presentation from BA is available at
https://trac.tools.ietf.org/group/irtf/trac/wiki/blockchain-federation
)

Cheers,
Dirk

From: Din [mailto:[email-masked]] On Behalf Of Hejianfei
(Jeffrey)
Sent: Donnerstag, 21. April 2016 14:54
To: [email-masked]<mailto:[email-masked]>
Subject: [Din] how to build an Internet-wide federation (for â€œupper
layersâ€)

Hi there,

Based on these initial thoughts, I think probably it would be
interesting to the research community in IRTF, to investigate the
challenges in building Internet-wide federation for data sharing for
various scenarios, and to explore design principles at the
architectural level that can be used as guidelines for standardization in other communities like IETF.
If we could have a research group in IRTF, we could investigate
several related areas, for examples:
-    Understanding the requirements and challenges for potential new
Internet-wide federations, including IoT, repository/data sharing,
cloud2cloud etc.
-    Architectural principles that may provide the scalability and
stability required for an Internet-wide federation
-    Systematic description of data and metadata, user and user group,
devices generating data (like sensors), actuators..
-    Understanding the relationship between the federation of data
sharing and the applications presenting or processing the data
-    Security and privacy for data sharing, especially cross domains, in
a federation
-    Efficiency of data retrieval and data processing in a distributed
architecture

Cheers,
Jeffrey

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição