Subject: [Din] Side meeting on Distributed Internet Infrastructure at IETF-99

From: "Dirk Kutscher" <[email-masked]>
Date: Wed, 21 Jun 2017 20:53:36 +0200

Hi all,

we are holding another side meeting on Distributed Internet 
Infrastructure at IETF-99. We had some good discussions with interested 
folks in and outside the IRTF in the past months and thought that it 
might be a good time now to try to start a more structured activity in 
the IRTF.

The scope would be “Distributed Internet Infrastructure”, I.e., 
applying distributed ledger technologies (such as blockchain, but not 
limited to it) to Internet technologies, for example to decentralized 
name registries, identity management, decentralized web etc.

We have some people looking at the topic from different angles, i.e., 
IoT, decentralized web, Internet architecture and think that there is an 
interesting and potentially very productive scope we could work in the 
IRTF.

The meeting to discuss this will be a side meeting on Monday, July 17, 
18:50 to 20:50 (room to be announced).

The agenda (as of current planning):

1) Background and Purpose
2) Selected Use Cases and Related Efforts
    - Decentralized OAuth
    - IoT
    - COALA.global
3) Ledger Technology
4) Next steps, RG Formation

We’ll post agenda details, updated etc. on 
https://trac.ietf.org/trac/irtf/wiki/blockchain-federation

Let us know in case you have any question or are interested to get 
involved!

Best regards,
Dirk (on behalf of co-organizers)

---

From: "Diego R. Lopez" <[email-masked]>
Date: Wed, 21 Jun 2017 22:45:25 +0000

Hi Dirk,

As you know, I am interested in the issue, and the NFV security group in ETSI is looking at applying distributed ledgers for provenance (including function and infrastructure attestation) and traceability matters.  This could constitute an additional use case…

Be goode,

On 21 Jun 2017, at 20:53 , Dirk Kutscher <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

we are holding another side meeting on Distributed Internet Infrastructure at IETF-99. We had some good discussions with interested folks in and outside the IRTF in the past months and thought that it might be a good time now to try to start a more structured activity in the IRTF.

The scope would be “Distributed Internet Infrastructure”, I.e., applying distributed ledger technologies (such as blockchain, but not limited to it) to Internet technologies, for example to decentralized name registries, identity management, decentralized web etc.

We have some people looking at the topic from different angles, i.e., IoT, decentralized web, Internet architecture and think that there is an interesting and potentially very productive scope we could work in the IRTF.

The meeting to discuss this will be a side meeting on Monday, July 17, 18:50 to 20:50 (room to be announced).

We’ll post agenda details, updated etc. on https://trac.ietf.org/trac/irtf/wiki/blockchain-federation

Let us know in case you have any question or are interested to get involved!

Best regards,

_______________________________________________
Din mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/din

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Dirk Kutscher" <[email-masked]>
Date: Thu, 22 Jun 2017 23:23:50 +0200

Hi Diego,

> As you know, I am interested in the issue, and the NFV security group 
> in ETSI is looking at applying distributed ledgers for provenance 
> (including function and infrastructure attestation) and traceability 
> matters.  This could constitute an additional use case…

Thanks for pointing this out! Is there any material available yet?

Could this be something to include in the use case part of our meeting?

Cheers,
Dirk

> Be goode,
>
> On 21 Jun 2017, at 20:53 , Dirk Kutscher 
> <[email-masked]<mailto:[email-masked]>> wrote:
>
> Hi all,
>
> Infrastructure at IETF-99. We had some good discussions with 
> interested folks in and outside the IRTF in the past months and 
> thought that it might be a good time now to try to start a more 
> structured activity in the IRTF.
>
> IoT, decentralized web, Internet architecture and think that there is 
> an interesting and potentially very productive scope we could work in 
> the IRTF.
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su 
> destinatario, puede contener información privilegiada o confidencial 
> y es para uso exclusivo de la persona o entidad de destino. Si no es 
> usted. el destinatario indicado, queda notificado de que la lectura, 
> utilización, divulgación y/o copia sin autorización puede estar 
> prohibida en virtud de la legislación vigente. Si ha recibido este 
> mensaje por error, le rogamos que nos lo comunique inmediatamente por 
> esta misma vía y proceda a su destrucción.
>
> The information contained in this transmission is privileged and 
> confidential information intended only for the use of the individual 
> or entity named above. If the reader of this message is not the 
> intended recipient, you are hereby notified that any dissemination, 
> distribution or copying of this communication is strictly prohibited. 
> If you have received this transmission in error, do not read it. 
> Please immediately reply to the sender that you have received this 
> communication in error and then delete it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu 
> destinatário, pode conter informação privilegiada ou confidencial e 
> é para uso exclusivo da pessoa ou entidade de destino. Se não é 
> vossa senhoria o destinatário indicado, fica notificado de que a 
> leitura, utilização, divulgação e/ou cópia sem autorização pode 
> estar proibida em virtude da legislação vigente. Se recebeu esta 
> mensagem por erro, rogamos-lhe que nos o comunique imediatamente por 
> esta mesma via e proceda a sua destruição

> [email-masked]

---

From: "Diego R. Lopez" <[email-masked]>
Date: Fri, 23 Jun 2017 06:51:41 +0000

Hi Dirk,

There is no more than some initial discussions and sketches, I’m afraid.

And I’d love to see it among the use cases, though I must say I don’t feel confident to bring a reasonably detailed presentation if that is what being among the use cases implies…

Be goode,

On 22 Jun 2017, at 23:23 , Dirk Kutscher <[email-masked]<mailto:[email-masked]>> wrote:

Hi Diego,

Cheers,
Dirk

Be goode,

On 21 Jun 2017, at 20:53 , Dirk Kutscher <[email-masked]<mailto:[email-masked]><mailto:[email-masked]>> wrote:

Hi all,

Best regards,

_______________________________________________
Din mailing list
[email-masked]<mailto:[email-masked]><mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/din

Dr Diego R. Lopez
Telefonica I+D

Dr Diego R. Lopez
Telefonica I+D

---

From: "Dirk Kutscher" <[email-masked]>
Date: Mon, 26 Jun 2017 23:25:46 +0200

Update: the meeting location is the Tyrolka room in the Hilton (meeting 
hotel).

Best regards,
Dirk