Subject: Re: [Din] Requesting comments on draft DIN charter

From: "Dirk Kutscher" <[email-masked]>
Date: Tue, 19 Sep 2017 11:01:11 +0200

Hi everyone,

Thanks for the feedback and suggestions for improving the proposed 
charter text. We have received input from Lixia Zhang, Eve Schooler, 
Thomas Hardjono, Spencer Dawkins, and Allison Mankin and updated the 
text accordingly:

https://trac.ietf.org/trac/irtf/wiki/blockchain-federation

Quick summary of the changes:

- highlighted Internet-level deployment criteria (scalability, security, 
performance)
- mentioned Distributed Trust and Delegated Computing as one the 
research challenges
- clarified the implementation & deployment objectives in the research 
challenges

Please have a look and let us know if there are other suggestions etc.

Also, we talked to Allison and are now aiming to run a meeting as a 
Proposed RG as part of the official agenda at IETF-100 in Singapore.

We are now starting to prepare that meeting. The current plan is to look 
into selected use cases and experimentation results, but also to discuss 
RG goals, next steps etc.

You are very welcome to reach out to us if you would like to propose 
something.

Best regards,
Melinda & Dirk

On 28 Aug 2017, at 12:35, Dirk Kutscher wrote:

> Hi everyone,
>
> Melinda and I drafted a charter for a proposed Research Group on 
> Decentralized Internet Infrastructure:
>
> https://trac.ietf.org/trac/irtf/wiki/blockchain-federation
>
> This is based on our discussions in Prague and additional input we 
> received in the meantime.
>
> We would be grateful for any feedback.
>
> Specific questions of interests:
>
> - Is this useful?
> - Anything missing?
> - Other suggestions?
> - Do you want to contribute?
>
> Please group-reply or unicast to Melinda and me as you see fit.
>
> Thanks,
> Dirk & Melinda
>
>
>
>
> _______________________________________________
> Din mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/din

---

From: "Diego R. Lopez" <[email-masked]>
Date: Tue, 19 Sep 2017 12:46:44 +0000

Hi Dirk,

Looking at the text I wonder whether we should include an explicit mention to privacy among the research challenges, given that many of these distributed infrastructures might facilitate unwanted access to personal data used to describe or secure the information managed by them.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

On 19/9/2017, 11:01 , "Din on behalf of Dirk Kutscher" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi everyone,

Thanks for the feedback and suggestions for improving the proposed charter text. We have received input from Lixia Zhang, Eve Schooler, Thomas Hardjono, Spencer Dawkins, and Allison Mankin and updated the text accordingly:

Quick summary of the changes:
·         highlighted Internet-level deployment criteria (scalability, security, performance)
·         mentioned Distributed Trust and Delegated Computing as one the research challenges
·         clarified the implementation & deployment objectives in the research challenges

Also, we talked to Allison and are now aiming to run a meeting as a Proposed RG as part of the official agenda at IETF-100 in Singapore.

We are now starting to prepare that meeting. The current plan is to look into selected use cases and experimentation results, but also to discuss RG goals, next steps etc.

You are very welcome to reach out to us if you would like to propose something.

Best regards,
Melinda & Dirk

Hi everyone,

Melinda and I drafted a charter for a proposed Research Group on Decentralized Internet Infrastructure:

This is based on our discussions in Prague and additional input we received in the meantime.

Specific questions of interests:
·      Is this useful?
·      Anything missing?
·      Other suggestions?
·      Do you want to contribute?

Thanks,
Dirk & Melinda

________________________________

Din mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/din

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Dirk Kutscher" <[email-masked]>
Date: Wed, 20 Sep 2017 11:45:45 +0200

Hi Diego,

Thanks for that. My personal view is that there could indeed be a 
dichotomy of publically recorded transactions etc. and privacy concerns, 
so I am leaning towards including that. BTW, do you have a specific use 
case in mind? What do others say?

Cheers,
Dirk

On 19 Sep 2017, at 14:46, Diego R. Lopez wrote:

> Hi Dirk,
>
> Looking at the text I wonder whether we should include an explicit 
> mention to privacy among the research challenges, given that many of 
> these distributed infrastructures might facilitate unwanted access to 
> personal data used to describe or secure the information managed by 
> them.
>
> Be goode,
>
> --
> e-mail: 
> [email-masked]<mailto:[email-masked]>
> Tel:    +34 913 129 041
> Mobile: +34 682 051 091
> On 19/9/2017, 11:01 , "Din on behalf of Dirk Kutscher" 
> <[email-masked]<mailto:[email-masked]> on behalf of 
> [email-masked]<mailto:[email-masked]>> wrote:
>
>
> Hi everyone,
>
> We are now starting to prepare that meeting. The current plan is to 
> look into selected use cases and experimentation results, but also to 
> discuss RG goals, next steps etc.
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su 
> destinatario, puede contener información privilegiada o confidencial 
> y es para uso exclusivo de la persona o entidad de destino. Si no es 
> usted. el destinatario indicado, queda notificado de que la lectura, 
> utilización, divulgación y/o copia sin autorización puede estar 
> prohibida en virtud de la legislación vigente. Si ha recibido este 
> mensaje por error, le rogamos que nos lo comunique inmediatamente por 
> esta misma vía y proceda a su destrucción.
>
> The information contained in this transmission is privileged and 
> confidential information intended only for the use of the individual 
> or entity named above. If the reader of this message is not the 
> intended recipient, you are hereby notified that any dissemination, 
> distribution or copying of this communication is strictly prohibited. 
> If you have received this transmission in error, do not read it. 
> Please immediately reply to the sender that you have received this 
> communication in error and then delete it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu 
> destinatário, pode conter informação privilegiada ou confidencial e 
> é para uso exclusivo da pessoa ou entidade de destino. Se não é 
> vossa senhoria o destinatário indicado, fica notificado de que a 
> leitura, utilização, divulgação e/ou cópia sem autorização pode 
> estar proibida em virtude da legislação vigente. Se recebeu esta 
> mensagem por erro, rogamos-lhe que nos o comunique imediatamente por 
> esta mesma via e proceda a sua destruição

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 20 Sep 2017 12:14:54 +0200

Privacy (and targeted verifiable disclosure) are certainly on topic here (e.g., TumbleBit).

The discussion talks about networks constraints, but not about node constraints; I think it is important to enable constrained nodes to benefit from elements of a consensus item that they cannot process or store as a complete set.

Grüße, Carsten

> On Sep 20, 2017, at 11:45, Dirk Kutscher <[email-masked]> wrote:
> 
> Hi Diego,
> 
> Thanks for that. My personal view is that there could indeed be a dichotomy of publically recorded transactions etc. and privacy concerns, so I am leaning towards including that. BTW, do you have a specific use case in mind? What do others say?
> 
> Cheers,
> Dirk
> 
> e-mail: [email-masked]
> Tel:    +34 913 129 041
> Mobile: +34 682 051 091
> On 19/9/2017, 11:01 , "Din on behalf of Dirk Kutscher" <[email-masked] on behalf of [email-masked]> wrote:
>  
> Hi everyone,
>

---

From: "Diego R. Lopez" <[email-masked]>
Date: Wed, 20 Sep 2017 10:22:22 +0000

Hi,

Dirk asked about use cases, and I think this issue of the constrained nodes is an essential one. And there is the obvious case of the application of these infrastructures to derive identity-related exchanges (at whatever the A you feel like: authentication, authorization, accounting, auditing...) and how they would be used to build reputation, for humans of for any other entity in the network.

Be goode,

Dr Diego R. Lopez
Telefonica I+D

On 20/9/2017, 12:15 , "Din on behalf of Carsten Bormann" <[email-masked] on behalf of [email-masked]> wrote:

    Grüße, Carsten

---

From: "Dirk Kutscher" <[email-masked]>
Date: Thu, 21 Sep 2017 14:41:36 +0200

On 20 Sep 2017, at 12:14, Carsten Bormann wrote:

> The discussion talks about networks constraints, but not about node 
> constraints; I think it is important to enable constrained nodes to 
> benefit from elements of a consensus item that they cannot process or 
> store as a complete set.

Yes, good points (both)!

Cheers,
Dirk

>> dichotomy of publically recorded transactions etc. and privacy 
>> concerns, so I am leaning towards including that. BTW, do you have a 
>> specific use case in mind? What do others say?
>>
>> Cheers,
>> Dirk
>>
>> <[email-masked] on behalf of [email-masked]> wrote:
>>
>> Hi everyone,
>>
>> destinatário, pode conter informação privilegiada ou confidencial 
>> e é para uso exclusivo da pessoa ou entidade de destino. Se não é 
>> leitura, utilização, divulgação e/ou cópia sem autorização 
>> pode estar proibida em virtude da legislação vigente. Se recebeu 
>> esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente 
>> por esta mesma via e proceda a sua destruição