Subject: Re: [Din] [T2TRG] [T2TRG/Din] Discussion New draft for draft-hong-iot-edge-computing-00.txt

From: William_J_G Overington <[email-masked]>
Date: Tue, 10 Jul 2018 11:20:16 +0100 (BST)

Hi

I am new to this group and this is my first post.

I have replied by using a reply all from the original post. I am not sure that this will go to [email-masked] as I am not registered for that. 

I write to put forward two suggestions. I do not know if they will be useful to this discussion and if I sit and try to work that out it may take a very long time and even then I might not get to an answer.

So I put my two suggestions here in the hope that they will be considered please by experts so that whether the suggestions are useful or otherwise can be determined by experts.

The first suggestion is an invention of mine that I call localizable sentences. It was devised for person to person communication through the language barrier in some specific circumstances.

The system will not do everything that a human translator could do by a long way, but could be useful in some circumstances, such as, for example, seeking information about relatives and friends after a disaster, or asking a patient in a hospital if he or she would like a drink of water.

I am wondering if some localizable sentences could be useful for human to thing, thing to thing, and thing to human communication.

For example, suppose that there were the two following localizable sentences.

What is the temperature at your location please?

The temperature at my location in degrees Celsius is as follows.

Each localizable sentence is encoded as a sequence of text characters, so messages can be sent and received as plain text.

In my research the encoding is as an integral sign character followed by some circled digit characters.

The coding is explained in the following document.

http://www.users.globalnet.co.uk/~ngo/An_encoding_space_designed_for_application_in_encoding_localizable_sentences.pdf

The following document may also be of interest.

http://www.users.globalnet.co.uk/~ngo/a_completed_publication_about_localizable_sentences_research.pdf

The second suggestion is as to whether there should be defined a portable interpretable object code expressible using a sequences of text character for each command of the portable interpretable object code. The portable interpretable object code would be run on a virtual machine. Thus a thing could receive some portable interpretable object code in an ordinary text message and then run it locally on a virtual machine.

This would mean that the portable interpretable object code could be run on things that have been made by a variety of manufacturers.

William Overington

Tuesday 10 July 2018

---

From: Jungha Hong <[email-masked]>
Date: Thu, 12 Jul 2018 01:17:35 +0000

Dear William Overington,

Thanks for your email.

I wonder how your two suggestions are related to our draft.

Could you please clarify your suggestions more related to the draft?

 Thanks,

Jungha Hong

________________________________
보낸 사람 : "William_J_G Overington" <[email-masked]>
보낸 날짜 : 2018-07-10 19:20:28 ( +09:00 )
받는 사람 : 홍정하 <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
참조 : [email-masked] <[email-masked]>, 홍용근 <[email-masked]>, [email-masked] <[email-masked]>
제목 : Re: [T2TRG] [T2TRG/Din] Discussion New draft for draft-hong-iot-edge-computing-00.txt

Hi

William Overington

Tuesday 10 July 2018