Subject: [dispatch] HITs in SIP/SDP

From: Peter Musgrave <[email-masked]>
Date: Tue, 4 May 2010 08:02:44 -0400

Hi Gao/Dispatch,

I though I would separate Gao's question about HIP in SIP into a
thread specific to the protocol issues.

Has this topic been raised before?

Do people see benefits in using HITs (built in NAT traversal, handling
of multi-homed and mobility issues etc.)?

Is the use of HITs in SIP/SDP protocols largely a matter of adding
conventions for URLs and SDP c= lines etc. or is it "deep"?

I suspect that the later is true (especially in mixed HIP/non-HIP
calls since they would e.g. still need ICE and perhaps the HITs become
candidates in an SDP offer)? The multi-homed and address mobility
issue may also cause deeper issues.

Peter Musgrave

---

From: [email-masked]
Date: Tue, 4 May 2010 20:19:42 +0800

Hi Peter Musgrave,

I once see section 15.2.4 of the book of 
"Host.Identity.Protocol.HIP.Towards.the.Secure.Mobile.Internet" has such 
discussion.

Thanks,

Gao

===================================
 Zip    : 210012
 Tel    : 87211
 Tel2   :(+86)-025-52877211
 e_mail : [email-masked]
===================================

Peter Musgrave <[email-masked]> 
2010-05-04 20:02

收件人
"gao.yang2" <[email-masked]>, dispatch mailing list 
<[email-masked]>
抄送

主题
HITs in SIP/SDP

Hi Gao/Dispatch,

Peter Musgrave

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 04 May 2010 09:00:46 -0700

Some time ago we worked on a draft about the interaction between HIP and 
SIP:
http://tools.ietf.org/html/draft-tschofenig-hiprg-host-identities-06

But the problem statement there was very different. It essentially 
simplified HIP deployment with the help of SIP.

I believe that Gao has a different goal. I have not fully understood why 
he believes that HIP is the solution since I don't understand the problem.

Ciao
Hannes

Peter Musgrave wrote:
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: Peter Musgrave <[email-masked]>
Date: Sun, 9 May 2010 07:44:54 -0400

Hi Hannes,

Thanks for the reference. So if I understand correctly this speaks to
using HIP for media encryption but not for identification. i.e. The
SDPs still have IN4 in the c= line.

I was wondering if HITs had been discussed in the context of host
location. i.e. could a HIP connection be established prior to sending
an initial INVITE by making reference to the HIT in the request URI? I
also have the same question about using in SDPs either in the c= line
or as an address candidate of some form.

This appears to me to have the advantage of letting the HIP socket
code become the place where ICE lives and then the media sub-system
can just use it.

Thanks,

Peter Musgrave

On Tue, May 4, 2010 at 12:00 PM, Hannes Tschofenig
<[email-masked]> wrote:
> I believe that Gao has a different goal. I have not fully understood why he
> believes that HIP is the solution since I don't understand the problem.
>
> Ciao
> Hannes
>
>
> Peter Musgrave wrote:
>>
>> Hi Gao/Dispatch,
>>

---

From: [email-masked]
Date: Mon, 10 May 2010 10:22:04 +0800

Hi Peter Musgrave,

Peter Musgrave <[email-masked]> 写于 2010-05-09 19:44:54:

> an initial INVITE by making reference to the HIT in the request URI? 

Yes. Supposing A and B has a HIP connection for one use. Then A and B want 
to reuse the HIP conncetion and have a call/session by SIP. This is 
typical use case of having HIP connection before INVITE.

But I'd like to point out that, if we want to use "HIP based SIP", some 
aspect of SIP should be cutted down, such as some part of it's routing 
mechanism.

> I also have the same question about using in SDPs either in the c= line

I think it would be both, while with different function.

> code become the place where ICE lives and then the media sub-system

I don't understand this issue well. Could you say more about it. Thanks.

Regards,

Gao