Subject: [dispatch] Charter proposal for drafts related to the tel URI

From: "Patel, Milan" <[email-masked]>
Date: Fri, 28 May 2010 09:13:05 -0400

Hello,

Attached is a charter proposal for a WG to be formed for work pertaining
to extensions to the tel URI - specifically, parameters for carrying the
DAI, CPC, OLI and RN required for primarily interworking scenarios to
ISUP/PSTN. 

Feedback is appreciated. 

Regards,

Milan

________________________________

From: Patel, Milan 
Sent: Tuesday, May 25, 2010 11:16 AM
To: Cullen Jennings; [email-masked]'; Robert Sparks;
'Gonzalo Camarillo'
Cc: [email-masked]; 'Sumanth Channabasappa'
Subject: Charter proposal

Hi all,

Attached is a charter proposal for a WG to be formed to handle Internet
Drafts pertaining to the Tel URI. Specifically these are the DAI draft
and the CPC/OLI draft and some further work on the RN parameter. 

Feedback is welcome. 

Kind regards,

Milan

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 28 May 2010 09:57:27 -0400

A comment on this proposal:

It presumes that this information should be conveyed by encoding it 
within a tel URI (or presumably in a sip URI using telephone-subscriber 
syntax.)

While that *may* be an appropriate solution for some of the intended 
data, its far from clear that is the most appropriate encoding for all 
of it. Some of that information describes the caller, some the callee, 
and some describes the circumstances of a particular call. Some may even 
be determined by intermediaries. Also, some of this information may be 
appropriate for calls using non-tel URI syntax.

I do agree that determining how to convey this information is important. 
But I think presuming a tel-based solution is overreaching. I suggest 
something along the lines of:

The working group will work on the following deliverables:
1. A document defining
    - sip analogs to the ISUP parameters DAI, CPC, and OLI,
    - where/how they are provided and consumed in sip sessions
    - how they are interworked with ISUP.

2. A document specifying how these parameters are to be transported
    within sip messages. This document will define extensions to
    SIP and/or TEL URI syntax as needed to accomplish this.

	Thanks,
	Paul

Patel, Milan wrote:
> to extensions to the tel URI – specifically, parameters for carrying the 
> ------------------------------------------------------------------------
> 
> *From:* Patel, Milan
> *Sent:* Tuesday, May 25, 2010 11:16 AM
> *To:* Cullen Jennings; [email-masked]'; Robert Sparks; 
> 'Gonzalo Camarillo'
> *Cc:* [email-masked]; 'Sumanth Channabasappa'
> *Subject:* Charter proposal
> 
>  
> 
> Hi all,
> 
>  
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: "Patel, Milan" <[email-masked]>
Date: Fri, 28 May 2010 10:33:23 -0400

Hi Paul,

The approach we have taken is not unique since other URI parameters that
have previously been specified have not always been a characteristic of
the entity identified by the URI. 3GPP have sent DISPATCH a liaison
related to some of the comments that have been raised concerning the use
of a tel URI parameter for the CPC/OLI. If you are available for the
3GPP-IETF coordination call hosted by Hannu next month, I would like
this to be discussed on the call.

Regards,
Milan

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]] 
Sent: Friday, May 28, 2010 2:57 PM
To: Patel, Milan
Cc: [email-masked]; [email-masked]; Cullen Jennings
Subject: Re: [dispatch] Charter proposal for drafts related to the tel
URI

	Thanks,
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 28 May 2010 12:37:38 -0400

Patel, Milan wrote:
> the entity identified by the URI.

That doesn't make it the right thing to do.

> 3GPP have sent DISPATCH a liaison
> of a tel URI parameter for the CPC/OLI.

Can you tell me where to get a copy to read?

> If you are available for the

Maybe. Is there a particular date/time?

	Thanks,
	Paul

---

From: "WORLEY, Dale R (Dale)" <[email-masked]>
Date: Fri, 28 May 2010 12:55:29 -0400

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Paul Kyzivat [[email-masked]]

> [The proposed charter] presumes that this information should be conveyed by encoding it

I most vigorously second Paul's objection.

Let me add that the fact that 3GPP has done similar things in the past is not exactly evidence that it is the architecturally-sound solution to the problem.

dale

---

From: Janet P Gunn <[email-masked]>
Date: Fri, 28 May 2010 14:28:30 -0400

Is the scope of this working group supposed to be “North American” or 
“Worldwide”?  Because there are many national “flavors” of ISUP, there are 
many different flavors of CPC.  I think that “Equal Access” is North 
America specific.  And even within North America, it does not appear to 
apply to mobile/cell phones.  The working group needs to define its 
geographical/jurisdictional  scope, and address ways to deal with the 
differences between different versions of ISUP.
Furthermore, some CPC values are already being translated/mapped into 
specific SIP headers (e.g., RPH (RFC4412)).  The working group needs to 
address the coordination between encapsulating ISUP, mapping to URI, and 
mapping to SIP headers, especially mapping back to CPC at the “other end”.
 Is “RN” in scope or not?  It is listed in the objectives, but not in the 
deliverables.
This is at least the third time in a decade that CPC has been addressed in 
the SIP context. Each of the previous times it didn’t go very far.  I am 
curious what has changed to make it viable now. 
Nits
5th para
“The "cic" parameter defined in identifies the freephone service provider 
that serves the freephone number. “ Defined in WHAT?
6th para
“The RN parameter is used for cases where specific prefixes are used to 
rout the call through the network.” Should be …”route the call”
Janet

This is a PRIVATE message. If you are not the intended recipient, please 
delete without copying and kindly advise us by e-mail of the mistake in 
delivery. 
NOTE: Regardless of content, this e-mail shall not operate to bind CSC to 
any order or other contract unless pursuant to explicit written agreement 
or government initiative expressly permitting the use of e-mail for such 
purpose.

From:
"Patel, Milan" <[email-masked]>
To:
<[email-masked]>, <[email-masked]>, "Cullen Jennings" 
<[email-masked]>
Date:
05/28/2010 09:13 AM
Subject:
[dispatch] Charter proposal for drafts related to the tel URI

Hello,

From: Patel, Milan 
Sent: Tuesday, May 25, 2010 11:16 AM
To: Cullen Jennings; [email-masked]'; Robert Sparks; 'Gonzalo 
Camarillo'
Cc: [email-masked]; 'Sumanth Channabasappa'
Subject: Charter proposal
 
Hi all,
 
Attached is a charter proposal for a WG to be formed to handle Internet 
Drafts pertaining to the Tel URI. Specifically these are the DAI draft and 
the CPC/OLI draft and some further work on the RN parameter. 
Feedback is welcome. 
 
Kind regards,
Milan[attachment "XXXX WG charter proposal.txt" deleted by Janet P 
Gunn/USA/CSC] _______________________________________________
dispatch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dispatch

---

From: "Richard Shockey" <[email-masked]>
Date: Fri, 28 May 2010 15:01:04 -0400

Though the larger issue of how to carry these types of messages or metadata
(CNAM,CIC,SPID) in SIP has not been fully addressed either. 

Needless to say we have had a vigorous discussion over this ongoing issue in
both DRINKS and the E2MD BOF ( NGN ENUM ) list. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of WORLEY, Dale R (Dale)
Sent: Friday, May 28, 2010 12:55 PM
To: Paul Kyzivat; Patel, Milan
Cc: [email-masked]
Subject: Re: [dispatch] Charter proposal for drafts related to the tel URI

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of
Paul Kyzivat [[email-masked]]

Let me add that the fact that 3GPP has done similar things in the past is
not exactly evidence that it is the architecturally-sound solution to the
problem.

dale

---

From: Janet P Gunn <[email-masked]>
Date: Fri, 28 May 2010 15:48:39 -0400

This is at least the third time in a decade that CPC has been addressed in 
the SIP context. Each of the previous times it didn’t go very far.  I am 
curious what has changed to make it viable now 

Nits

5th para

6th para

Janet

[email-masked] wrote on 05/28/2010 09:13:05 AM:

> [image removed] 
> Patel, Milan 
> to:
> dispatch, mary.ietf.barnes, Cullen Jennings
> 
> 05/28/2010 09:13 AM
> 
> Sent by:
> 
> [email-masked]
> 
> Hello,
> 
> Attached is a charter proposal for a WG to be formed for work 
> pertaining to extensions to the tel URI – specifically, parameters 
> for carrying the DAI, CPC, OLI and RN required for primarily 
> interworking scenarios to ISUP/PSTN. 
> Feedback is appreciated. 
> Regards,
> Milan
> 
> 
> 
> From: Patel, Milan 
> Attached is a charter proposal for a WG to be formed to handle 
> Internet Drafts pertaining to the Tel URI. Specifically these are 
> the DAI draft and the CPC/OLI draft and some further work on the RN 
> parameter. 
> Feedback is welcome. 
> 
> Kind regards,

---

From: "Belling, Thomas (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 31 May 2010 13:01:03 +0200

>> related to some of the comments that have been raised concerning the 
>> use of a tel URI parameter for the CPC/OLI.

>Can you tell me where to get a copy to read?

http://www.3gpp.org/ftp/tsg_ct/WG1_mm-cc-sm_ex-CN1/TSGC1_64_Kyoto/Docs/C
1-101810.zip