Subject: [dispatch] Disaggregated media - charter proposal

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 04 May 2010 16:07:08 +0300

Folks,

after discussing the Disaggregated Media charter proposal with a few
IESG members, I have clarified and narrowed the scope of this WG-to-be.
Some people have concerns that the original proposal was too vague. This
proposal should be more specific.

Comments are welcome. I would like to get the whole IESG to review this
proposal pretty soon.

Also, we still do not have an acronym for this.

Thanks,

Gonzalo

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 04 May 2010 09:52:34 -0400

Gonzalo,

> Comments are welcome. I would like to get the whole IESG to review this

I continue to disagree with some of the assumptions implicit in how this 
is worded, though the current phrasing is less objectionable than before.

My main concerns are:

- the distinction between "loosely coupled" and "tightly coupled":
   There is an explicit assertion that tightly coupled, with a
   "master", is more difficult and expensive than "loosely coupled".
   But the only suggestions I have seen for how to do "loosely
   coupled" really just shift some of the burden from the end that
   wants to use disaggregated media to the device(s?) at the other
   end. And this also increases the difficulty of implementing
   various "features", such as transfer, hold, etc.

- deliverable number 2 (labeling multiple dialogs) presumes a
   particular outcome to deliverable number 1.

I can live with the introductory material even though I don't fully 
agree with it. But I would like to see deliverable number 1 produced 
before deciding what solution mechanisms are required.

The act of coming up with that first deliverable will provide a context 
for exploring the pros and cons of differing implementation approaches.

To be specific, how about the following deliverables, to be sequenced:

1) a disaggregated media use cases document

2) a framework for realization of the use cases, including requirements
    for new mechanisms

3) specification for any new mechanisms required by (2).

	Thanks,
	Paul

> ------------------------------------------------------------------------
> 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Tue, 4 May 2010 13:34:08 -0400

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Paul Kyzivat [[email-masked]]

To be more clear, "deliverable number 2" is a specific implementation technique, and it is the #1 feature of the current proposals that people object to.  So approving this charter proposal as it stands would beg the question regarding the most significant design choice.

Dale

---

From: "Elwell, John" <[email-masked]>
Date: Fri, 7 May 2010 17:13:53 +0200

I agree that deliverable #2 pre-supposes a particular form of solution, which until requirements are explored further, and different architectures considered, is premature.

John 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Worley, Dale R (Dale)
> Sent: 04 May 2010 18:34
> To: Paul Kyzivat; Gonzalo Camarillo
> Cc: DISPATCH
> Subject: Re: [dispatch] Disaggregated media - charter proposal
> 
> From: [email-masked] [[email-masked]] 
> On Behalf Of Paul Kyzivat [[email-masked]]
> 
> To be more clear, "deliverable number 2" is a specific 
> implementation technique, and it is the #1 feature of the 
> current proposals that people object to.  So approving this 
> charter proposal as it stands would beg the question 
> regarding the most significant design choice.
> 
> Dale

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 07 May 2010 18:56:40 +0300

Hi,

thanks for your feedback based on the feedback received, I have revised
the charter proposal (see attachment). Does this new revision address
your comments?

Thanks,

Gonzalo

---

From: "Elwell, John" <[email-masked]>
Date: Fri, 7 May 2010 18:01:27 +0200

Yes, thanks.

John 

> From: Gonzalo Camarillo [mailto:[email-masked]] 
> Sent: 07 May 2010 16:57
> To: Elwell, John; Worley, Dale R (Dale); Paul Kyzivat
> Cc: DISPATCH
> Subject: Revised proposal WAS (Re: [dispatch] Disaggregated 
> media - charter proposal)
> 
> Hi,
>

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 07 May 2010 12:11:29 -0400

Gonzalo,

Yes, this is acceptable to me.

I don't believe that a solution with no master (at least briefly) is 
possible, or important, I accept that others think so, and I'm willing 
to hear them out on it.

	Thanks,
	Paul

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 07 May 2010 19:17:12 +0300

Hi Paul,

from past discussions, people mentioned scenarios where the "master"
(i.e., the entity with complete knowledge of all the devices involved in
the session at one end) was the human user. In any case, I agree with
you that this is exactly the type of thing that should be discussed in
this WG.

Thanks,

Gonzalo

---

From: "WORLEY, Dale R (Dale)" <[email-masked]>
Date: Fri, 7 May 2010 15:45:32 -0400

________________________________________
From: Gonzalo Camarillo [[email-masked]]

Yes, that's better.

Dale