Subject: [dispatch] [IANA #1176833] Last Call: <draft-hardie-dispatch-rfc3405-update-03.txt> (Updated registration rules for URI.ARPA) to Best Current Practice

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Tue, 22 Sep 2020 20:55:37 +0000

(BEGIN IANA COMMENTS)

IESG/Authors/WG Chairs:

The IANA Functions Operator has completed its review of draft-hardie-dispatch-rfc3405-update-03. If any part of this review is inaccurate, please let us know. 

The IANA Functions Operator understands that, upon approval of this document, there is a single action which we must complete.

IANA understands that the rules for registration in the .uri.arpa zone were established by RFC3405. That document says:

"In order to be inserted into the URI.ARPA zone, the subsequent URI scheme MUST be registered under the IETF URI tree. The requirements for this tree are specified in BCP35."

IANA understands that [ RFC-to-be ] removes this normative requirement and that the new requirement is:

"All registrations in URI.ARPA MUST now be for schemes which are permanent registrations, as they are described in BCP 35."

On the .ARPA Zone Management page located at:

https://www.iana.org/domains/arpa

IANA Question --> RFC3405 is listed as the reference for the .uri.arpa zone. Upon approval of this document, should this reference be replaced with [ RFC-to-be ] or should this document be added as an additional reference?

The IANA Functions Operator understands that this is the only action required to be completed upon approval of this document.

Note:  The actions requested in this document will not be completed until the document has been approved for publication as an RFC. This message is meant only to confirm the list of actions that will be performed. 

Thank you,

Sabrina Tanamal
Senior IANA Services Specialist

(END IANA COMMENTS)

---

From: Barry Leiba <[email-masked]>
Date: Tue, 22 Sep 2020 17:07:05 -0400

Hi, Sabrina,

> "All registrations in URI.ARPA MUST now be for schemes which are permanent registrations, as they are described in BCP 35."

Correct.

> IANA Question --> RFC3405 is listed as the reference for the .uri.arpa zone. Upon approval of this document,
> should this reference be replaced with [ RFC-to-be ] or should this document be added as an additional reference?

Additional, please.

Barry

---

From: Ted Hardie <[email-masked]>
Date: Tue, 22 Sep 2020 16:25:33 -0700

Not that you need this, but I agree with Barry.  It should be additional,
because it is written as a patch to the original, not a replacement.

regards,

Ted

On Tue, Sep 22, 2020 at 2:07 PM Barry Leiba <[email-masked]> wrote:

> > "All registrations in URI.ARPA MUST now be for schemes which are
> permanent registrations, as they are described in BCP 35."
>
> Correct.
>
> > should this reference be replaced with [ RFC-to-be ] or should this
> document be added as an additional reference?
>
> Additional, please.
>
> Barry
>