Subject: [dispatch] APN presentation in DISPATCH on Monday

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Fri, 5 Mar 2021 23:28:27 +0000

Hi Folks,

Thanks to the DISPATCH Chairs and the ADs, we are going to present APN (Application-aware Networking) in the DISPATCH working group at 13:00-15:00 (UTC+1) Monday.

APN is focused on developing a framework and set of mechanisms to derive, convey and use an attribute information to allow for the implementation of fine-grain user (group)-, application (group)-, and service-level requirements at the network layer. APN works within a limited trusted domain, which typically is defined as a service provider's limited domain in which MPLS, VXLAN, SR/SRv6 and other tunnel technologies are adopted to provide services.

In the presentation, we would like to introduce the concepts, clarify the scope, attract people to understand and discuss the topic, and collect feedback and suggestions on this work, to further address the main concerns that were raised by the IESG.

For the ARTers, we would like to especially know about the new applications' trends and requirements on the network, and how the network can serve these groups/types of applications better.

Please find the latest version of the key draft, clarifying the scope and the gap analysis.
https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis-01

We have been discussing in the APN mailing list regarding the various aspects of APN. If you have not subscribed, you are very welcome to subscribe. You can also find the archived discussions.
https://datatracker.ietf.org/wg/apn/about/

More information about APN can be found here.
https://github.com/APN-Community

Best Regards,
Shuping

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Thu, 11 Mar 2021 03:09:30 +0000

Hi Folks,

Many thanks for your very valuable discussions and feedback on the APN presentation in the ARTAREA on Monday!

When going through the discussions in the Jabber room, we found that some similar questions have been frequently asked, so we summarized a list of FAQs as below to further clarify the confusions and concerns. Your review and feedback will be very much welcomed and appreciated. Thank you!

1. Are there any applications that can benefit from APN?
I would like to ask how many of us have experienced the Meetecho issues in this IETF and the virtual ones before. This is one of the applications that can benefit from APN. :)

In this IETF, we had a hackathon "Application-aware G-SRv6 networking", which shows the improvements that can be achieved with APN, using which the traffic is steered into the appropriate SRv6 path [1]. The results are going to be presented and demonstrated in the INFOCOM2021. There was also the first demonstration of APN in the INFOCOM2020 [2].

[1]https://github.com/APN-Community/IETF-110-Hackathon-Demo/blob/master/Application-aware_G-SRv6_networking__Demo_and_Test.pdf
[2]https://ieeexplore.ieee.org/abstract/document/9162934

2. How APN can help resolve the QoE issues?
As shown in the APN demonstrations, we can see the differences/improvements which APN can make in the network. QoE is complex and has many impacting factors including the terminal, access, and network. APN aims to provide ways to improve the QoE within the network.

3. Who is to set the APN attribute?
It is the network edge device such as CPE (Customer Premises Equipment) not the application.

4. How to set the APN attribute?
There are many possible ways that can be used to classify the traffic flow at the network edge, e.g., the N-tuples as defined in the MEF70 and the AI technologies. An APN attribute can be derived by using the match items published in MEF70 as well as the access port in the edge device.

5. How the APN attribute is used in the network?
The APN attribute is carried in the data packet's header, and it can be used in the various nodes/service functions along the network path to enforce the policies on the differentiated traffic flow, e.g.,
1) at the headend to steer into corresponding path satisfying SLAs
2) at the midpoint to collect corresponding performance measurement data
3) at the service function to execute particular policies

Best regards,
Shuping

From: Pengshuping (Peng Shuping)
Sent: Saturday, March 6, 2021 7:28 AM
To: [email-masked]' <[email-masked]>
Cc: [email-masked]
Subject: APN presentation in DISPATCH on Monday

Hi Folks,

Best Regards,
Shuping