Subject: Re: [dispatch] [sipcore] Exception in RFC 3261 document

From: Liviu Chircu <[email-masked]>
Date: Mon, 20 Dec 2021 19:19:07 +0200

On 19.12.2021 15:10, Mojtaba Esfandiari.S wrote:
> *"When a UAC resubmits a request with its credentials after receiving 
> a 401 (Unauthorized) or 407 (Proxy Authentication Required) response, 
> it MUST increment the CSeq header field value as it would normally 
> when sending an updated request."*

But that's as arbitrary of a CSeq as it can be, right?  As I read 
8.1.1.5, the caller is simply free to choose their own starting CSeq.  
It can be the number *1* for all initial requests it ever builds - the 
server should still play along.

Best Regards,

-- 
Liviu Chircu
www.twitter.com/liviuchircu | www.opensips-solutions.com

---

From: Liviu Chircu <[email-masked]>
Date: Tue, 21 Dec 2021 06:55:02 +0200

On 20.12.2021 23:59, Mojtaba Esfandiari.S wrote:
> The UE sends its request to Sems, then Sems relay the request to 
> Asterisk server. because in all INVITE messages, the Sems used the 
> same CSeq value (CSeq: 10 INVITE), asterisk goes to LOOP for 
> authentication UE.

Then the UE is not RFC 3261-compliant, as it is disobeying the 
additional restrictions of § 22.2.

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 21 Dec 2021 20:06:36 +0000

Hi Mojtaba,

After an initial thought, your suggested clarification to section 8.1.1.5 seems correct. It could perhaps be more generic, though, and e.g.,say that specific procedures may define rules regarding the CSeq value. The 401/407 case could then be mentioned as an example.

In any case, may I suggest that you send your issue to the SIPCORE list?

Regards,

Christer

From: sipcore <[email-masked]> On Behalf Of Mojtaba Esfandiari.S
Sent: tiistai 21. joulukuuta 2021 12.19
To: Liviu Chircu <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [sipcore] Exception in RFC 3261 document

Actually, the UE is obeying the RFC 3261, But the SEMS project is not RFC 3261 compliant.
It occurs because for 401 (Unauthorized) or 407 (Proxy Authentication Required) response, the value of CSeq does not change.
So for more clarity and more understanding, It would be nice to have a quiet bit of update in RFC 3261 section 8.1.1.5.
For example, the word "arbitrary" in the CSeq value may be confused with the same value as before.
Thanks

On Tue, Dec 21, 2021 at 8:25 AM Liviu Chircu <[email-masked]<mailto:[email-masked]>> wrote:

--
Liviu Chircu
www.twitter.com/liviuchircu<https://protect2.fireeye.com/v1/url?k=31323334-501d5122-313273af-454445555731-742427605f27b27a&q=1&e=15584eeb-52e0-4596-a64d-ab25cbbb7dcb&u=http%3A%2F%2Fwww.twitter.com%2Fliviuchircu> | www.opensips-solutions.com<https://protect2.fireeye.com/v1/url?k=31323334-501d5122-313273af-454445555731-db93e02ae851094d&q=1&e=15584eeb-52e0-4596-a64d-ab25cbbb7dcb&u=http%3A%2F%2Fwww.opensips-solutions.com%2F>