Subject: Re: [dispatch] SMTP Code for Undesirable Messages

From: Anton Tveretin <[email-masked]>
Date: Sun, 26 Dec 2021 04:06:00 +0500

Hello Alex,

I think it is sometimes a good idea. But the problem is that spammers sometimes use this kind of feedback to check for valid addresses. For this reason, some implementers would avoid this feedback. Also, a check for spam need not complete immediately. The incoming message might be bounced later.

Sincerely yours,

Anton

--

Date: Fri, 17 Dec 2021 17:04:46 +0000
From: "Brotman, Alex" <[email-masked]>
To: "[email-masked]" <[email-masked]>
Subject: [dispatch] SMTP Code for Undesirable Messages
Message-ID:
<[email-masked]>

Content-Type: text/plain; charset="us-ascii"

Hello,

I've been wondering if it may be beneficial for a mailbox provider to be able to signal back to the sender that the message is being accepted, but is undesirable based on some criteria. The idea would be that a provider may evaluate some characteristics of the message, and before issuing a "250 Ok" have already determined the message would be routed to the spam folder. Something as simple as:

255 Ok - Routing to spam folder

This would likely need some "Security Considerations" section about how informing a malicious entity may be undesirable. I'm willing to write this up as a proposed draft, though I'm not entirely sure where to direct that draft. Thank you for any advice you could provide.

--
Alex Brotman
Sr. Engineer, Anti-Abuse & Messaging Policy
Comcast

---

From: "Brotman, Alex" <[email-masked]>
Date: Sun, 26 Dec 2021 06:55:50 +0000

Anton,

Thanks for the feedback.  I understand the potential abuse implications, though spammers already have many methods to test efficacy.  The server side could exhibit control over whether or not to provide this feedback (not in ACL, or poor IP reputation, etc). The goal is to provide receivers with an standardized option to provide feedback in a more real-time fashion, should they choose to do so.  This could help senders detect and stop outbound abuse they've previously missed.

--
Alex Brotman
Sr. Engineer,  Anti-Abuse & Messaging Policy
Comcast
________________________________
From: Anton Tveretin <[email-masked]>
Sent: Sunday, December 26, 2021 12:06:00 AM
To: Brotman, Alex <[email-masked]>
Cc: DISPATCH list <[email-masked]>
Subject: [EXTERNAL] Re: [dispatch] SMTP Code for Undesirable Messages

Hello Alex,

--
Date: Fri, 17 Dec 2021 17:04:46 +0000
From: "Brotman, Alex" <[email-masked]<mailto:[email-masked]>>
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [dispatch] SMTP Code for Undesirable Messages
Message-ID:
        <[email-masked]<mailto:[email-masked]>>

Hello,