Subject: Re: [dispatch] IPv6 Zone Identifiers in URIs (RFC6874bis)

From: Brian E Carpenter <[email-masked]>
Date: Fri, 18 Feb 2022 08:58:47 +1300

FYI, we have recently updated this draft at
https://www.ietf.org/archive/id/draft-carpenter-6man-rfc6874bis-03.html

We opened discussion with various people in the browser community, but
did not find much enthusiasm for implementation. Until there is a great
increase in demand for link-locals to be supported by browsers, the
necessary work seems unlikely to be done.

However, we believe that this demand will eventually arise and therefore
it's important that the relevant URI syntax is well-defined. There is a
significant change in this version. Following the discussions a few months
ago, and after I spent some time looking into the URI parsers in wget and
Firefox (and a brief look at curl), we propose to drop the "%25" encoding
of "%". The ABNF in this version, originally suggested by Andrew Cady,
reflects that proposal. There is extra explanation in the text.

The other signficant change is that, as Martin Dürst pointed out, we
also need to formally update the IRI syntax. That was an omission in
RFC6874.

We are not asking for action by DISPATCH, but of course we'd welcome
feedback.

Regards
    Brian Carpenter
On 09-Jul-21 15:46, Brian E Carpenter wrote:
> Hi,
> 
> Bob Hinden and I are working on an update to RFC 6874, "Representing IPv6 Zone Identifiers in Address Literals and Uniform Resource Identifiers":
> https://datatracker.ietf.org/doc/draft-carpenter-6man-rfc6874bis/
> There will be an updated version before the cutoff, and there has
> been quite a bit of discussion already at
> https://mailarchive.ietf.org/arch/browse/ipv6/.
> 
> We expect this to be processed in 6MAN, as RFC 6874 was, but we would like to briefly introduce it to DISPATCH/ART Area since clearly it is not just an Internet Area topic. We're also very much aware that it needs to be looked at by the browser community.
> 
> So this is a request for a short slot to raise awareness. We're not quite sure who would be presenting due to time zone and agenda clash challenges.
> 
> Please keep us in Cc as we are not on the DISPATCH list.
>

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 22 Feb 2022 10:48:45 +1100

If we know it's not going to be implemented by browsers for the foreseeable future and we still choose to publish something, it should be clearly marked as what's effectively a hope-based standard.

Cheers,

> On 18 Feb 2022, at 6:58 am, Brian E Carpenter <[email-masked]> wrote:
> 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

--
Mark Nottingham   https://www.mnot.net/

---

From: Bob Hinden <[email-masked]>
Date: Mon, 21 Feb 2022 16:01:13 -0800

Mark,

Another way to look at it is “if you are going to support it, do it this way”.

Bob

> On Feb 21, 2022, at 3:48 PM, Mark Nottingham <[email-masked]> wrote:
>

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 22 Feb 2022 11:04:49 +1100

Sure. But if it's going to be an RFC, many will read that and expect it to be supported by browsers. If browsers aren't involved in creating it and decline to implement, it should set reasonable expectations.

> On 22 Feb 2022, at 11:01 am, Bob Hinden <[email-masked]> wrote:
> 
> Mark,
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 22 Feb 2022 14:09:59 +1300

Yes, we can add a sentence or two to make that clear.

Regards
    Brian

On 22-Feb-22 13:04, Mark Nottingham wrote:
> Sure. But if it's going to be an RFC, many will read that and expect it 
to be supported by browsers. If browsers aren't involved in creating it and decline to implement, it should set reasonable expectations.
>>>>> We expect this to be processed in 6MAN, as RFC 6874 was, but we would like to briefly introduce it to DISPATCH/ART Area since clearly it is not just an Internet Area topic. We're also very much aware that it needs 
to be looked at by the browser community.
>>>>> So this is a request for a short slot to raise awareness. We're not 
quite sure who would be presenting due to time zone and agenda clash challenges.