Subject: [Diversity] IETF Guidelines for Conduct - draft-moonesamy-ietf-conduct-3184bis

From: Brian Trammell <[email-masked]>
Date: Mon, 2 Sep 2013 12:34:19 +0200

hi SM,

+1 to thanks for writing this draft. 

I'd like to second previous comments with regard to "slang", that such is merely a symptom of not communicating clearly: slang, higher- or lower-register speech, formal jargon designed to be impenetrable, etc, are all such symptoms, and we should try to address the cause rather than listing the effects. In my experience, network engineers as a class are not necessarily gifted with clarity, even in their own languages, but a reminder to try is certainly useful.

There is one very important point though, that I think is missing from the draft, though it has been raised in the discussion:

The IETF operates on rough consensus. 

From my viewpoint, this is probably the most important aspect of IETF culture (especially as it differs from many other engineering cultures), and should probably be made more central to point 3 than it is now. Indeed, the word consensus only appears in the introduction of revision -01, 

There are sound technical reasons behind this aspect of the culture: briefly, systems designed by committees where every member has an effective veto -- "complete consensus" processes -- tend to be overly complex and to compromise on technical requirements where they shouldn't, and therefore difficult or practically impossible to implement correctly. On the other end of the spectrum, "single architect" systems tend to be more coherent (at least within the limits of the abilities of the architect), but can suffer from the limited viewpoint of the single architect and tend to have less thorough review. We've evolved something in the middle, and it seems (to me, anyway) to work well: we get the quality of review of many technically skilled people that comes with good committee processes, while avoiding the complexity and compromise inherent in complete consensus.

All the subparts of point 3 are important - especially "we're looking for the best solution for the whole Internet, not just... for any particular...". However, this is partially at odds with rough consensus, in that rough consensus building does require compromise and often involves arbitrary choice among equally-good options. Holding out for "the best solution" here seems to invite precisely the blocking of the process that rough consensus is designed to avoid.

I'd suggest the following text for point 3 (also de-emphasizing scale, which is important but perhaps a little out of scope here IMO.)

NEW:

3. IETF participants devise solutions for the Internet that meet the needs of diverse technical and operational environments.

The goal of the IETF is to maintain and enhance a global Internet, and the problems we encounter are genuinely very difficult.  IETF participants use their best engineering judgment to work toward consensus for the best solution for the whole Internet, balancing the technical concerns of all participants, not just the best solution for any particular network, technology, vendor, or user.  We understand that "scaling is the ultimate problem" and that many ideas that seem workable at smaller scales fail this crucial test.

Best regards,

Brian

---

From: S Moonesamy <[email-masked]>
Date: Mon, 02 Sep 2013 08:19:02 -0700

Hi Brian,
At 03:34 02-09-2013, Brian Trammell wrote:
>I'd like to second previous comments with regard to "slang", that 
>such is merely a symptom of not communicating clearly: slang, 
>higher- or lower-register speech, formal jargon designed to be 
>impenetrable, etc, are all such symptoms, and we should try to 
>address the cause rather than listing the effects. In my experience, 
>network engineers as a class are not necessarily gifted with 
>clarity, even in their own languages, but a reminder to try is 
>certainly useful.

I'll highlight a point from the above:

   "jargon designed to be impenetrable"

Sometimes a person might be using the jargon because he or she sees 
other people doing it.  It might also be that it's easier (shorter 
way of expressing a thought).  Sometimes it might be because it won't 
be understood by a layman (see point above).

I agree that nowadays network engineers are not gifted with clarity 
even in their own language.

I proposed the following text to replace the sentence about slang:

    Native English participants attempt to accommodate the needs of other
    participants by communicating clearly.

>There is one very important point though, that I think is missing 
>from the draft, though it has been raised in the discussion:
>
> From my viewpoint, this is probably the most important aspect of 
> IETF culture (especially as it differs from many other engineering 
> cultures), and should probably be made more central to point 3 than 
> it is now. Indeed, the word consensus only appears in the 
> introduction of revision -01,
>
>There are sound technical reasons behind this aspect of the culture: 
>briefly, systems designed by committees where every member has an 
>effective veto -- "complete consensus" processes -- tend to be 
>overly complex and to compromise on technical requirements where 
>they shouldn't, and therefore difficult or practically impossible to 
>implement correctly. On the other end of the spectrum, "single 
>architect" systems tend to be more coherent (at least within the 
>limits of the abilities of the architect), but can suffer from the 
>limited viewpoint of the single architect and tend to have less 
>thorough review. We've evolved something in the middle, and it seems 
>(to me, anyway) to work well: we get the quality of review of many 
>technically skilled people that comes with good committee processes, 
>while avoiding the complexity and compromise inherent in complete consensus.

Agreed.

>All the subparts of point 3 are important - especially "we're 
>looking for the best solution for the whole Internet, not just... 
>for any particular...". However, this is partially at odds with 
>rough consensus, in that rough consensus building does require 
>compromise and often involves arbitrary choice among equally-good 
>options. Holding out for "the best solution" here seems to invite 
>precisely the blocking of the process that rough consensus is 
>designed to avoid.

Agreed.

The above is insightful.

>I'd suggest the following text for point 3 (also de-emphasizing 
>scale, which is important but perhaps a little out of scope here IMO.)
>
>NEW:
>
>3. IETF participants devise solutions for the Internet that meet the 
>needs of diverse technical and operational environments.
>
>The goal of the IETF is to maintain and enhance a global Internet, 
>and the problems we encounter are genuinely very difficult.  IETF 
>participants use their best engineering judgment to work toward 
>consensus for the best solution for the whole Internet, balancing 
>the technical concerns of all participants, not just the best 
>solution for any particular network, technology, vendor, or 
>user.  We understand that "scaling is the ultimate problem" and that 
>many ideas that seem workable at smaller scales fail this crucial test.

I like the text you suggested.  I'll add it to my working copy.

Regards,
S. Moonesamy

---

From: Brian Trammell <[email-masked]>
Date: Mon, 2 Sep 2013 17:44:25 +0200

hi SM,

On 2 Sep 2013, at 17:19 , S Moonesamy <[email-masked]> wrote:

> Sometimes a person might be using the jargon because he or she sees other people doing it.  It might also be that it's easier (shorter way of expressing a thought).  Sometimes it might be because it won't be understood by a layman (see point above).

Here I was referring to a disease specific to academia where simple ideas are often disguised in math to make them look more impressive. Jargon designed to be precise is actually a good thing: there's a reason our documents have terminology sections. :)

> I agree that nowadays network engineers are not gifted with clarity even in their own language.
> 

Tiny nit: the above reads a little ambiguously, and could be interpreted as referring to participants born in England, which is clearly not what you mean. It also absolves speakers of English as a second language from the responsibility of communicating clearly, which I hope is also not what you mean. Anecdotally years of working in a country where essentially everyone speaks English as a second language have taught me that ability to speak English and ability to communicate clearly in English are far less linked than I'd have originally thought.

I'd suggest "All participants attempt to accommodate the needs of others by communicating clearly, particularly those with English as a first language", instead.

Best regards,

Brian

> _______________________________________________
> diversity mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/diversity

---

From: S Moonesamy <[email-masked]>
Date: Mon, 02 Sep 2013 11:47:46 -0700

Hi Brian,
At 08:44 02-09-2013, Brian Trammell wrote:
>Here I was referring to a disease specific to academia where simple 
>ideas are often disguised in math to make them look more impressive. 
>Jargon designed to be precise is

The IETF has a somewhat similar disease. :-)

>Tiny nit: the above reads a little ambiguously, and could be 
>interpreted as referring to participants born in England, which is 
>clearly not what you mean. It also absolves speakers of English as a 
>second language from the responsibility of communicating clearly, 
>which I hope is also not what you mean. Anecdotally years of working 
>in a country where essentially everyone speaks English as a second 
>language have taught me that ability to speak English and ability to 
>communicate clearly in English are far less linked than I'd have 
>originally thought.

I was looking for a replacement for "native English 
speakers".  Thanks for providing an explanation for the suggested 
text.  It is easier to make a change when it is accompanied by an explanation.

>I'd suggest "All participants attempt to accommodate the needs of 
>others by communicating clearly, particularly those with English as 
>a first language", instead.

I added the above suggested text to my working copy.  I dropped the "all".

Regards,
S. Moonesamy

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 2 Sep 2013 20:28:36 -0500

On Monday, September 2, 2013, S Moonesamy wrote:

>  I'd suggest "All participants attempt to accommodate the needs of others
>> by communicating clearly, particularly those with English as a first
>> language", instead.
>>
>

For what it's worth, I'm reading "particularly those ..." as bound to "others",
and not "participants". Is that what's intended?

If not, perhaps "participants, particularly those with English as a first
language, attempt ..."?

Spencer

---

From: Brian Trammell <[email-masked]>
Date: Tue, 3 Sep 2013 07:18:21 +0200

hi Spencer,

On Sep 3, 2013, at 3:28 AM, Spencer Dawkins at IETF <[email-masked]> wrote:

> For what it's worth, I'm reading "particularly those ..." as bound to "others", and not "participants". Is that what's intended?
> 
> If not, perhaps "participants, particularly those with English as a first language, attempt ..."?

Yep, that's better.

Cheers,

Brian

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 3 Sep 2013 07:02:20 +0000

> I'd suggest "All participants attempt to accommodate the needs of others by communicating clearly, particularly those with English as a first language", instead.

+1

I believe I'm pretty decent at parsing different accents (incl. my own :-) but it is harder when non-native speakers speak very fast.

And we really need to bash folks like Ekr who simply refuse to speak slowly.

Lars

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Tue, 3 Sep 2013 09:27:02 -0400

This sounds good.  As a reminder, it is not easy for everyone to make the adjustment to speaking at a pace that is easy for an international audience to parse, while being articulate.  I would suggest reminders, rather than bashing.  I am often complimented on my ability to speak articulately and at a pace that is easy to understand.  This is something I have learned over time through many interactions and am cognizant of this requirement.  I do think it is an adjustment and that some, even with exposure, will require gentle reminders. 

Cut Ekr some slack, he has made a conscience effort to slow down since I started doing work in the IETF.  He also did a fantastic job when I introduced him to someone from Japan interested in crypto at a meeting.  

Gentle reminders may be a constant state as I don't think this adjustment comes easily to all.

Thank you,
Kathleen
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Eggert, Lars [[email-masked]]
Sent: Tuesday, September 03, 2013 3:02 AM
To: Brian Trammell
Cc: <[email-masked]>; S Moonesamy
Subject: Re: [Diversity] IETF Guidelines for Conduct    -       draft-moonesamy-ietf-conduct-3184bis

+1

Lars

---

From: S Moonesamy <[email-masked]>
Date: Tue, 03 Sep 2013 07:53:31 -0700

Hello,

This is the text I have now:

  Participants, particularly those with English as a first language, attempt
  to accommodate the needs of other participants by communicating clearly.

There was a comment about the above:

   Except for the part between the commas it's great. As written, it presumes
   that a mis-communication between a native speaker of English and someone who
   isn't is the fault of the native speaker.  I don't think this is 
appropriate.

Feedback about the text and comment is welcome.

Regards,
S. Moonesamy

---

From: Spencer Dawkins <[email-masked]>
Date: Tue, 03 Sep 2013 10:04:16 -0500

> Feedback about the text and comment is welcome.

For Scott - the text recently dropped "All", as in "All participants". 
Would that make any difference in the way you are reading it?

I'm not reading it the way Scott's reading it, but I might be the only 
one who's not.

Spencer

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 3 Sep 2013 15:11:49 +0000

>    isn't is the fault of the native speaker.  I don't think this is appropriate.
> 

Here's my suggestion:
IETF participants need to accommodate the needs of other participants by communicating clearly. Examples of such needs are English being a second language, lack of familiarity with various region-specific English pronunciation or phrases, and hearing disabilities.

Barbara

---

From: Juliao Braga <[email-masked]>
Date: Tue, 03 Sep 2013 12:48:57 -0300

+1

I think it is very clear and also "accommodates" all expectations seen
so far.

Juliao

Em 03/09/2013 12:11, STARK, BARBARA H escreveu:
> Here's my suggestion: IETF participants need to accommodate the needs
> of other participants by communicating clearly. Examples of such needs
> are English being a second language, lack of familiarity with various
> region-specific English pronunciation or phrases, and hearing
> disabilities.

---

From: S Moonesamy <[email-masked]>
Date: Tue, 03 Sep 2013 09:29:09 -0700

At 08:04 03-09-2013, Spencer Dawkins wrote:
>For Scott - the text recently dropped "All", as in "All 
>participants". Would that make any difference in the way you are reading it?
>
>I'm not reading it the way Scott's reading it, but I might be the 
>only one who's not.

I should not have dropped the "all". :-)

I am looking at that text as a general guideline.  It is not about 
finding fault.

At 08:11 03-09-2013, STARK, BARBARA H wrote:
>Here's my suggestion:
>IETF participants need to accommodate the needs of other 
>participants by communicating clearly. Examples of such needs are 
>English being a second language, lack of familiarity with various 
>region-specific English pronunciation or phrases, and hearing disabilities.

Barbara, thanks for suggesting text and thanks to Juliao for the feedback.

Here's the entire paragraph from my working copy:

   "English is the de facto language of the IETF.  However, it is not 
the native
    language of many IETF participants.  Participants, particularly those with
    English as a first language, attempt to accommodate the needs of other
    participants by communicating clearly."

The intent of the text is: IETF work is done in English.  We leave 
that as it is instead of discussing what should be the language of 
the IETF.  People who use English as their first language and can 
communicate clearly have an advantage.  The "particularly" is a 
request to these people to try and accommodate the needs of other participants.

The text did not get into pronunciation as I was trying to cover 
verbal and written communication.  I am not trying to tackle 
disabilities in the draft as that opens another debate.  If there is 
someone with hearing disabilities it would be appreciated if the 
group is understanding and attempts to accommodate that person.

I like the text suggested by Barbara as it offers another alternative 
which I did not think about.  I consider the text in the draft as an 
open issue as people are reading it differently (see what Spencer wrote).

Regards,
S. Moonesamy

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 5 Sep 2013 03:09:15 +0200

Hi Moonesamy,

The problem I get very much in IETF Lists/Langauges from native
speakers is the informal language/vocabularies, usually IETF use
written-drafts in formal language as is done in international
science/engineering/knowledge languages, but informal is more social
which is also done in IETF lists/meetings. However, if non-native
tries to write in his informal way he/she will get messages of
unclear, but informal English is not English as well in my opinion. In
history Africans have spoken English language in North America in
their way which was a special informal way different than others came
from France or Spain or England, each had their own informal language
(but all understood by people their because they all tried to
socialise).

AB

---

From: S Moonesamy <[email-masked]>
Date: Thu, 05 Sep 2013 01:26:15 -0700

Hi Abdussalam,
>(but all understood by people their because they all tried to

An interesting point in the above is that informal is more social.  A 
conversation can also be faster when both parties know each 
other.  In my opinion it would be better if the person using English 
as a second language avoids writing in an informal way so that 
his/her message is not unclear.

Was your message written in a formal or informal way?

Regards,
S. Moonesamy